JeremyNicoll

Settings greyed-out in EIS 2017.1.0.7138

Recommended Posts

I noticed settings were greyed-out in this new version of EIS, an hour or two ago.  Since then I've done a complete/cold shutdown and reboot, and the same situation continues.  Any clues?

Oh... and it's still not possible to c&p a version number from the About screen.  Why's it so hard for you to make simple changes like that?

Share this post


Link to post
Share on other sites

Ah, I see it's the new permissions system.    But, after signing-out from my ordinary user and in as an Admin id (under W8.1), and using the EIS GUI under the Admin id to grant my ordinary user 'full access', when I signed out of the Admin id and back in as the ordinary user, although I see that the greyed-out stuff is now accessible again, it DOESN'T get the full access that the Admin id had.  In particular there's no Permissions tab at all. 

 

The explanation at: http://blog.emsisoft.com/2017/02/01/introducing-emsisoft-product-updates-new-versioning-scheme/  does not say that that difference will exist (I used the 'Custom' feature to specify 'Full Access' for my ordinary id).

Share this post


Link to post
Share on other sites

I'm facing the same issue with EAM 2017.1.0.7138 under W10. Using my regular domain account, that has local admin rights on my system (is part of the Administrators group) the Permissions settings is not accessible, the tab is not showing at all. Changing to my local admin account I can access all the settings (my domain account is not shown on the list at all), but not with my regular domain account - despite I've changed the "All other users" default permission to Full access.

Using a workaround actually I can access almost all of the settings (except the permissions) also with my regular account: reinstalling an older version in airplane mode I have set up an admin password on the Permissions tab. After going online and the auto-update of EAM but before the restart I've temporarily disabled the protection. After the restart, I've tried to enable the protection and EAM asked for the previously set password. Now on the Overview page the "Admin mode" flag is turned green, and the settings are now not greyed out...

It's just a workaround, but I've already reported the issue by email [#LRJ-851-52002]. I hope, they will sort out this issue soon.

Andras

Share this post


Link to post
Share on other sites
5 hours ago, szaszandras said:

... After the restart, I've tried to enable the protection and EAM asked for the previously set password. Now on the Overview page the "Admin mode" flag is turned green, and the settings are now not greyed out...

Access to "Admin mode" was given without entering the password?

 

As for the issue at hand, I have asked our QA Manager about the permissions settings only being accessible for the Administrator account.

Share this post


Link to post
Share on other sites
3 hours ago, GT500 said:

Access to "Admin mode" was given without entering the password?

No, I had to enter the password.

The problem is, that using my regular domain account I can now only control EAM with the password despite being the member of the Administrators group on this system.

Share this post


Link to post
Share on other sites
11 hours ago, szaszandras said:

No, I had to enter the password.

OK, then that is working as intended. Once the password is entered, the admin mode is unlocked.

 

As for the issue with accounts not being able to access the Permissions settings, we're going to need some debug logs. Here's what to do (the below instructions are the same for EIS and EAM):

  1. Open Emsisoft Internet Security from the icon on your desktop.
  2. In the 4 little gray boxes at the bottom, move your mouse into the one that says Support, and click anywhere in that gray box.
  3. At the bottom, turn on the option that says Enable advanced debug logging.
  4. Either click on Overview in the menu at the top, or close the Emsisoft Internet Security window.
  5. Reproduce the issue you are having (log in as a user that is in the Administrators group, and then verify that the Permissions in EIS are not accessible).
  6. Once you have reproduced the issue, open Emsisoft Internet Security again, and click on the gray box for Support again.
  7. Click on the button that says Send an email.
  8. Select the logs in the left that show today's dates.
  9. Fill in the e-mail contact form with your name, your e-mail address, and a description of what the logs are for (if possible please leave a link to the topic on the forums that the logs are related to in your message).
  10. If you have any screenshots or another file that you need to send with the logs, then you can click the Attach file button at the bottom (only one file can be attached at a time).
  11. Click on Send now at the bottom once you are ready to send the logs.

Important: Please be sure to turn debug logging back off after sending us the logs. There are some negative effects to having debug logging turned on, such as reduced performance and wasting hard drive space, and it is not recommended to leave debug logging turned on for a long period of time unless it is necessary to collect debug logs.

Please note that if you have a lot of debugs logs, then you should not send all of them. There is a size limit, and currently there is no error if the message is rejected due to the size being too large. Normally we only need one copy of the 4 or 5 different logs that have been saved after the time you reproduced the issue (the list shows what time each log was saved). Those logs have the following names:

  • Security Center
  • Protection Service
  • Real-Time Protection
  • Firewall
  • Logs database (contains the logs you can view in Emsisoft Internet Security by clicking on Logs at the top of the window).

Share this post


Link to post
Share on other sites

Thank you Jeremy.

Both of you have already been told this privately, however I will post it here as well for anyone who might have the same issue and find this forum topic. Currently this is functioning as intended. Since some users are obviously having issues with this functionality, I have recommended to our QA Manager that we consider changing how this works.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.