Jump to content

Update rule doesn't work for Universal Apps


M.Sadegh.M
 Share

Recommended Posts

Hello Emsisoft team;

 

I'm using some of universal app in my pc and every time I updating one of them I should answer to firewall (I set that firewall ask question about every connection) and BB question again and Update rule doesn't work for UWP app.

Is it a bug? or maybe it's only my problem. Please Help me to find a way because answer to this question and editing this rule again as I wanted to be is very time consuming .

 

Thank you;

Link to comment
Share on other sites

Are you seeing the alerts warning you that a program has been updated even though you have the option enabled not to see those warnings for the program in question, or are you seeing some other type of alert/notification?

Link to comment
Share on other sites

Every time after Update same boring question.

for example I Set MSN weather "allow All Connection" for both: incoming and outcoming.

but after update MSN weather, EIS alerted me that this App want to connect to network.

This happened exactly for BB.

Untitled.png

Link to comment
Share on other sites

On 3/18/2017 at 4:51 AM, M.Sadegh.M said:

but after update MSN weather, EIS alerted me that this App want to connect to network.

I'll let our QA team know about this. We may need some debug logs, so I'll let you know if they ask for them.

Link to comment
Share on other sites

OK, we'll probably need some debug logs. Here's how to get debug logs (note that debug logging turns off automatically after 7 days):

  1. Open Emsisoft Internet Security from the icon on your desktop.
  2. In the 4 little gray boxes at the bottom, move your mouse into the one that says Support, and click anywhere in that gray box.
  3. At the bottom, turn on the option that says Enable advanced debug logging.
  4. Either click on Overview in the menu at the top, or close the Emsisoft Internet Security window.
  5. Reproduce the issue you are having (do whatever is necessary to cause the firewall alerts that you believe you shouldn't be seeing).
  6. Once you have reproduced the issue, open Emsisoft Internet Security again, and click on the gray box for Support again.
  7. Click on the button that says Send an email.
  8. Select the logs in the left that show today's dates.
  9. Fill in the e-mail contact form with your name, your e-mail address, and a description of what the logs are for (if possible please leave a link to the topic on the forums that the logs are related to in your message).
  10. If you have any screenshots or another file that you need to send with the logs, then you can click the Attach file button at the bottom (only one file can be attached at a time).
  11. Click on Send now at the bottom once you are ready to send the logs.

Important: Please be sure to turn debug logging back off after sending us the logs. There are some negative effects to having debug logging turned on, such as reduced performance and wasting hard drive space, and it is not recommended to leave debug logging turned on for a long period of time unless it is necessary to collect debug logs.

Please note that if you have a lot of debugs logs, then you should not send all of them. There is a size limit, and currently there is no error if the message is rejected due to the size being too large. Normally we only need one copy of the 4 or 5 different logs that have been saved after the time you reproduced the issue (the list shows what time each log was saved). Those logs have the following names:

  • Security Center
  • Protection Service
  • Real-Time Protection
  • Firewall
  • Logs database (contains the logs you can view in Emsisoft Internet Security by clicking on Logs at the top of the window).

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 months later...

I would believe this issue is fixed in the latest beta. Here's how to install it, if you have not already done so:

  1. Open Emsisoft Internet Security.
  2. Click on Settings in the menu at the top.
  3. Click on Updates in the menu at the top.
  4. On the left, under Update Settings, click on the box to the right of Update feed and select Beta from the list.
  5. Click on the Update now button on the right side.

Link to comment
Share on other sites

  • 3 weeks later...
Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...