wonexams

block Chrome Remote Desktop?

Recommended Posts

Will Emisoft Internet Security block Chrome Remote Desktop?
I can't connect to my home PC now.

Thank you for this good software, I love its UI.


Microsoft Windows 10 Home 64-bit 1607 14393.1198
Google Chrome 58.0.3029.110 (64-bit)
Emisoft Internet Security 2017.4.1.7484

Share this post


Link to post
Share on other sites

Technically a firewall will block remote access software, however many remote access software have ways around firewalls. You may have to create a rule in the firewall to allow Chrome Remote Desktop. Do you know the port number it is configured to use?

Share this post


Link to post
Share on other sites

on this page (Google Chrome Help)
https://support.google.com/chrome/answer/1649523?co=GENIE.Platform%3DDesktop&hl=en

there is a Troubleshooting tips at the bottom, and it says:

Antivirus software might prevent you from using Chrome Remote Desktop. Make sure your antivirus allows the following:

  • Outbound UDP traffic
  • Inbound UDP responses
  • Traffic on TCP ports 443 (HTTPS) and 5222 (XMPP)

 

but I don't know how to configure Emsisoft Internet Security

Share this post


Link to post
Share on other sites

They can't simply tell you to allow all UDP traffic. That's ridiculous. They need to specify either the port numbers the software uses, or the port range.

Anyway, for the TCP ports, here's how to create a Firewall rule to allow them:

  1. Open Emsisoft Internet Security.
  2. Click on Protection.
  3. Click on Firewall in the menu at the top.
  4. Click the Add rule button near the lower-right.
  5. Give the rule a name so that it is easy to identify what it does when looking through the list of firewall rules.
  6. Make sure the Action is set to 'Allow'.
  7. Assuming this is on the computer you are trying to connect to, set Direction to IN.
  8. Set Protocol to TCP.
  9. Enter your port number in the field for Ports (you can enter multiple port numbers if you separate them with commas, such as 443,5222 for instance).
  10. You can set Addresses to All, however this may be a security risk, so I recommend setting it for only specific addresses and then entering the IP address of the computer that is going to be connecting (multiple addresses can be entered if separated by commas).
  11. Click OK at the bottom to save your new firewall rule.
  12. Click on your new firewall rule in the list to select it.
  13. Click the Move up button to move your new firewall rule above the two block rules at the bottom of the list.

If the computer that needs to connect is a remote computer (a computer at another location), then you can find the IP address by logging in to that computer and visiting the following link:

https://start.duckduckgo.com/?q=IP&ia=answer

If you prefer Google, then you can get the same information from them:

https://www.google.com/#q=IP

 

If the computer that you will be connecting from is a local computer (on the same network, using the same Internet connection/WiFi/router/etc) then you can find the IP address by holding down the Windows key on your keyboard (the one with the Windows logo on it) and tap the R key to open the Run dialog, type (or copy and paste) the contents of the following box into the field, and then click OK:

CMD /K IPCONFIG

This will display the network adapter information for the computer you run it on. You'll be looking for your IPv4 Address. There may be more that one network adapter in the list, and ones that are not in use should say "Media disconnected" on the right instead of having network adapter information.

Share this post


Link to post
Share on other sites

After creating the Firewall rule,
I can now connect my home computer from mobile phone,
but still can't connect from another computer which also installed Emsisoft Internet Security.

All of my computers and mobile phone use dynamic IP,
even visit the link, I can't remotely set Address.

Share this post


Link to post
Share on other sites
23 hours ago, wonexams said:

All of my computers and mobile phone use dynamic IP...

Unfortunately Emsisoft Internet Security doesn't support port knocking or single packet authorization, so you'll have to open the ports globally (for all addresses).

 

23 hours ago, wonexams said:

but still can't connect from another computer which also installed Emsisoft Internet Security.

You may need to add rules to the other computer to allow the ports for Outbound traffic rather than Inbound.

Share this post


Link to post
Share on other sites
2 hours ago, GT500 said:

You may need to add rules to the other computer to allow the ports for Outbound traffic rather than Inbound.

Could you please tell me what I should do?

  1. Open Emsisoft Internet Security.
  2. Click on Protection.
  3. Click on Firewall in the menu at the top.
  4. Click the Add rule button near the lower-right.
  5. Give the rule a name so that it is easy to identify what it does when looking through the list of firewall rules.
  6. Make sure the Action is set to 'Allow'.
  7.  ---------- WHAT SHOULD I DO ? -----------------------------------
  8. You can set Addresses to All, however this may be a security risk, so I recommend setting it for only specific addresses and then entering the IP address of the computer that is going to be connecting (multiple addresses can be entered if separated by commas).
  9. Click OK at the bottom to save your new firewall rule.
  10. Click on your new firewall rule in the list to select it.
  11. Click the Move up button to move your new firewall rule above the two block rules at the bottom of the list.

 

Thank you very much!

Share this post


Link to post
Share on other sites

I know you said all your computers are using dynamic IP... but can I just check?   You do mean they're all on your network?    If they ARE on your network, why are you using dymaic IP - is it so that if/when the machines are taken elsewhere and use dynamic IP elsewhere, you don't have to change the way they're set up?

Arthur commented above on the advisability (or not) of allowing traffic to/from all addresses... but if the machines are on a network then surely you only need to allow that traffic to/from the IP addresses that are valid on your network, not the entire outside world?   On the other hand, if one of these computers IS in the outside world then apart from rules in both machines' EIS firewalls, there might be a problem in the firewall component of your router (if you have one) - it may not be passing all the required inbound traffic to the target machine.

Share this post


Link to post
Share on other sites

Thank you for help.
Please forgive me if I make any errors. My English is pretty basic.

I usually use two computers: one at home, and another in the office.
I Also use two mobile phones.

Sometimes I need to connect Home PC from Office PC or phones.
Or connect Office PC from Home PC or phones.

These two computers are not on a network.
And their WAN IP are assigned by different ISP DHCP servers.

Chrome Remote Desktop doesn't need to set router or port forwarding.
It just need a Google Chrome and Google Account.
I use it well for a long time.

After Emsisoft Internet Security installed on Home PC and Office PC ,
I can't connect any computer from another one or two phones.

After creating EIS firewall rule,
I can now connect Home PC and Office PC from two mobile phones.
And connect successfully via both mobile network and local area network.

But no matter connect Home PC or Office PC from another computer, I always got error message:
'Unable to reach the host. This is probably due to the configuration of the network you are using.'

For test, I use VMware to create a virtual machine on Home PC, and call it 'Home VM'.
I can connect Home PC and Office PC from Home VM.
Home VM has no EIS.

Share this post


Link to post
Share on other sites

Do you also have the ports forwarded in your modem/router configuration?

Share this post


Link to post
Share on other sites
13 hours ago, GT500 said:

Do you also have the ports forwarded in your modem/router configuration?

The ports forwarded configuration of both Home Router and Office Router are empty.
Chrome Remote Desktop has never ask me to configurate it.

Share this post


Link to post
Share on other sites

Most software that requires ports to be forwarded won't ask you to, although most popular forms of remote access software have some sort of NAT traversal these days. If you're familiar with how to forward the ports, then you can go ahead and try it and see if it helps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.