Jump to content

EEC service crashing: 'System.OutOfMemoryException' in logs

Recommended Posts

Hi Team,

We've been using EEC for some time and love it! Have about 150 clients running off of it at this point and adding more soon.

The EEC is running on a server that is also the Domain Controller. (Running Server 2016 Standard with 8GB of RAM). It isn't doing any file/web serving or hosting any other 3rd-party applications, basically just Active Directory and EEC.

Lately, the EEC service seems to not want to stay running for very long. Initially we would notice that we hadn't been getting email and webhooks for a while, or we wouldn't be able to connect to it with the GUI on a workstation and then investigate and find that the service wasn't running. We could usually just start it back up or reboot the server and it would be fine for a while longer. Well, the intervals between needing to be restarted have gotten far too short and I need some help figuring it out.

One thing I was able to find in the logs were a bunch of: 'System.OutOfMemoryException' messages. I'm not a C# coder but I gather that may mean that there isn't enough contiguous RAM space available. What I find odd is that we did upgrade the RAM on this server from 4GB to 8GB and even when EEC is having trouble, the RAM usage as reported by Task Manager is pretty low. (attached pic) so I'm not sure a RAM upgrade will even solve this problem.

What I really want to know:

Is this a simple case of my server not meeting system requirements?

Is this because we have 150 clients and that's more than EEC can really handle?

Is there a setting I can adjust in my server to provide more contiguous RAM space (if that's even the problem)?

More than happy to arrange a remote access for an official Emsisoft representative.


Thank you!

2018-01-19 18_48_11-CARETECH-SRV - InstantCare Support - Connected.png

2018-01-19 18_55_30-CARETECH-SRV - InstantCare Support - Connected.png

Link to comment
Share on other sites

A quick update. I have created a scheduled task to stop the EECServer service, kill the EECServer.exe process, and then start the EECServer service every 15 minutes. At least, that will keep us from going long stretches of time with no updates, but probably not a good long-term solution.

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...