Mark Verhyden

Auto provision W10 pro failing

Recommended Posts

I've done a quick look around but have not seen anything on this.  Just started testing out EEC.  As I understand it, it is supposed to auto provision the client from the server.  Which worked on a W7 client as well as the server.  When I try to do this it'll start and then fail on step 2.  The following is the log output.  No domain, just work group on the server and clients.  I do know the credentials are good.  TIA.

 

Mark Verhyden

 

Job[7]: Deploy Finished(1)
WORKGROUP\WSW10-001: Failed [2/25/2018 8:35:53 PM]
2/25/2018 8:35:52 PM: Info - HostJob[7] on 'WORKGROUP\WSW10-001' started
2/25/2018 8:35:52 PM: Info - Impersonator: Applying network credentials: 'WORKGROUP\user (****************)' ...
2/25/2018 8:35:53 PM: Info - Impersonator: Applied network credentials 'WORKGROUP\user (****************)'
2/25/2018 8:35:53 PM: Info - HostJob[7]: step CheckComputerConnected started
2/25/2018 8:35:53 PM: Info - HostJob[7]: Checking Emsisoft Anti-Malware communication connection for computer 'WORKGROUP\WSW10-001'
2/25/2018 8:35:53 PM: Info - HostJob[7]: step CheckComputerConnected finished
2/25/2018 8:35:53 PM: Info - HostJob[7]: step WMILogin started
2/25/2018 8:35:53 PM: Info - HostJob[7]: Connecting to WORKGROUP\WSW10-001 using NT AUTHORITY\SYSTEM user credentials
2/25/2018 8:35:53 PM: Info - HostJob[7] WMI context: NT AUTHORITY\SYSTEM
2/25/2018 8:35:53 PM: Info - HostJob[7] WMI connecting to WSW10-001 as user
2/25/2018 8:35:53 PM: Trace - HostJob[7] WMI connection to WSW10-001 FAILED due to error: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)).
2/25/2018 8:35:53 PM: Warn - HostJob[7] WMI connection to WSW10-001 FAILED due to error: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)).

Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) (System.UnauthorizedAccessException)
  at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
  at System.Management.ManagementScope.InitializeGuts(Object o)
  at System.Management.ManagementScope.Initialize()
  at System.Management.ManagementScope.Connect()
  at A2Enterprise.WMI.WMIManagementScopeProvider.Connect()

2/25/2018 8:35:53 PM: Warn - HostJob[7]: Connection failed. Access is denied.

Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) (System.UnauthorizedAccessException)
  at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
  at System.Management.ManagementScope.InitializeGuts(Object o)
  at System.Management.ManagementScope.Initialize()
  at System.Management.ManagementScope.Connect()
  at A2Enterprise.WMI.WMIManagementScopeProvider.Connect()
  at A2Enterprise.Server.Tasks.Operations.Deploy.WMILogin(HostJobExecutionContext context)

2/25/2018 8:35:53 PM: Warn - HostJob[7]: Remote credentials are incorrect or the user does not have remote access to the computer through DCOM. 

Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) (System.UnauthorizedAccessException)
  at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
  at System.Management.ManagementScope.InitializeGuts(Object o)
  at System.Management.ManagementScope.Initialize()
  at System.Management.ManagementScope.Connect()
  at A2Enterprise.WMI.WMIManagementScopeProvider.Connect()
  at A2Enterprise.Server.Tasks.Operations.Deploy.WMILogin(HostJobExecutionContext context)

2/25/2018 8:35:53 PM: Info - HostJob[7]: step WMILogin finished
2/25/2018 8:35:53 PM: Warn - HostJob[7] failed with the following message: HostJob[7]: Connection failed. Access is denied.

HostJob[7] failed with the following message: HostJob[7]: Connection failed. Access is denied. (System.ServiceModel.FaultException`1[A2Enterprise.Entities.Errors.ServerError])


2/25/2018 8:35:53 PM: Warn - HostJob[7] on 'WORKGROUP\WSW10-001' failed due to error: HostJob[7] failed with the following message: HostJob[7]: Connection failed. Access is denied.

HostJob[7] failed with the following message: HostJob[7]: Connection failed. Access is denied. (System.ServiceModel.FaultException`1[A2Enterprise.Entities.Errors.ServerError])
  at A2Enterprise.Server.Tasks.HostJobExecutor.ExecuteOperationSteps(List`1 steps)
  at A2Enterprise.Server.Tasks.HostJobExecutor.<>c__DisplayClass17_0.<Run>b__0()
  at A2Enterprise.Impersonation.Impersonator.Execute[TError](Action action, Entity entity, Func`2 errorBuilder, Identification[] identifications)
  at A2Enterprise.Server.Tasks.HostJobExecutor.Run(Object state)




***This email was generated by Emsisoft Enterprise Console. Please do not reply to it.***

 

 

Share this post


Link to post
Share on other sites

Hi Mark,

Did you read the EEC setup guide ?

https://dl.emsisoft.com/EmsisoftEnterpriseConsoleManual.pdf

When you try to deploy to a workstation some settings are required for a successful deploy, i.e. opening a firewall port on the client and some WMI related settings.

EEC offers batchfiles which you can run on the workstations prior to deploy. These batchfiles makes the changes for you.

If you want to test if the connection between EEC and EAM works anyways, you could install EAM on a workstation and make the connection to EEC manually via settings/licence.

Installation of EAM and setting up the connection with EEC can be fully automated by using the MSI installers with cmdline parameters and when EAM is installed you can run a cmdline script to connect EAM to EEC.

Hope this helps.

 

 

Share this post


Link to post
Share on other sites
11 hours ago, Frank H said:

Hi Mark,

Did you read the EEC setup guide ?

https://dl.emsisoft.com/EmsisoftEnterpriseConsoleManual.pdf

When you try to deploy to a workstation some settings are required for a successful deploy, i.e. opening a firewall port on the client and some WMI related settings.

EEC offers batchfiles which you can run on the workstations prior to deploy. These batchfiles makes the changes for you.

If you want to test if the connection between EEC and EAM works anyways, you could install EAM on a workstation and make the connection to EEC manually via settings/licence.

Installation of EAM and setting up the connection with EEC can be fully automated by using the MSI installers with cmdline parameters and when EAM is installed you can run a cmdline script to connect EAM to EEC.

Hope this helps.

 

 

Hi Fred,

Thanks for the prompt reply.  Yes I did read though the guide.  This is a brand new install and firewall has been disabled.  So, in theory, I should not have to make any changes to firewall rules.  I do know about the installer packages but I was testing the remote install.  I'll have to do some more digging around.  Thanks again.

Regards,

Mark Verhyden

Share this post


Link to post
Share on other sites

Solution found.  From https://social.technet.microsoft.com/Forums/lync/en-US/4f33837b-1cb1-4648-85b1-3ba87cbfe93e/wmi-remote-access-denied?forum=winserverManagement

You have to start the shell in Run as Administrator to do this.

C:\Windows\system32>winrm quickconfig
WinRM is not set up to receive requests on this machine.
The following changes must be made:

Start the WinRM service.
Set the WinRM service type to delayed auto start.

Make these changes [y/n]? y

WinRM has been updated to receive requests.

WinRM service type changed successfully.
WinRM service started.
WinRM is not set up to allow remote access to this machine for management.
The following changes must be made:

Enable the WinRM firewall exception.
Configure LocalAccountTokenFilterPolicy to grant administrative rights remotely to local users.

Make these changes [y/n]? y

WinRM has been updated for remote management.

WinRM firewall exception enabled.
Configured LocalAccountTokenFilterPolicy to grant administrative rights remotely to local users.

C:\Windows\system32>

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.