Raynor

Playing around with EEC - some questions and issues

Recommended Posts

I've been playing around with EEC in a virtual machine prior to possibly deploying it in our company.
A few questions and issues have arisen:

1) (See attached screenshot 1)
For testing purposes, I have deleted all groups under "Polices-->Computers-->Groups"
except the "New Computers" default group.
Now I can't create any new groups, because the "clone" option is greyed out in all context menus
and there is no "new" option anywhere.

2) (See attached screenshot 2)
Why on earth is there a "Scanner Settings" section under Settings-->Options?
I thought that all the settings for the clients, including the scanner settings would be configured via policies!
And the same scanning options are indeed (as expected) present in the policies.
To top it off, there is no mention of this section in the help or the manual :blink:

3) How often does the Update Proxy update its data? (signatures and downloadable EAM program updates)
I can find nothing about this in the manual.

Thank you in advance!
Raynor

Computers.png
Download Image

Settings.png
Download Image

Share this post


Link to post
Share on other sites

Hi Raynor,

1) for a reason i do not know yet, you can't clone the 'New computers' group. only fix for now : reinstall EEC to be able to clone the existing default computer groups.

2) these scanner settings are applied as a default settings,  when you start a manual scan. Select a computer in the overview grid, and use context menu or scan button. You can modify the 'On scan completion' setting. The performance setting will be applied as set in Settings.

3)  Update Proxy Server is just a 'man in the middle' and only gets signatures and program updates when an endpoint requests them.

I hope this helps

 

Share this post


Link to post
Share on other sites

1) Other context menus seem to be a bit wonky, too:
Under "User Policies", If you right click on "Default for admins",
you get a greyed out context menu, and if you right-click on "Default for non-admin",
you get a normal, not greyed out context menu, but the "Edit" and "Delete" menu
items do nothing. "Clone" works.

Suggestion: Add a "New" Button at the bottom :), and make the
behaviour for context menus on non-deleteable default groups consistent
(i.e. consistently allow "clone" and grey out "edit" and "delete").
 

2) Thanks, yes, that makes it clear.
May I suggest that you rename this section from "Scanner Settings" to
"Scanner settings for console-initiated scans" and/or add a little descriptive text like
"These settings are applied when performing a manually initiated scan from EEC".
This might save some confusion for future users.
 

3) Thanks, this makes sense!

Best regards,
Raynor

 

Share this post


Link to post
Share on other sites

PS: Could we please get a "remember password" checkbox in the EEC login/connection screen in the future?
(no security risk for us, as only domain admins are allowed on the server anyway)...

Share this post


Link to post
Share on other sites

Such feature might not be a risk for you, but it might be for other enterprises and this is why we didn't add it.

 

Share this post


Link to post
Share on other sites

Hmmm ... maybe with a BIG FAT "potential security issue" warning message ? :blush:

Oh, and one more thing: The console window does not seem to remember its size and position, could this be fixed?

Share this post


Link to post
Share on other sites

On the topic of "playing around":

I just installed a fresh copy of EEC (for pre-deployment testing purposes) in a fairly basic Windows Server 2016 virtual machine (VirtualBox),
and stumbled over two obscure "Value does not fall within the expected range" warnings in the log.

Again, quite basic & fresh Server 2016 VM, just installed EEC (2018.3.0.3338) a minute ago (first thing was taking a look at the logs).
Any insights ?

Best regards,
Raynor

Value.png
Download Image

Share this post


Link to post
Share on other sites

Hi,

this log do not give any detailed information.

The issue might sit in installer synchronization.

As long as the installers download fine, i'd not worry too much,

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.