Raynor

EAM kills VirtualBox, starting 23-03-2018

Recommended Posts

Hi,

starting yesterday (Friday 23-03-2018), VirtualBox always throws an error (see attached screenshot) when starting a virtual machine, be it an existing one
or a new one. I was puzzled because I had extensively used VirtualBox just the day before (Thursday 22-03-2018) and everything worked fine (as it always had).

This thread lead me onto the right track: https://forums.virtualbox.org/viewtopic.php?f=6&t=83791#p397261

"The "process has more than one thread" error implies, I think, that some other process was trying to access VirtualBox process memory. So, either malware or antivirus. [...]
It would be something invasive: system monitor of some kind, developer debug environment, crash manager maybe."

 

And indeed, If I shut down EAM, VirtualBox starts to work again just fine (no errors whatsoever :rolleyes:).
So some very recent protection/signature update must have made EAM more invasive, thus causing this error.

Please fix this. :D

I am using EAM 2018.1.1 (delayed feed), Win 10 x64 v1709, VirtualBox 5.2.8.

Thanks,
Raynor

 

VirtualBoxError.jpg
Download Image

Share this post


Link to post
Share on other sites
On 3/24/2018 at 10:36 AM, Raynor said:

Please fix this. :D

VirtualBox has issues with security software (and always has), but that seems to have gotten worse lately. You can try the current beta version of Emsisoft Anti-Malware and see if it doesn't react as badly to some of the changes we've made, or you can add exclusions for VirtualBox so that Emsisoft Anti-Malware doesn't open hooks to its processes.

To install the beta (a reboot will almost certainly be required):

  1. Open Emsisoft Anti-Malware.
  2. Click on Settings in the menu at the top.
  3. Click on Updates in the menu at the top.
  4. On the left, under Update Settings, click on the box to the right of Update feed and select Beta from the list.
  5. Click on the Update now button on the right side.

 

To add a folder to the exclusions:

  1. Open Emsisoft Anti-Malware from the icon on the desktop.
  2. Click Protection.
  3. Select File Guard in the menu at the top.
  4. On the right side, roughly in the middle, click on the Manage whitelist button.
  5. In the box under Type click the little down arrow and select Folder (you may need to click in the box for the arrow appear).
  6. Click in the gray box below Item to make a button with three dots (...) appear, and then click the ... button.
  7. Navigate to the directory you wish to exclude, select it, and click OK at the bottom to add it.
  8. Click the OK button at the bottom when done, and close Emsisoft Anti-Malware.

Note that you will more than likely need to restart your computer (or at least stop and restart any VirtualBox services) before the exclusions will fully take effect. On Windows 10 you'll need to restart your computer by doing the following:

  1. Right-click on the Start button.
  2. Go to Shut down or sign out.
  3. Select Restart from the list.

Share this post


Link to post
Share on other sites
13 hours ago, GT500 said:

VirtualBox has issues with security software (and always has), but that seems to have gotten worse lately. You can try the current beta version of Emsisoft Anti-Malware and see if it doesn't react as badly to some of the changes we've made, or you can add exclusions for VirtualBox so that Emsisoft Anti-Malware doesn't open hooks to its processes.

Thanks, beta 2018.3.0.8528 seems to have fixed the problem.

I had added an exclusion of the file VirtualBox.exe before, that helped as well.
But with the recent beta, the exclusion is no longer required.

Share this post


Link to post
Share on other sites
11 hours ago, Raynor said:

Thanks, beta 2018.3.0.8528 seems to have fixed the problem.

Awesome. Thanks for letting me know. ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.