JeremyNicoll

CLOSED Build 8555 - some weird things

Recommended Posts

Build 8555 updated smoothly (on my W8.1 64bit system), but since then I've noticed that

a) the systray icon was hidden; it was possible to turn its display back on via the systray Customisation thing, but this is not normally needed

b) I'd downloaded a copy of FRST64.exe; I right-clicked it and chose EAM scan... and nothing seemed to happen - I expected the GUI to be displayed and be told the scan result.  I've repeated this and once the GUI has popped up.  But I also get instances of the mouse pointer just becoming a revolving blue circle.  Moving it towards the taskbar doesn't make the taskbar unhide as usual.  Last time I tried to follow an Admin Tools shortcut (on my desktop, heading towards the Eventlog Viewer) and there was a sort of hiccup, a brief (sub-second) dispay of an all blue screen, then the Explorer desktop display was redrawn and the revolving blue circle had gone.  Would that imply an issue with the code what runs from the file explorer context menu? - that weirdness starts with a right-click action.

Edited by JeremyNicoll
can't spell "weird"!!!

Share this post


Link to post
Share on other sites

The eventlog shows that twice explorer.exe hung, eg

Log Name:      Application
Source:        Application Hang
Date:          02/04/2018 16:46:01
Event ID:      1002
Task Category: (101)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      SAMSUNG-NP350
Description:
The program Explorer.EXE version 6.3.9600.18460 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Action Center control panel.
 Process ID: f78
 Start Time: 01d3c90bc6f1a1ec
 Termination Time: 31
 Application Path: C:\Windows\Explorer.EXE
 Report Id: f0fafba4-368c-11e8-8119-50b7c3e8a12a
 Faulting package full name:
 Faulting package-relative application ID:

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Hang" />
    <EventID Qualifiers="0">1002</EventID>
    <Level>2</Level>
    <Task>101</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2018-04-02T15:46:01.000000000Z" />
    <EventRecordID>174318</EventRecordID>
    <Channel>Application</Channel>
    <Computer>SAMSUNG-NP350</Computer>
    <Security />
  </System>
  <EventData>
    <Data>Explorer.EXE</Data>
    <Data>6.3.9600.18460</Data>
    <Data>f78</Data>
    <Data>01d3c90bc6f1a1ec</Data>
    <Data>31</Data>
    <Data>C:\Windows\Explorer.EXE</Data>
    <Data>f0fafba4-368c-11e8-8119-50b7c3e8a12a</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Binary>55006E006B006E006F0077006E0000000000</Binary>
  </EventData>
</Event>

Share this post


Link to post
Share on other sites

Did you come from previous beta or from eam stable ?

Does a pc restart resolves these issues ?

Share this post


Link to post
Share on other sites

As a beta tester, please always have debuglogs enabled or enable them when you can replicate the issue.

Such logs always are required.
With hangs etc, a full system dump is required. you could use the tool 'notmyfault' from Microsoft.

 

Thanks

Share this post


Link to post
Share on other sites

I've been on the beta feed for a while (weeks?), but couldn't say whether I had a beta or stable installed earlier today.   Wait, the log says I had 8528 on  31 Mar.

I've just done a full shutdown.  I've noticed something else - in the log there's a line I've never seen before which says:

02/04/2018 17:26:04
Setting "Detection signatures updates" has been changed to "Disabled"

It says this was a user action.  I sure as hell didn't turn anything off myself.  Using the search filter for the word 'signatures' shows this is the first time this message has ever been in the log.

 

 

 

 

Share this post


Link to post
Share on other sites

I just tried another right-click of FRST64.exe and an EAM scan - explorer hung again.  I'll turn on debug logs and do another full shutdown...

Share this post


Link to post
Share on other sites

as this is a hang of the OS part, could you create a full dump please. debuglogs make no sense here.

Share this post


Link to post
Share on other sites

A full dump'll take a bit longer.  I'll need to find my notes on how to do it.

When debug logging was on, after a reboot my first attempt at context-scanning the same .exe worked, but there was still 5-10 seconds of revolving blue cursorbefore the GUI was displayed with the result.  I spend a minute or so writing some notes then right-clicked the .exe and asked for another scan and that time the full hang occurred again. It's interesting that something in explorer detects the hang and restarts itself, just as well.

Share this post


Link to post
Share on other sites

I thought I'd try to dump the system from my admin id because fewer applications start when I logon there, eg the Dropbox client doesn't.  Dumping a system deliberately isn't a great plan & leaving DB's control databases in a funny state isn't attractive... But EAM behaved properly on this simpler id: the GUI immediately popped up then a second or two later showed the scan result.   

So I've disabled DB from starting and will try a full shutdown & reboot of my normal id and see how EAM behaves.

Share this post


Link to post
Share on other sites

OK, I've dumped the system during a hang and the compressed dump is being uploaded.   That'll take, I think, about an hour.  Meantime I've reverted to the stable feed and a few test scans have been ok.

Share this post


Link to post
Share on other sites

we've just released 2018.3 stable, so beta = stable now

did you get the issue with dropbox not started ?

Share this post


Link to post
Share on other sites

At this instant I'm back on 8483; are you saying 8555 will replace it as soon as another update is done?    If so, why push it out so fast?

What would I get if I changed to the Delayed feed?

Share this post


Link to post
Share on other sites

8555 is a minor beta update and there was no reason to not release it as beta as it passed all internal and external tests.

I suggest you stay on 8555 so you can hep us tracing the issue asap.

The issue only occurs when you do a context scan, right ? so don't that that ;)

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.