brain_ticket

Windows 7 bootet nicht mehr nach Neustart von EAM

Recommended Posts

Hallo,

nach dem gestrigen Update und dem geforderten Neustart bootet mein Rechner mit Windows 7 x64 nicht mehr. Er startet bis diese kleinen bunten Kacheln kommen von Windows und dann friert er ein. Es gibt einen Bluescreen mit dem Stopcode 0x0000007B und dahinter einen Haufen Nullen in mehreren Blöcken. Hab dann ein Image zurückgespielt was funktionierte. Jetzt wird es ganz jeck, wenn ich dann in die Registry gehe fehlt dieser Eintrag von M$ bzw. der wegen der (glaube ich) Spectre Lücke eingeführte Key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\QualityCompat

cadca5fe-87d3-4b96-b7fb-a231484277cc

Den habe ich dann händisch gesetzt und habe EAM deinstalliert. Neustart, alles bestens. Dann EAM neu installiert, Neustart -> Bluescreen -> Image etc. Also ohne EAM läuft der Rechner fehlerfrei incl. Neustart. Installiere ich EAM, Bluescreen. Was soll ich da jetzt machen. Bin ziemlich ratlos. Auch weil es ja so reproduzierbar ist.

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Guten Tag brain_ticket,

 

Es tut uns Leid, dass Emsisoft Ihnen Probleme bereitet. Könnten Sie mir bitte sagen um was für einen Rechner es sich handelt? Könnten Sie für uns auch einmal schauen ob bei den Abstürzen Memorydumps erstellt wurden. Entweder C:\Windows\Memory.dmp oder in C:\Windows\Minidump (dann mit Datum und Uhrzeit des Absturzes).

Könnten Sie mir auch noch ein FRST-Log zukommen lassen: https://helpdesk.emsisoft.com/de/article/274-einen-scan-mit-frst-duchfuehren

 

EDIT: @Optimist Danke für den Link zu dem Sicherheitsupdate. Windows hat dies in der Tat zurückgenommen.

In dem Fall handelt es sich leider vermutlich trotzdem um ein von uns verursachtes Problem, weswegen die Startreparatur hier langfristig nicht hilft.

 

Mit freundlichen Grüßen

Kathrin

Share this post


Link to post
Share on other sites

Danke @Optimist für die Hilfe. Ich wußte nicht das der Key zurückgezogen wurde.

@kathrin,

Memorydumps finde ich keine, sind anscheinend keine erstellt worden unter diesem Pfad. Der Rechner ist ein 1 Jahr altes HP ProBook 450 G3 https://www.notebooksbilliger.de/hp+probook+450+g3+t6q54et

Im Anhang die beiden FRST Logs:

 

FRST.txt

Addition.txt

Share this post


Link to post
Share on other sites

Guten Tag brain_ticket,

 

Vielen Dank für die Rückmeldung. Die Tatsache, dass Sie ein HP Notebook besitzen, bestätigt weiter, dass es sich hier um einen Konflikt von unserem Programm mit HP Rechner handeln. Leider sind wir noch nicht ganz auf die Ursache gestoßen.

 

Könnten Sie bitte einen Registry-Export für mich erstellen? Den würde ich unseren Entwicklern geben, damit diese sich das Problem näher anschauen können.

 

Geben Sie dafür bitte regedit in die Suche im Starmenü ein und führen Sie den Registry-Editor anschließend aus. Sie erhalten eine Warnung dass das Verändern der Registry gefährlich ist, bestätigen Sie diese bitte. Wir werden keine Veränderung vornehmen.

Klicken Sie anschließend auf HKEY_LOCAL_MACHINE und klappen den Eintrag aus. Wählen Sie dann SYSTEM, CurrentControlSet, Control und Class an und klappen diese aus. Scrollen Sie dort zu den Einträgen die mit {4d36 beginnen und suchen Sie da den Eintrag raus wo auf der rechten Seite für den Wert mit Namen (Standard) die Daten DiskDrives steht.

Machen Sie einen Rechtsklick auf den Eintrag {4d36....} und wählen Sie exportieren aus. Speichern Sie die Datei an einem Ort Ihrer Wahl und hängen Sie diese bitte an Ihrer nächsten Antwort an.

 

Mit freundlichen Grüßen

Kathrin

Share this post


Link to post
Share on other sites

Das wäre ja fatal wenn die beiden nicht zusammen gingen. Ich nutze nicht umsonst EAM. ;-) Wobei seit einem Jahr wo ich den Rechner hab keinerlei Probleme auftraten. Nun gut im Anhang der Reg Auszug mit der Kennung 4d36:

 

4d36.reg

Share this post


Link to post
Share on other sites

Ich benutze auch ein HP-Notebook und habe heute Morgen den zweiten Versuch gestartet, EAM zu deinstallieren und neu zu installieren. Das Ergebnis war wie beim ersten Versuch. Das Notebook bootet nicht mehr. Es kommt eine Fehlermeldung, dass der PC defekt ist. Die von Windows gestartete automatische Reparatur führte nicht zu einem Erfolg. Auch ein Booten im abgesicherten Modus blieb erfolglos. Ich musste den PC zurücksetzen und bin gerade dabei, alle Programme wieder neu zu installieren. EAM wird mit Sicherheit nicht mehr dabei sein. :(

Share this post


Link to post
Share on other sites

Guten Tag Optimist,

 

Das tut mir Leid! Ich hatte nicht verstanden, dass Sie dieses Problem ebenfalls gehabt haben.

 

Haben Sie den Rechner bereits zurückgesetzt? Falls nicht können wir den betroffenen Registry-Eintrag eventuell noch von Hand korrigieren und so den Rechner wieder zum booten kriegen.

 

@brain_ticket

Vielen Dank für den Export. Dieser bestätigt, dass auf HP Rechnern der UpperFilters-Wert scheinbar nicht korrekt implementiert ist, sodass beim Einfügen unseres Wertes Datensalat eingesetzt wird. Letztlich fehlt bei dem Wert der Stopper. Wir lesen jedoch den Wert (wie von Microsoft vorgesehen) bis zum nächsten Stopper aus und erhalten dadurch den Datensalat, der eigentlich bereits zu einem anderen Wert gehört.

Wir werden schauen wie wir dieses Problem umgehen können, da es unwahrscheinlich ist, dass HP nachrüstet.

Mit freundlichen Grüßen

Kathrin

 

Share this post


Link to post
Share on other sites

Das Problem ist nur das ich in der Zeit kein AV habe und auch den Rechner nicht ausmachen kann. Obwohl das wäre das kleinste Problem, der Ruhezustand funktioniert ja.

 

[editiert]

Share this post


Link to post
Share on other sites

Guten Tag,

Es gibt eine Lösung, die jedoch etwas riskant ist.

Sie können Emsisoft wie gewohnt installieren. Nach der Installation (und vor dem Neustart) öffnen Sie regedit erneut und gehen wieder zu dem oben genannten Registryschlüssel:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318}]

Schauen Sie dort auf den Wert UpperFilters. Dieser sollte zwei Einträge haben: Partmgr und eppdisk. Wenn dort zusätzliche unleserliche (zb chinesische) Zeichen sind (beziehungsweise statt eppdisk), dann  konnte der Wert nicht korrekt gesetzt werden.

Machen Sie einen Doppeklick auf den Wert Upperfilters um diesen zu editieren. Sie sollten dann auf der ersten Zeile partmgr stehen haben. Löschen Sie die Sonderzeichen auf der nächsten Zeile und, wenn notwendig, ersetzen Sie diese durch eppdisk. partmgr und eppdisk müssen auf zwei unterschiedlichen Zeilen stehen. Sonst sollte sich in dem Eintrag nichts befinden.

Damit sollten Windows und Emsisoft wie gewohnt starten können. Es bleibt ein kleines Restrisiko, dass dies nicht korrekt funktioniert und Sie anschließend nicht booten können. Sollte dies der Fall sein, würde ich Sie bitten sich bei mir zu melden, dann können wir nochmal versuchen die Registry von der Wiederherstellungskonsole aus zu editieren.

 

Mit freundlichen Grüßen

Katrhin

 

Share this post


Link to post
Share on other sites

@Optimist,

natürlich ärgerlich, sehe ich ja bei mir. Dann installiere alles neu und mache Dir ein frisches Image. Falls dann was passiert hast Du in 20min. den Rechner wieder am laufen. Als Notlösung. Und so schnell würde ich die Flinte nicht ins Korn werfen, warte doch erst mal ab was die Technik sagt bei Emsisoft.

Share this post


Link to post
Share on other sites

Das ist ein Screenie des Reg Eintrages: Es gibt nur einen Eintrag PartMgr. eppdisk ist nicht dabei.

[edit]

Soll ich denn eppdisk da rein schreiben wie von Dir empfohlen? Oder hab ich das falsch verstanden und diese, ich sag mal, chinesischen Schriftzeichen o. ä. sind erst nach der Installation vorhanden? Dann kann ja jetzt nix da drin stehen da ich es ja noch nicht installiert habe. *schäm

[/]

 

 

 

 

reg UpperFilter.JPG
Download Image

reg UpperFilter offen.JPG
Download Image

Share this post


Link to post
Share on other sites

Also doch. Hab EAM nun installiert und die besagten Zeichen in der Reg sind vorhanden. Nun werde ich wie gesagt die Einträge dahin gehend ändern wie Du gesagt hast. Bin mal gespannt.

Ich wurde allerdings nicht zu einem Neustart aufgefordert.

 

reg UpperFilter2.JPG
Download Image

Share this post


Link to post
Share on other sites

Was soll ich sagen, es hat funktioniert. Mehrfach neu gestartet und problemlos hochgefahren. Und ich hab auch mein heißgeliebtes EAM wieder.

Vielen Dank kathrin und dem Team für, wie immer, erstklassige Arbeit. Was ich noch fragen wollte, wo ist denn das Risiko von dem Du weiter oben gesprochen hast?

 

 

 

reg UpperFilter3JPG.JPG
Download Image

Share this post


Link to post
Share on other sites

Hi,

Wir sind noch dabei alle Ursachen zu erkunden. Ihr Rechner ist der erste bei dem wir in der Lage waren den Registry-Eintrag vor der Installation von Emsisoft einzusehen und zu verstehen wieso die Korruption stattfindet.

Ich war zwar recht zuversichtlich, dass das Problem nur die Registry betrifft, aber es hätte durchaus sein können, dass es bei der Installation zwei Probleme gab und nicht nur eins. Es hätte zum Beispiel sein können, dass die dazugehörige Datei ebenfalls nicht kopiert worden ist.

Es hätte auch einfach passieren können dass Sie oder ich beim tippen ein Fehler gemacht haben und dann statt eppdisk, epdisk im Eintrag steht und der Rechner trotzdem nicht bootet.

Bootet der Rechner nicht mehr und Sie wollen ihn reparieren, würde ich die Anleitung ohne große Warnung rausgeben.. Schlimmer kann es ja nicht mehr werden. Aber Sie hatten einen funktionalen Rechner und es bestand das Risiko, das dieser sich wieder in einen kaputten Rechner verwandelt. Da bin ich dann etwas vorsichtiger. ;)

 

Mit freundlichen Grüßen

Kathrin

 

Share this post


Link to post
Share on other sites

Verstehe. Wie sieht es denn für die Zukunft aus. Muß ich damit rechnen das nach dem nächsten Update von EAM das Gleiche wieder passiert oder ist jetzt durch die Änderung der Registry alles behoben.

Share this post


Link to post
Share on other sites

Noch ne Frage. Soll ich den ganz oben erwähnten und von mir gesetzten Key wieder löschen, da @Optimist ja aufzeigte das er selbst von M$ wieder entfernt wurde? Was meint Ihr?

Share this post


Link to post
Share on other sites

Guten Tag,

 

Der Wert braucht nicht wieder gesetzt zu werden. Microsoft sollte Ihnen auch zukünftig Updates ohne diesen Schlüssel installieren.

Zum einen werden wir den Wert bei den nächsten Updates nicht mehr verändern, von daher sollte es keine Gefahr geben. Zudem haben wir den Schlüssel jetzt auch korrekt konfiguriert, sodass Sie auch in Zukunft, wenn ein anderes Programm sich dort eintragen möchte keine Probleme haben sollten.

Mit freundlichen Grüßen

Kathrin

Share this post


Link to post
Share on other sites
Am 13.4.2018 um 13:08 schrieb brain_ticket:

@Optimist,

natürlich ärgerlich, sehe ich ja bei mir. Dann installiere alles neu und mache Dir ein frisches Image. Falls dann was passiert hast Du in 20min. den Rechner wieder am laufen. Als Notlösung. Und so schnell würde ich die Flinte nicht ins Korn werfen, warte doch erst mal ab was die Technik sagt bei Emsisoft.

@brain_ticket

Das war nur der letzte Anstoß für meinen Wechsel zu einem anderen AV. Unter Windows-Edge versagte der Surfschutz, ein Coin-Miner wurde zwar entdeckt, wurde angeblich in die Quarantäne verschoben, blieb aber tatsächlich aktiv, beim Update der Virensignaturen werden auf meinen "schwächeren" Rechnern Programme derart heftig ausgebremst, dass in der Kopfzeile die Meldung erscheint "Program antwortet nicht", und nun der Fehler beim Booten nach einer Deinstallation, das war einfach zuviel.

Share this post


Link to post
Share on other sites

Guten Tag Optimist,

 

Ich kann Ihre Entscheidung nachvollziehen, auch wenn es mir natürlich Leid tut Sie zu verlieren. Ich hoffe, dass Sie uns aber dennoch auch in Zukunft hier erhalten bleiben und wünsche Ihnen ein angenehmes Rest-Wochenende.

 

Mit freundlichen Grüßen

Kathrin

Share this post


Link to post
Share on other sites

Hallo kathrin,

ich wünsche Ihnen ebenfalls noch ein schönes Rest-Wochenende. Ich werde hier sicher auch in Zukunft reinschauen und die Entwicklung beobachten.

Mit freundlichen Grüßen

Optimist

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.