Jump to content

Upgrade Win v1709 to v1803 causes EEC connection to be lost

Recommended Posts

System environment:

Windows Server 2016 Domain
About 40 domain-joined PCs, some Win 7, some Win 10
EEC 2018.06 on the DC
EAM 2018.05 (delayed feed) on the workstations


First of all: installing and initially connecting EAM to EEC worked fone on all PCs.


I have just upgraded a couple of our company's Win 10 v1709 PCs to Win 10 v1803
using the normal Windows Update installation process.

On all of the upgraded PCs, the connection to EEC is lost after the upgrade.

This is annoying. After all the connection problems in the past (see this forum)
I thought that these issues were a thing of the past. Obviously not.
Connection stability sill seems iffy and unreliable, at least after upgrading
domain-joined workstations from v1709 to v1803.

I had to manually disconnect the PCs (using the interface within EAM itself, not
from the server console) and then manually reconnected them (also from within EAM).

After that, the connection was back up again.

Still, unacceptable behaviour in a coroprate environment 😪


Thanks and best regards


Link to comment
Share on other sites

Thanks for your feedback.

When such rare issues show-up next time, I suggest you contact our support team so we can guide you and collect debug logging files from EAM side.

We have many EEC users and this issue showed up for a few only. We are unable to replicate, so logs will be very welcome and required to be able to further analyze this.


Link to comment
Share on other sites

Thanks for your reply.

I'm puzzled, because our whole domain  setup is pretty much run-of-the-mill, nothing fancy...
EEC uses its default ports, there are no fancy firewall settings in place, nothing.
We use the update proxy (default port 8080) and that works fine as well.

Some weeks ago, I installed EEC on the Server 2016, added the PCs, created manual deployment packages
(we don't use remote deployment), installed them on the Win 10 v1709 clients via "Install.bat", and the connection
to the Server worked flawlessly. On the clients no windows settings have been changed / no preparations have been made
prior to deployment (if I understand correctly, preparations are only necessary for REMOTE deployment).

Everything has worked fine for the last couple of weeks.

Today, I upgraded some client PCs to v1803 through Windows Update (by removing the feature update deferral policy we had in place before),
the upgrade itself went fine, but after that the clients all showed "connection" failed. Manually reconnecting was necessary and immediately
worked fine (see above).

I have just sent a mail to support asking for further instructions.

I will be upgrading more clients tomorrow, so lots of logs will be there I guess :)

Link to comment
Share on other sites

  • 3 weeks later...
On 7/26/2018 at 10:41 PM, Frank H said:

Thanks for sending the email, i've seen it.

Dear all,

is there any news on this issue? Did the logs provide any meaningful insights?

I still got more workstatios to upgrade from 1709 to 1803, so I could

gather more logs if needed.


Thanks and all the best


Link to comment
Share on other sites

  • 3 months later...

We have just started upgrading a few clients from v1803 to v1809 for testing purposes.

At the moment they are running EAM 2018.8.1 (delayed feed). Our Server 2016 is running the latest EEC version.

The issue still persists. Clients are losing connectionto EEC after upgrading to v1809.
Manually reconnecting the clients from the EAM User Interface is necessary and works flawlessly and instantly...

The EAM Logs say:

Connection with Emsisoft Enterprise Console SERVERNAME:8082 failed.
276: Server certificate verification failed. Connection aborted.

Any insights ? What could cause the certificate verification to fail ?
We really need to get this fixed, we can't run around manually reconnecting each and every client
from now until forever 😪




Link to comment
Share on other sites

  • 4 weeks later...


Sorry for being so persistent 😀, but I find it hard to believe that we are the only ones suffering from this issue.
Why ? because our Server 2016 is totally run-of-the-mill, nothing fancy, no special configuration at all.
Just one server (fresh install, about one year ago), acting as Domain Controller for a bunch of workstations,
and as a file server, and hosting the EEC. No additional firewalls/proxies/security appliances running in the network.
As I said, no fancy stuff 😆

Please let me reiterate my question: If the "Server certificate verification" fails according to the EAM log on the clients
after upgrading Windows to a newer semi-annual build, something on the clients must have changed in a way that the
certificate is no longer valid.

I don't think that the server could be the culprit, as nothing whatsoever has changed on the server side.

Again, any help would be greatly appreciated, as the current situation is quite unsatisfactory.


Link to comment
Share on other sites

  • 3 weeks later...
On 12/16/2018 at 4:24 PM, Raynor said:

I find it hard to believe that we are the only ones suffering from this issue

Hi Raynor, we're also suffering from it too so you aren't alone. Like you we have a relatively simple setup and I believe I've eliminated the obvious potential issues such as network transport, time synchronisation, etc..

I have noticed it's a lot better than it used to be, it's only a few clients each time now instead of nearly all. And I've discovered I can rejoin the clients remotely using WMI remote process execution which saves wear and tear on my legs.

Regards, Jonathan


Link to comment
Share on other sites

2 hours ago, Jonathan Starr said:

Hi Raynor, we're also suffering from it too so you aren't alone.

Thanks for this confirmation Jonathan. I thought I was going crazy.

@Emsisoft: Please let me kindly ask that the process of verifying the client certificates is reviewed with regard to EEC's/EAM's behaviour
after upgrading to a new semi-annual Windows version. I would really appreciate if this issue could get squashed once and for all. Thanks ☺️


Link to comment
Share on other sites

This topic is now closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...