Jump to content

2018.7.1. 8839 shutdown issue.

Recommended Posts

On Windows 10 I saw this in System Event viewer logs this morning.

I rebooted just now and it shows again.

I have FastBoot disabled.

It doesn't show on Win 7.


The Emsisoft Protection Service service did not shut down properly after receiving a pre-shutdown control.





Link to post
Share on other sites

regarding to the shutdown delays: could you guys try this:

1. disable self-protection in EAM

2. open CMD as administrator

3. run: sc stop a2antimalware

4. check with taskmanager if proces a2service stays in 'stopping' state

5. create a process dump if so

6. please send me the dumpfile, zipped.

you can start EAm again by starting Emsisoft Anti-Malware via  the windows start  menu.


Link to post
Share on other sites

I think I may have broken something :(

Did it first time and saved a dump but didn't know it EAM was stopped because I forgot to look under the details tab :blush:

So I restarted EAM via start menu but it didn't show in taskbar, so I tried with EAM desktop icon.

Then it showed 2 EAM guards in taskmanager and cmd wouldn't let me stop the service again and an EAM  popup said it had a problem and try rebooting. :(

I am going to reboot and try again.



Link to post
Share on other sites

I also had a delayed shutdown (in W8.1) and since rebooting have tried your process twice.  The first time, a2service.exe did not go into "Stopping" at all, just stayed "running".   I didn't dump it, because I was looking for "Running" to become "Stopping"... but I realise now I probably got that wrong... because that "Running" was on the Details tab in TM next to the display of a2service.exe,  and I now realise the service state is shown on a different tab. (I normally use PH.) 

I rebooted and tried the whole thing again and the second time it stopped immediately.

Link to post
Share on other sites

Excellent!  (The restart needed to get the new beta installed stalled, presumably because it was the older a2service.exe that was failing to stop properly... and I did dump that, but I suppose you won't need the dump). 

After that I shut down my W8.1 system and I can confirm that, here, that shutdown was its normal brisk self - the message saying that Emsisoft Protection Service was shutting down was only visible for a second or two before subsequent stuff happened.  Hooray!

Link to post
Share on other sites

Build 8843 is working fine for me - no more errors in Event Viewer at shutdown and it shuts down nice and quickly again.

I didn't notice any delay between service shutdown and restart during the upgrade - went very smoothly and the EAM log shows it took 4 secs to stop and start protection.

Link to post
Share on other sites
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...