Jump to content

New version of EAM causing massive lag on Heroes of the Storm


Recommended Posts

Windows 10, version 2018.9.1.8968.

Shortly after the slide that notified me EAM has been updated popped up, my Heroes of the Storm session started behaving strangely - mouse delays, inability to control cursor properly ingame. Things work fine outside of the game itself, and quitting EAM fixed the problem.

Right now I have restarted EAM with all protections disabled.

Link to post
Share on other sites
5 hours ago, Sintharius said:

Adding the game folder to monitor exclusion fixed it. Don't know what changed in the beta update to mess the game up so badly...

It's no secret.  The update that fixed it contained in its description: "Fixed: issue with Steam and other apps that use DirectX".

See: https://en.wikipedia.org/wiki/DirectX 

Link to post
Share on other sites
On 10/8/2018 at 3:35 AM, JeremyNicoll said:

It's no secret.  The update that fixed it contained in its description: "Fixed: issue with Steam and other apps that use DirectX".

See: https://en.wikipedia.org/wiki/DirectX 

The beta patch you mentioned fixing it was actually the one that caused it, as I have stated in the original post. Heroes of the Storm was running fine until the patch dropped, then I had to add it to exclusions to fix the issue.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...