Tarnak

Back to using EAM after an absence...

Recommended Posts

I installed EAM on my Surface Book, earlier today, but I was dismayed that it takes such an amount of memory resources on Surface Book.  Previously, I had been using EAM on  my XP desktop, for quite a number of years. 

 

 

 

EAM_takes a huge chunk of my system memory_01.JPG
Download Image

Share this post


Link to post
Share on other sites

That memory usage is completely normal. The database is over 200 MB just by itself, so in order to reduce memory usage Emsisoft Anti-Malware would need to offload parts of the database that aren't being actively used into the pagefile, which reduces performance (when those parts of the database are needed Windows has to load them from the pagefile). Since a few hundred megabytes is relatively small by today's standards, we decided that it would be best to leave such "memory optimizations" off by default.

Feel free to turn it on if you'd like. Just open Emsisoft Anti-Malware, click on the Settings tile (or click the gear icon in the menu/sidebar on the left), click on Advanced in the menu at the top, and turn on the Memory usage optimization option.

image.png
Download Image

 

Share this post


Link to post
Share on other sites

Am I wrong in assuming that EAM initially decides on its own whether to enable that option or not? I seem to remember on a PC with limited memory that it was turned on by default.

Tarnak, if you have enough memory you should let EAM use it and leave that option disabled - everything will work better this way.

 

On 11/3/2018 at 7:09 AM, Tarnak said:

...but I was dismayed that it takes such an amount of memory resources

 

Share this post


Link to post
Share on other sites

I apologise for hijacking this thread but I'm confused about the memory optimisation setting.

The tooltip says 'Please turn this option OFF if you experience performance issues while using the software' - so, as I have never experienced performance issues while using the software, I've always turned this option ON.

Having now seen the comments in this thread, and also checked the text in the user guide, it seems to me that I should turn this option off rather than having it turned on (I have 8GB RAM) and that the tooltip should say 'Please turn this option ON if you experience performance issues while using the software'.

GT500 - can you clarify/confirm please ?

  • Thanks 1

Share this post


Link to post
Share on other sites

Yes, you should turn it off. No, the tooltip is correct (although indeed somewhat confusing) because performance issues are most likely to come if you turn it on (= pagefile used, more disk activity, Windows becomes slower etc.). We want to use the RAM here, not the pagefile.

Some confusion may arise because a user intuitively assumes that "performance issues" could be caused by the ~300MB needed by EAM so the user feels the option should be on (= less RAM used). It seems like extra, unnecessary RAM usage. But it is not.

Most systems can spare 200-300MB of RAM nowadays and that option should only be enabled in critical situations, like not having enough RAM to even open and run programs, for example.

Share this post


Link to post
Share on other sites
18 minutes ago, Quirky said:

Yes, you should turn it off. No, the tooltip is correct (although indeed somewhat confusing) because performance issues are most likely to come if you turn it on (= pagefile used, more disk activity, Windows becomes slower etc.). We want to use the RAM here, not the pagefile.

Thanks for the explanation - that's helpful, unlike the tooltip :)

Share this post


Link to post
Share on other sites

Thanks,  to all that replied.  ...It can be confusing when you see conjecture in a thread, as to what is the right thing to do. 

So, for the time being, I will just leave as is. :)

 

 

Share this post


Link to post
Share on other sites
13 hours ago, Quirky said:

Am I wrong in assuming that EAM initially decides on its own whether to enable that option or not? I seem to remember on a PC with limited memory that it was turned on by default.

The option used to be on by default, however to my knowledge it is now always off by default.

 

13 hours ago, marko said:

Having now seen the comments in this thread, and also checked the text in the user guide, it seems to me that I should turn this option off rather than having it turned on (I have 8GB RAM) ...

That is correct. If the 300-500 MB of RAM it will use isn't a burden, then there's no real need to have the option turned on.

Note that if your pagefile is on an SSD, you may not notice any performance differences between having the option on or off. It may also work differently on Windows 10, where Windows favors compressing memory pages rather than moving them to the pagefile to reduce memory usage.

 

13 hours ago, marko said:

... the tooltip should say 'Please turn this option ON if you experience performance issues while using the software'.

The way it works, turning the option on would reduce performance, and turning the option off would improve performance. The text of the tooltip may need to be updated to clarify that it is off by default due to reduced system performance when the option is on.

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.