Sign in to follow this  

Anti-Malware Installer gets "Access Denied" when trying to create the Quarantine directory.

Recommended Posts

I'm trying to install Anti-Malware on a FAT32 Windows XP system disk (the following problems do not occur on an NTFS system disk, only FAT32). At all times I'm logged in as Administrator.

The installer aborts with the error message "Setup was unable to create the directory 'C:\Program Files\Emsisoft Anti-Malware\Quarantine'. Error 5: Acess is denied."

I've tried to create the directory structure by hand, ie, the root and the 4 subdirectories - Languages, Logs, Quarantine, and Signatures. Setup asks me if I want to reuse the existing root directory; I answer "yes", and I get the same error as above.

When I try to OPEN the Quarantine directory, I get the error "C:\Program Files\Emsisoft Anti-Malware\Quarantine is not accessible. Access is denied". (I can open any of the other directories).

When I try to RENAME it, I get "[Error Renaming File or Folder] - Cannot rename Quarantine: Access is denied. Make sure that the disk is not full or write protected and that the file is not currently in use". (I can rename the parent directory, or any other subdirectory except Quarantine).

When I try to DELETE it, I get "[Error Deleting File or Folder] - Cannot delete file: Cannot read from the source file or disk". When I try to delete it using the DOS rd /s command, I just get "Access is denied". (I can delete any of the other three subdirectories, but not the parent, because I can't remove Quarantine).

I've tried to unlock the Quarantine directory with the following 2 programs:

* Unlocker: says "No locking handle was found".

* FileASSASIN: says "The file you have specified does not exist or is not visible".

I have repeated all of the above after defragmenting the disk, and get the same errors.

There is no problem with the other three directories (Languages, Logs, and Signatures) - I can open, rename and delete them. The problem is only on the Quarantine directory (and only on FAT32). Note that even when you clear the option "Use simple file sharing", FAT32 does not allow access control lists as NTFS does; files and directories just have a Read-Only attribute, and in the Read-Only attribute of a directory always appears as a solid green blob (neither a tick nor an empty square).

Can anyone help?

Share this post

Link to post
Share on other sites

Hi JohnSh, welcome to the forum

1st question is : why it's v5.1.0.3 when the latest version is

At the same time - it may not be the cause.

Most likely you do have permission issues, that are not related to EAM.

That has to be investigated.

I'm not using FAT32 for a long time on the default system drive (it's NTFS either on XP 32bit or Win7)

x64) at the same time I do have Fat32 partition on a separate physical drive & EAM can be installed there with no problems whatsoever.

Then any installation of Emsisoft Emergency Kit (EEK) installs on Fat32 formatted USBs (flash sticks or hard drives) & on my FAT32 partition without any issues

There should not be a difference with the installation (EAM or EEK).

Were any versions of the old a-squared Free or new EAM Free v5 ever installed there?

In addition please provide more detailed information about your System Environment as in Forum Posting Rules #2)

Hope we will try to figure that out and the developers will reply as well

My regards

Share this post

Link to post
Share on other sites

Yes, this computer has previously had both a-squared free and an earlier version of EAM (4 point something) but both have been thoroughly removed using Revo Uninstaller.

Windows XP Professional SP3; x86; Avira AntiVir Personal Free (including Resident Shield) v.; Comodo Internet Security (Firewall only) v.5.0.32580.1142.

Share this post

Link to post
Share on other sites

Dear Lynx and Fabian - problem resolved. I just noticed after a few days that I could delete the whole folder set. Grabbed the latest installer, and it ran without a hitch. Please remove this discussion topic from the forum, as none of it is any longer relevant. Thanks again for your attention.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.