exar

for the new users - network printing

Recommended Posts

well I installed Online Armor thinking it would add a level of security... well I got that and more in return... My PC in my office has the network printer on it... and well as you surely already figured out... the FIREWALL is working properly. NO ONE CAN PRINT!...lol however the problem is that I CAN NOT find the area inside Online Armor to allow them to print on my pc.... please help

Share this post


Link to post
Share on other sites

Hi exar,

You can either Trust your interface under Firewall -> Interfaces or under Firewall -> Computers you can individually Trust only the computers on the network that you want to allow to connect to your computer, by right clicking their entries and choosing "Trust". Can you try one of these options and see if that helps or let us know if you already have the interface Trusted and it hasn't helped? :)

Share this post


Link to post
Share on other sites

I don't know what happened with him but my network printer stopped working. I did what was suggested above but no luck. When I turn off OA, I can print from everything. Any help would be appreciated.

Share this post


Link to post
Share on other sites

I don't know what happened with him but my network printer stopped working. I did what was suggested above but no luck. When I turn off OA, I can print from everything. Any help would be appreciated.

How is your network printer connected to your network? Is it connected to a router, or to another computer on the network?

Share this post


Link to post
Share on other sites

My setup is the "HP All-in-One 8500A Plus" plugged into the router and I connect to the router via wireless Win7 laptop. Both OA and EAM full versions installed.

It threw me for a loop because I had just successfully installed the printer on my other machine (XP) which is also wireless to the router. First I shut both AO and EAM down to see if I could get the printer to work at all on the laptop. And it did so I knew it had to be one or both blocking commands to the printer. Started EAM and the printer still worked; so EAM is eliminated as the culprit. Started OA and printing stopped. So at that point I knew it was OA blocking it. So then with both EAM and OA running, I further isolated the issue by turning off/on each of the individual functions of OA ie Firewall, Web Shield, Program Guard and Keyloggers. It turned out that it was the Firewall blocking the printer.

At that point I "Trusted" all computers and interfaces in the Firewall. That didn't work. Then I ran the Safety Check Wizard and trusted all installed software on the computer. That didn't work. At that point I posted the above cry for help. Since I am one not to give up or even stop with out an answer yet, I looked over the OA manual a bit and realized there was a "Learn" function in OA. I had forgotten that. I was at the end of my abilities at that point and decided to try it.

With the Firewall disabled and OA in learning mode, I opened several programs and printed from them. Maybe five different programs. Then I disabled Learning mode, enabled the Firewall and it didn't work. Then I went to the Firewall/Computers settings and saw a new entry and it was the printer that was not there before! I immediately "Trusted" the printer and I am now happily printing with both EAM and OA fully operational. Rebooted and yes! It worked! After many reboots, its still working as designed.

Solved!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.