cma6

EIS icon disappears from Win 10 notification area

Recommended Posts

EIS icon disappears from Win 10 notification area even though when I check programs loaded, EIS is shown as loaded. 

In "Taskbar Settings"/"Select which icons appear on taskbar" is set to "On".

Thanks, CMA 

Share this post


Link to post
Share on other sites

Here (with Win 8.1) various apps' icons disappear from the taskbar at random intervals.   Taskbar - Properties - Notification Area - Customise  leads to a long list of apps whose icons might be displayed and the criteria that must apply - eg whether each should always be shown, or only under some circumstances.  The settings seem to get changed by something every so often.  Also there doesn't sem to be enough space for every app's icon to show, and I have the impression that if I've run any unusual apps their icons take up space that another app's icon would normally occupy, so Windows (maybe) turns the usual one's display option off, then I don't run the new apps ever again.  But meantime the old app icon doesn't come back.  It might be something like that.

Share this post


Link to post
Share on other sites
On 11/2/2019 at 9:58 PM, cma6 said:

EIS icon disappears from Win 10 notification area even though when I check programs loaded, EIS is shown as loaded.

The component that draws the System Tray icon is a2guard.exe (probably called "Emsisoft Real-Time Protection" by the Task Manager when you're on the "Processes" tab instead of the "Details" tab). It's also responsible for displaying notifications. As as long as it's running, you should see the System Tray/Notification Area icon.

Let me know if the fix stapp recommended doesn't work.

Share this post


Link to post
Share on other sites

GT500, thanks. I am using a simpler fix, although it is not a true fix. After boot up, I click open EIS; the icon appears in the notification tray. Then I close EIS, though naturally the program is still loaded.

Share this post


Link to post
Share on other sites

Same phenomenon on two of my 5 systems after recent Win 10 update. I think it is an issue with how Win 10 handles EIS' icon.

Share this post


Link to post
Share on other sites

Try the following:

  • Open Emsisoft Anti-Malware.
  • Click on Settings.
  • Click on Advanced in the menu at the top.
  • Disable the option that says "Start on Windows startup".
  • Re-enable that option, and then restart the computer.

Share this post


Link to post
Share on other sites

Your idea is the most direct and likely will ultimately provide a fix. When I did this, I was disappointed that on reboot, EIS icon still did not show in notification area. I checked again in Advanced and was surprised to see that "Start on Windows startup" was no longer checked. I will continue to investigate this behavior and report back to you.

Share this post


Link to post
Share on other sites

According to that log, a2guard.exe should run automatically when you log in to Windows, however the log also clearly shows that it isn't running. Let's try the following, and see if it resolves the issue:

  1. Uninstall Emsisoft Anti-Malware.
  2. Restart your computer twice.
  3. Download and reinstall Emsisoft Anti-Malware from this link.

Share this post


Link to post
Share on other sites

GT500, 

I appreciate your going the extra mile. I followed your instructions but problem not solved. Taskbar settings/notification area/ always shows EIS as "Off". Every time I chage it to "On'", it reverts back to Off on next reboot. So for now, I will use workaround of clicking program open and then closing it in order to see icon in notification area.

Share this post


Link to post
Share on other sites

Would you be OK with sending us debug logs? If so, then here's what to do:

  1. Open Emsisoft Anti-Malware.
  2. Click on the little gear icon on the left side of the Emsisoft Anti-Malware window (roughly in the middle).
  3. Click Advanced in the menu at the top.
  4. Scroll to the bottom of the Advanced section, and change the option for Debug logging to Enabled for 1 day.
  5. After that, close the Emsisoft Anti-Malware window.
  6. Reproduce the issue you are having (make sure EAM is configured to run on startup, and then restart your computer).
  7. Once you have reproduced the issue, open Emsisoft Anti-Malware again.
  8. Click on the little icon in the lower-left (right above the question mark) that looks like little chat bubbles.
  9. Click on the button that says Send an email.
  10. Select the logs on the right that show today's dates (if you try to send too many logs, then we may not receive them).
  11. Fill in the e-mail contact form with your name, your e-mail address, and a description of what the logs are for (if possible please leave a link to the topic on the forums that the logs are related to in your message).
  12. If you have any screenshots or another file that you need to send with the logs, then you can click the Attach file button at the bottom (only one file can be attached at a time).
  13. Click on Send now at the bottom once you are ready to send the logs.

Important: Please be sure to turn debug logging back off after sending us the logs. There are some negative effects to having debug logging turned on, such as reduced performance and wasting hard drive space, and it is not recommended to leave debug logging turned on for a long period of time unless it is necessary to collect debug logs.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.