ajn3806

New DHCP lease un-trusts network

Recommended Posts

I have Online Armor 4.0.0.45 Free running on Windows XP Professional SP3 32-bit with a Pentium 4 3.2GHz processor. Other security software installed is avast! Free Antivirus version 5.0.677 with virus definition version 101229-0.

Whenever my DHCP lease renews with a different TCP/IP address for my wired network card in the same subnet the Firewall Interfaces tab displays "Discovering Network. Please wait.." under the description and the tick is removed from the "Trusted" column. Until the tick is manually put back under the "Trusted" column I can no longer Print to the shared printer on this computer or Remote Desktop into the computer from other computers on the same subnet.

Regards, Aj N

Share this post


Link to post
Share on other sites

I don't know if it's relevant to your particular problem, but you may want to upgrade to the latest version of OA, which is 4.5.1.431.

Do you have "New networks discovery" ticked under Options -> Firewall? If this option is ticked, you should get a popup when a new network is detected that allows you to trust it directly from the popup.

Share this post


Link to post
Share on other sites

I don't know if it's relevant to your particular problem, but you may want to upgrade to the latest version of OA, which is 4.5.1.431.

Moreover I suspect that the version of OA the OP is currently running doesn't allow individual computers to be trusted in the local network - but only the whole network.

Share this post


Link to post
Share on other sites

I have updated to version 4.5.1.431 Free and the problem still exists, refer to attached picture.

Dear fellow sufferer! I have been troubled with this, what I call a bug, since February 2009, in both OA Premium and OA++. I have complained for it several times during the years passed. Two years ago I was promised that the solution is very near, but it seems to be very near ad infinitum. I had to assure OA that my wired local network is trusted, sometimes several times an hour; my wife demanded me to remove OA from he computer, as she couldn't bear anymore to answer over and over again the question of the trustworthness of our home network, cutting her internet connection. What me matters, I have overcome this nuisance by removing the tick from Options/New networks discovery in my desktop computer; unfortunately, I cannot do this with my portable. However, I don't know whether this remedy is possible in OA Free.

Share this post


Link to post
Share on other sites

I have overcome this nuisance by removing the tick from Options/New networks discovery in my desktop computer; unfortunately, I cannot do this with my portable. However, I don't know whether this remedy is possible in OA Free.

Yeah, you can do that also in OA Free

Regards,

N.

Share this post


Link to post
Share on other sites

I've done as suggested. But what does this option really mean?

Hi, you might find useful what Webhelp says about this option:

New networks discovery – Allows Online Armor to detect new networks and lets you assign separate trust statuses to each new network via a popup. When this option is enabled, the interface status will then reflect the Trust status of the network you are currently connected to. If this option is disabled, Online Armor will not detect new networks and they will instead be treated according to the Trust status you have previously chosen for your interface. This option is enabled by default.

Link

Share this post


Link to post
Share on other sites

Hi, you might find useful what Webhelp says about this option:

New networks discovery – Allows Online Armor to detect new networks and lets you assign separate trust statuses to each new network via a popup. When this option is enabled, the interface status will then reflect the Trust status of the network you are currently connected to. If this option is disabled, Online Armor will not detect new networks and they will instead be treated according to the Trust status you have previously chosen for your interface. This option is enabled by default.

Link

I do not recall any popup messages asking to respond to a new network that has been detected. The DHCP addresses that have been leased to the wired desktop would eventually be repeated also. I bet if 10.7.3.4 was allocated again after a couple more leases with different IP addresses expire OA would not remember the previous status for 10.7.3.4. Anyway, shouldn't OA be able to work out the gateway is always the same device via the MAC address returned?

Share this post


Link to post
Share on other sites

Anyway, shouldn't OA be able to work out the gateway is always the same device via the MAC address returned?

Sorry, I don't understand your question very well. Are you asking if OA is able to lookup external IP address (geteway) regardless of the network adapters installed/used?

Share this post


Link to post
Share on other sites

Anyway, shouldn't OA be able to work out the gateway is always the same device via the MAC address returned?

OA detects the interface based on the IP as well as the MAC address. For an interface where the IP is constantly changing, with "New networks discovery" ticked, every time the IP changes you should get a new network popup from OA. If you don't want that, you can untick the "New networks discovery option. If you make the interface trusted and "New networks discovery" is unticked, what should happen is that OA will automatically Trust any new networks it detects without prompting you. I gather you are seeing different behaviour than this though?

Share this post


Link to post
Share on other sites

OA detects the interface based on the IP as well as the MAC address.

But if the IP is in the same subnet as last time and the same gateway device is present then I would have thought OA should consider it the same network and the previous trust status would apply?

For an interface where the IP is constantly changing, with "New networks discovery" ticked, every time the IP changes you should get a new network popup from OA. If you don't want that, you can untick the "New networks discovery option. If you make the interface trusted and "New networks discovery" is unticked, what should happen is that OA will automatically Trust any new networks it detects without prompting you. I gather you are seeing different behaviour than this though?

Correct, I have not seen a new network popup from AO.

I have overcome this nuisance by removing the tick from Options/New networks discovery in my desktop computer

Thanks, Olli Greybeard, Your advice/work around has worked my earlier leased IP of 10.7.3.4 has been updated to 10.7.3.5 and OA did not get stuck on "Discovering Network. Please wait..." and the network remained trusted. Cheers, Aj N

Share this post


Link to post
Share on other sites

But if the IP is in the same subnet as last time and the same gateway device is present then I would have thought OA should consider it the same network and the previous trust status would apply?

I'm not sure, but I suppose this could be why even with "New networks dicovery" ticked, you don't get a new network popup, if OA knows it's the same network. However, the fact that it says it's "Discovering network", makes one think that it doesn't consider it to be the same network. Maybe it's just having trouble getting the updated IP information though.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.