G11

Importing Hosts Files

Recommended Posts

Does EAM recover after some time, or do you have to restart it (or restart your computer) to get it to respond again?

Share this post


Link to post
Share on other sites

I had to restart computer with the larger hpHosts file (300282 entries). After rebooting the Hosts file was not imported.

There was no problems with a small hpHosts file (2800+ entries).

 

Share this post


Link to post
Share on other sites

There no longer appears to be a download link on the hpHosts downloads page for their full HOSTS file. What exactly did you download/import, and from where? The last full update appears to have been on March 16th, 2018 and can still be obtained on some of the old download mirrors, so I can try to reproduce this with it if necessary.

Share this post


Link to post
Share on other sites

It looks like that's too many hosts for EAM. After about 10 minutes of waiting, it eventually crashed with memory usage around 1 GB. I'll report this to QA along with the memory dump.

Share this post


Link to post
Share on other sites

FYI: I just tried this again while trying to get more debug information, and there was no crash this time, so I was able to eventually import the HOSTS file (it's extremely slow):

image.png
Download Image

image.png
Download Image

Share this post


Link to post
Share on other sites

Does EAM's memory use climb during the import and then decrease again (eg if it's building a new table while the old one is still there, then removing the old one)?

How much real+virtual memory do @GT500 and @G11 have?

Share this post


Link to post
Share on other sites

The memory usage of a2start.exe was consistently increasing during adding the HOSTS file contents, and I think that's what led to the crash the first time I tried it. The VM was only assigned 2 GB of RAM.

We added sciter support to that dialog in the latest stable version, so that more than likely has something to do with it.

Share this post


Link to post
Share on other sites

OK, thanks. I'll wait to see if this is fixed before trying to import the HpHosts lists again.

Share this post


Link to post
Share on other sites
5 hours ago, G11 said:

OK, thanks. I'll wait to see if this is fixed before trying to import the HpHosts lists again.

If you want a workaround, you can switch to the Delayed update feed and then check for updates to downgrade EAM to an older version from before this change, import your HOSTS file, and then switch back to the Stable update feed and check for updates again.

Share this post


Link to post
Share on other sites
20 hours ago, GT500 said:

If you want a workaround, you can switch to the Delayed update feed and then check for updates to downgrade EAM to an older version from before this change, import your HOSTS file, and then switch back to the Stable update feed and check for updates again.

Thanks, but I'll wait for a fix.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.