Sign in to follow this  
CraigNZ

Teredo Tunneling Pseudo-Interface on Win 7, 64-bit

Recommended Posts

I have noticed that in device manager, under Network Adapters, "Teredo Tunneling Pseudo-Interface" that used to be visible only when "show hidden devices" was enabled and Emsisoft Anti-Malware is not installed, is now shown with a yellow triangle and exclamation mark without hidden devices enabled once Emsisoft is installed and system rebooted.

Clicking on the item shows device status "This device cannot start (code 10)."

If I then uninstall Emsisoft and reboot computer, it is back to normal. This is on Win 7, 64-bit Dell Laptop.

I have Emsisoft installed on two other laptops using Win 10 and they don't have this problem.

If anyone using Win 7 can look at their network adapters/device manager and see if it is like mine.

Under "Devices And Printers" in the control panel, I can see the yellow triangle on my laptop, right-click and do the troubleshoot but cannot be fixed.

Any ideas, or is it a bug known to Emsisoft?

 

Share this post


Link to post
Share on other sites

I've tried various things, as well as advice on the link provided but still the same.

I uninstalled, then reinstalled. Then tried updating driver etc as mentioned on the link. Though I do notice that the name is slightly changed. Previously it was: Teredo Tunneling Pseudo-Interface

But upon reinstalling (using 'add legacy hardware' within device manager) it is now: Microsoft Teredo Tunneling Adapter

And as expected, I uninstalled Emsisoft Anti-Malware and then the item appears without the yellow triangle.

I then reinstalled Emsisoft and seems OK when device manager is checked. But after rebooting computer it is back to showing the same 'code 10' yellow triangle.

Share this post


Link to post
Share on other sites

Just a note adding that I also installed on another Win 7 laptop with exactly the same issue. Only when Emsisoft is installed does the issue occur. Uninstalling and is all normal.

 

Share this post


Link to post
Share on other sites

OK, officially the issue is the driver is buggy, and EAM has to disable it otherwise you may experience BSoD issues (system crashes) when there's a WFP driver (like the one our Web Protection uses) installed. There's an optional update from Microsoft that should fix the issue, however installing that update won't cause the device to start working as (from what I'm being told) EAM has actually disabled the device and it won't be re-enabled until EAM is uninstalled.

This particular device is only needed if you need to connect to IPv6 resources over the Internet, but are on a network that only supports IPv4. Most networking devices these days support IPv6, and most Internet resources are still IPv4, so it's very rare to actually need this device (which is why we disable it instead of requiring people to download and install the optional update from Microsoft).

Also, note that this isn't an issue on Windows 10:

image.png
Download Image

Share this post


Link to post
Share on other sites

Hey, thanks for updating the post! Good support.

Windows 7 is no longer supported by Microsoft for Windows Updates so I won't be using it long term, its just that my license is for 3 computers so thought I'd use the 3rd install on my Win 7 laptop. So should I just ignore the device manager warning, or should I right-click on the Teredo and "uninstall"? If I uninstall Teredo, should I reinstall EAM or will that not be required?

Thanks again.

Share this post


Link to post
Share on other sites
10 hours ago, CraigNZ said:

So should I just ignore the device manager warning, or should I right-click on the Teredo and "uninstall"?

You can just ignore it. If you ever uninstall EAM, then it start be re-enabled and start running normally again.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.