Jump to content

Unexpected installation problem

Recommended Posts


I decided to install EAM on a laptop with Windows 7x64. The program worked on it for more than 5 years, now on another laptop, with Windows 10.

There have never been problems with reinstalling and installing EAM - and suddenly I can not install the program!

The web installer starts working, but cannot download (installer database load error)

... What is the reason?

I tried it several times today, it does not work. EmsiClean does not find EAM residues in the system. What to do?

Thanks in advance!🙂

2020-05-02 19_35_36-Загрузки.jpg

2020-05-02 19_37_24-No supported product found.jpg

Link to comment
Share on other sites

The EAM 'sales' page has a small link, just under the "free trial" button, to "alternative installation options".   Some installers are small, but have to go to servers to download the real installer *which is fine, unless that server is unavailable).   Other installers are much bigger but include the program code.    You should perhaps try one of the big installer files, either Inno or MSI.

  • Like 1
Link to comment
Share on other sites


Thanks Jeremy!
However, everything is not so simple ... 😉
Of course, I tried the MSI installer as well. However, there is a problem!
The installer reports that there is already a newer version of the program in the system and offers to remove it through the Windows control panel.🙁
But in the system I do not have EAM on this PC!
Of course, the screen is in Russian, but I wrote what was reported there.
I can assume that the installation problem is related to the fact that licensed EAM has been working in this system for several years. Now he is on another computer!
But why is it impossible to reinstall EAM on this computer?
At least in the Free version ?!

2020-05-03 08_35_26-Установщик Windows.jpg

2020-05-03 08_35_13-Установщик Windows.jpg

Link to comment
Share on other sites

You said Emsiclean doesn't find anything, so this is definitely something @GT500 will have to answer.    It might be worth running the diagnostic program and attaching its log, for him to look at. See:



Also you said you'd tried the MSI installer.  Did it create a log file - usually they're found in %TEMP% with names like: MSIxxxxx.log    (the xxxxx is a 'random' string of hex digits.  If you have lots of such files find the one whose timestamp is for when you tried the install).    If there is one, attaching it might tell Arthur what specific part of its processing hit a problem.

Link to comment
Share on other sites

If MSI logging is not on (it's quite likely it's not on because logging slows down installs of Windows updates etc), then you can turn it on if you're willing to update a registry entry.  See: https://support.microsoft.com/en-us/help/223300/how-to-enable-windows-installer-logging     Turning off logging is done by deleting the registry value, as described.

Note that at the top of that page there's a list of every version of Windows this works for... and oddly Win 7 is not on the list, but the even older XP is.  However I've found advice elsewhere that suggests it does work for W7.   When choosing which flags to set, I usually choose "voicewarmup" ie I leave "x" and "+" not set.  Beware of setting "!" as that forces the log file to be closed after every line is added, which makes logging very very very slow (it's meant for situations when the machine crashes during an install and you want the log file, which you'll examine after a reboot,  to be as uptodate as possible).

Most users never turn this on.   I tend to have it on because when installs fail it can be a good place to look for reasons why. 


Alternatively, try the Inno installer.  Once you've downloaded it, make a shortcut to it.  Then edit the shortcut's properties to append  ' "/LOG"'    to the command,   that is: a space, a double quote, a slash, LOG and a trailing double quote.   Save it, then double-click the shortcut.  Have a quick look in %TEMP%; if adding the log parameter worked you'll see that a file with a name like "Setup Log yyyy-mm-dd #001.txt" has been created.  If there's no such file stop the installer, go back and look at the changes you made to the shortcut.   Hopefully you'll end up with a log from the Inno process, which again /might/ tell Arthur how, if it also fails to install EAM, how it made that check.

Link to comment
Share on other sites

Just in case.. you aren't trying to install it in a limited user account are you?

Make sure in Settings..Apps and Features that you have selected to install Apps from anywhere (top option drop down box.)


Link to comment
Share on other sites


God, how complicated it is!
But why so ?!
I have been using Emsisoft for almost 9 years - I come across this for the first time!
Jeremy, the problem is on Windows 7x64.
There are no logs in the system after trying to install - but I'm not sure about this - we must try to install and see again.
What dear stapp says - I don’t understand at all!🙁
What kind of "limited user"? and where such settings in the installation file ?!
Now in my Windows 7 there is no EAM, no folders, files, traces in the registry!
Even the epp drivers are removed. After all, EmsiClean does not find traces!
So why, what is the reason that I cannot install EAM in the system?
Launched EEKit - everything is clean!
Link to comment
Share on other sites

At least we know it's Windows 7 now 😀

I meant what kind of user account you were using.. administrator?

Anyway it may not matter know we know it's Windows 7.

Have you used your Emsisoft account to move your key from Win 10 to Win 7 ?

Or do you mean you have bought another key?

Link to comment
Share on other sites

Yes, this is Windows7)

No, my license key has been transferred to Windows10 (another laptop).

For some time I worked on an old laptop a little and without EAM!

Now I want to install it again on Windows7, but the key is NOT MOVABLE.

I plan to use it only as a scanner so far, without real-time protection. After all, is that possible?

But the fact is that it doesn’t even reach the introduction of a license key - I can’t install the program at all!

Yes, I downloaded the installation file through my account, i.e. with registration!

Ok, now I just did everything according to the instructions - I went into my personal account, where the option -Set protection - chose an alternative bootloader - 64-msi. downloaded it and now try again to install on Windows 7.😉
Link to comment
Share on other sites

Complicated...  Why?   We don't know either.   But logs /might/ help work out why.

Try the Inno installer, with its logging turned on, as I suggested.  If the log file is created it /might/ say why the process thinks EAM is still installed.


Link to comment
Share on other sites

Ok, done!🙂

I took the Inno file - and the installation went right the first time and without any problems!

Of course, I don’t understand what is the reason for the previous failures (msi & web)🙄

- but now I managed to install EAM on the old computer as a scanner)

Thank you all for your desire to help!

2020-05-03 18_55_49-Свойства_ EmsisoftAntiMalwareSetup.exe.jpg

2020-05-03 18_59_54-Emsisoft Anti-Malware.jpg

Link to comment
Share on other sites

Well, I'm glad it worked (if it did?).  Maybe the Inno installer checks different things, or fewer things, than the MSI ones?  Did you actually run the install with logging on?

Your screenshot shows no protection is actually running though, even though it also suggests it's uptodate ("last update 6 mins ago"). 

You said you wanted it to run "just as a scanner, with no real-time protection".   Why?   If you context-scan a known-bad file, does the scan actually tell you the file is bad?

Link to comment
Share on other sites

It so happened that
I rarely use an old laptop with Windows 7 to work on the Internet.
For this, a new one with Windows 10)
Therefore, installing full protection in real time is not necessary. Enough scanner!
That is exactly what I wanted. It was simply amazing that it was not possible to install EAM after a complete removal!🙄
But now everything is OK!
Unfortunately, the reason is not clear - well, let it be)
p.s. On Windows 10, EAM works without problems!
Link to comment
Share on other sites

I think the overhead of having full protection turned on is so small, you'd be better to have it on.   Otherwise, you'll have to be very careful and also - probably - run full scans of all the files on the machine much much more often than you would otherwise, to be sure that nothing bad has sneaked onto the machine.

Link to comment
Share on other sites

On 5/3/2020 at 6:49 AM, JeremyNicoll said:

I know you were already able to resolve this, however please note that the log from this tool that @JeremyNicoll linked to would have allowed me to determine if there were any leftovers from a previous installation preventing reinstall.

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...