Jump to content

Windows 10 2004: MsMpEngCP.exe high CPU


Recommended Posts

So, I was feeling adventurous and updated to the new Windows 10 2004 version (19041.264), released yesterday/today. I know, I shouldn't have. All seems ok, except that I'm noticing high CPU usage from both MsMpEngCP.exe and MsMpEng.exe. Not constantly high. but in spikes.

Aren't these Windows Defender and its scans? What's strange is that I've always had Defender disabled entirely. It looks like it doesn't want to stay disabled? Perhaps there's some sort of conflict with EAM and the new Windows version?

Link to comment
Share on other sites

No problem here with new 2004 and EAM.

If you open Windows Security shield from the taskbar icon and then click on Virus and protection what does it say?

Also have you done a full restart of your machine since the 2004 update?

 

Link to comment
Share on other sites

6 hours ago, Quirky said:

Aren't these Windows Defender and its scans?

Correct, those are Windows Defender processes.

 

6 hours ago, Quirky said:

What's strange is that I've always had Defender disabled entirely. It looks like it doesn't want to stay disabled? Perhaps there's some sort of conflict with EAM and the new Windows version?

Windows is supposed to automatically turn off Windows Defender's protection when a third-party Anti-Virus is installed and its protection is active.

Do you have the beta of Emsisoft Anti-Malware 2020.6 installed?

Link to comment
Share on other sites

Thank you both. Yes, I restarted several times. No, not using the beta. I meant that it I disable Defender manually, usually via the reliable O&O ShutUp10 tool. So, even if I temporarily disabled or uninstalled EAM, Defender did not kick in automatically. This is probably why I don't ever remember seeing those processes at all in Task Manager, Defender was permanently turned off.

I think I've solved this though, hopefully. I tried accessing Defender's settings but couldn't, so:

1. Uninstalled EAM
2. Enabled Defender, restarted
3. Turned off Tamper Protection, disabled Defender, restarted (never had to do this in previous W10 versions - not sure if it's recommended to do, even if using another protection software)

From this point on, those two processes were finally gone. Re-installed EAM and restarted a few times. Everything looks good. Next time I see these processes, I'm back at 1909. 😬

Link to comment
Share on other sites

20 hours ago, Quirky said:

3. Turned off Tamper Protection, disabled Defender, restarted (never had to do this in previous W10 versions - not sure if it's recommended to do, even if using another protection software)

It's necessary to turn off Tamper Protection in 1909 before disabling Windows Defender as well (I ran into that in February when I installed a new motherboard, CPU, and RAM and did a fresh install of 1909). Unfortunately installing feature updates re-enables a lot of the things that ShutUp10 disables, and I think every Feature Update I've installed has turned Windows Defender back on.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...