Jump to content

a2start on beta 10204 memory use


JeremyNicoll
 Share

Recommended Posts

Win 8.1 64 bit

I can't remember what a2start's memory use normally is, but right now mine has (according to Process Hacker) a "Private Bytes" value of 1.43 GB and a /working set/ of 1.38 GB.

 A custom scan (which looked at 1.4m objects) finished about an hour and a quarter ago; that ran with debug-logging on.    Debug-logging has been disabled and re-enabled since then, without affecting a2start's memory use.

 

I understand that this working set is only /virtual storage/ but commited pages still have to be backed in either RAM or the page file.  I've 8 GB RAM and just over 8 GB of pagefile, so about 16.1 GB is the maximum amount of commitable vs ... and on that basis 1.38 GB doesn't seem like a vast amount - about 8.6% of the system's overall maximum.

But it's still the largest WS of any application on the system by a huge margin.

Link to comment
Share on other sites

Memory use stayed high for ages, and then at some point yesterday it fell markedly, don't know why.

This morning, restarted but still using 10204, it was initially about 80 MB but climbed, going up by maybe 3 or 4 MB an hour.

At noon, I installed the 10209 beta, and it started with WS 70 MB but three hours later (and I've been away from the pc for quite a lot of that time) it's reached 87 MB.

Link to comment
Share on other sites

  • 4 weeks later...

The memory leak that was responsible for the extreme RAM usage was fixed in 2020.7

We are aware that he issue is not completely gone, though.

This will be further improved in release 2020.8, where a new Sciter version will be implemented that fixes related issues in the Sciter engine.

 

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...