Jump to content

Is Emsisoft blocking my router access?


Ull
 Share

Recommended Posts

I cannot accesss my BT router management page from my PC, but I can from WIFI.

Does Emsisoft block access?

Windows 10 Pro 64bit v 1909

Firefox 83.0

I changed the IP address using the WIFI but still no access from my PC.

I have NordVPN installed but it is not connected.

 

Link to comment
Share on other sites

33 minutes ago, Ull said:

I cannot accesss my BT router management page from my PC, but I can from WIFI.

Does Emsisoft block access?

Windows 10 Pro 64bit v 1909

Firefox 83.0

I changed the IP address using the WIFI but still no access from my PC.

I have NordVPN installed but it is not connected.

 

Are you using 192.168. 1.254 ?

A lot of the BT router urls seem to be http.

Does this work?

http://bthomehub.home/html/home/home.html

Link to comment
Share on other sites

That url goes to an https warning page saying bt doesn't use https. Which is odd as your url is not https.

I tried changing it to http but it just goes to the https unavailable page again.

I normally use 254 but changed it to 40 to see if it helped, it didn't so I changed it back to 254.

Link to comment
Share on other sites

The machine I am on has no wifi just an ethernet cable.

I have just checked again, went to the hub url, entered my password and was allowed in.

I have no idea why you cannot get in:(

Mine is an older version of the home hub but that shouldn't matter really.

Have you tried without EAM running?

Link to comment
Share on other sites

Well, I solved it, but not in a good way.

The only way I can get it to work is by shutting Emsisoft down completely (before I was just pausing it), and then activating NordVPN!

Then I can connect to the hub.....but

If I shut Nord down, the connection to the hub is lost.

If I keep Nord connected then launch Emsisoft, the connection to the hub is lost.

So it seems that Emsisoft doesn't like Nord or vice versa.

Link to comment
Share on other sites

Firefox v83 introduced a new facilty which forces FF to use https connections.  I know about this because I read the "What's New" page (when Firefox tells me a new version is available.  I don't let FF just install new versions - maybe if I did I wouldn't have the opportunity to read about those changes?   You can also get to the release notes for the version you're using by: Help - About Firefox -  What's New.

See: https://blog.mozilla.org/security/2020/11/17/firefox-83-introduces-https-only-mode/

It's not supposed to be on though.  But maybe you've turned it on by accident, or maybe there's a bug in the way it works.

Link to comment
Share on other sites

11 hours ago, JeremyNicoll said:

Firefox v83 introduced a new facilty which forces FF to use https connections.

This could be part of the problem. Any attempt to force HTTPS for websites (or devices that use website-like interfaces for configuration) which don't support it ends up in websites that won't load, often with cryptic error messages that don't tell you the fault lies with the web browser or an extension that tried to force the connection to use encryption when it wasn't supported.

This is why I tell people not to use extensions like "HTTPS Everywhere", because it's not necessary on most websites that support HTTPS, and it breaks the ones that don't support it.

 

12 hours ago, Ull said:

So it seems that Emsisoft doesn't like Nord or vice versa.

It's not abnormal for VPN's to have issues with Anti-Virus software. Some VPN service providers actually tell users to uninstall their Anti-Virus software rather than deal with the compatibility issues. It doesn't help that most VPN providers will just use OpenVPN's drivers for creating virtual network adapters rather than developing their own tech, and they may not actually want to make any serious changes to those drivers to try to resolve issues with third-party software.

One thing you can try is uninstalling the VPN software, and setting up connections to your VPN via Windows built-in VPN settings. There are instructions for adding the VPN connection on Windows 10 at the following link:
https://support.nordvpn.com/Connectivity/Windows/1047410092/How-to-connect-to-NordVPN-with-IKEv2-IPSec-on-Windows-10.htm

Link to comment
Share on other sites

I have the following solution with Firefox:
Enter fritz.box in the address bar
the lock symbol next to the address should then be crossed out
Click on the lock symbol with the left mouse button
A menu opens
Switch off the menu item: "Only https mode".

Emsisoft isn't the problem.

I have the German version of Firefox, so the English version could differ a little.

Please excuse my bad english.

Link to comment
Share on other sites

9 hours ago, Optimist said:

I have the following solution with Firefox:
Enter fritz.box in the address bar
the lock symbol next to the address should then be crossed out
Click on the lock symbol with the left mouse button
A menu opens
Switch off the menu item: "Only https mode".

Emsisoft isn't the problem.

I have the German version of Firefox, so the English version could differ a little.

Please excuse my bad english.

Your English is excellent.

The only thing I'd add is that in your case entering "fritz.box" in the address bar only makes sense for someone who is using a "fritz box" (which is a combined broadband modem/router) - see: https://en.wikipedia.org/wiki/Fritz!Box  and it also presumes that either there's an entry in your hosts file which translates the name "fritz.box" to the box's LAN ip address, or (more likely?) that users of these boxes usually configure their systems to use a local DNS server on the fritz box so that when the browser asks the box where the device named "fritz.box" is, it says "I'm here" and the browser is then able to see the admin interface.

Link to comment
Share on other sites

Thank you one and all for your responses.

Jeremy - I have that Firefox https function turned off, however, when I type in the IP address it adds the https every time.

I have spoken to BT and to Nord, they are as mystified as me.

I looked at fritzbox but can't see how that can help.

I do not see a padlock next to the address bar, just an exclamation mark, which, when clicked, shows a red text message saying "Connection not secure".

I also looked at the windows method of connecting but it seems to have a few potential security issues, it's a bit beyond my understanding to know if those risks are serious.

I think that as I can connect to the router via WIFI, I'll just settle for that. A bit inconvenient, but not earth shatteringly so.

 

Link to comment
Share on other sites

Can I suggest you try this in Firefox "safe mode" - see: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Also, how often do you clear cache, history, cookies, site data etc?  I clear ALL of that, usually once per day.  But some people hardly ever clear stuff (which has the advantage that FF remembers things for you but the disadvantage that you don't know what it is remembering).

There's some suggestion (at:  https://stackoverflow.com/questions/30532471/firefox-redirects-to-https  - which I realise is an old Q&A) that "site preferences" might be the cause.  Googling for help on how to control site preferences suggests: via Tools - Options - Privacy & Security - Cookies & Site Data - Manage Data ... but then the display (at least for me) only shows cookies. I /assume/ that site data is the list of things you can see for a site if, when connected, you click the shield and/or padlock to the left of the URL bar (or right-click the page, choose Page Info, and then explore the Permissions and Security tabs). 

The suggestion to clear "site preferences" has been up-voted 200 times, so it must be a good possibility.  However, if you've intentionally (or otherwise) stored lots of preferences, losing those would be annoying.

There's also suggestions about various internal settings in FF (accessed via  about:config).

 

If nothing there helps, I'd suggest you ask on the Firefox support mai list; you can find info about that at: https://lists.mozilla.org/listinfo/support-firefox  Be aware that that's a public forum, and not everyone who answers questions is an expert, but there are people there who know far more about FF than I do. 

Link to comment
Share on other sites

13 hours ago, JeremyNicoll said:

Can I suggest you try this in Firefox "safe mode" - see: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Also, how often do you clear cache, history, cookies, site data etc?  I clear ALL of that, usually once per day.  But some people hardly ever clear stuff (which has the advantage that FF remembers things for you but the disadvantage that you don't know what it is remembering).

There's some suggestion (at:  https://stackoverflow.com/questions/30532471/firefox-redirects-to-https  - which I realise is an old Q&A) that "site preferences" might be the cause.  Googling for help on how to control site preferences suggests: via Tools - Options - Privacy & Security - Cookies & Site Data - Manage Data ... but then the display (at least for me) only shows cookies. I /assume/ that site data is the list of things you can see for a site if, when connected, you click the shield and/or padlock to the left of the URL bar (or right-click the page, choose Page Info, and then explore the Permissions and Security tabs). 

The suggestion to clear "site preferences" has been up-voted 200 times, so it must be a good possibility.  However, if you've intentionally (or otherwise) stored lots of preferences, losing those would be annoying.

There's also suggestions about various internal settings in FF (accessed via  about:config).

 

If nothing there helps, I'd suggest you ask on the Firefox support mai list; you can find info about that at: https://lists.mozilla.org/listinfo/support-firefox  Be aware that that's a public forum, and not everyone who answers questions is an expert, but there are people there who know far more about FF than I do. 

Thanks for the advice.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...