Jump to content

Installation issues

Recommended Posts

I have downloaded the Console and created a workspace.  Then clicking 'Install protection' gives me EmsisoftAntiMalwareWebSetup_de718bc8-c9b8-4848-97f1-3cdd73b345ea.exe in my Download folder.  So I ran that but then my console doesn't recognize it and still says 'Waiting for new devices to be installed.'

What am I missing?

Link to comment
Share on other sites

Were you able to complete the Emsisoft Anti-Malware install?

If so, then open Emsisoft Anti-Malware and check in the lower-right corner "below the "Settings" tile) to see if it says it's managed by your workspace:


Link to comment
Share on other sites

After opening Emsisoft Anti-Malware I see no new window or tab.  In my Console the Settings in on the lower left.  There is no indication of being managed.

Now I have a window advising me to restart and try again.  I'll report back later.

Link to comment
Share on other sites

2 hours ago, Young Geezer said:

After restart, opening Emsisoft Anti-Malware causes two Emsisoft tasks to show in Task Manager, both with 0% CPU.  

Am I supposed to click Install Protection again?

What version of Windows are you running?

Is this a brand new installation of EAM, or did you have it before?  If you didn't have it before did you have some other anti-virus or anti-malware product?  And if you did are you certain you completely uninstalled that properly?

In Task Manager rather than using its "Processes" tab, which is vague about things, click on the "Details" tab and sort (by clicking on the column title if needed) on the "Name" column.  Most of the EAM things have names that start with "a2".  I'd expect to see a2guard.exe, a2service.exe and a2start.exe, and also (not an a2-thing): eppwsc.exe     Which ones do you see?


Also, when you open the EAM GUI, the lefthand tile (named "Protection") should be green and have four ticks on it (as in GT500's screenshot in the second post of this thread).  Do you see it in green with four ticks?


Does the "major problem - please restart" window come from Windows or from EAM, can you tell?  Does it say anything else, eg mentioning any of the a2-things or any other .exe?   Do you know how to check your system's "event logs" to find out what the "major problem" actually was?

Link to comment
Share on other sites

Windows 10 Home, 20H2.   Didn't have EAM, using Comodo CIS until I have something to replace it.  Am I supposed to be 'naked' while installing EAM?

No a2... processes running in Task Manager.

My EAM GUI looks like my screenshot: no left-hand tile, just a menu item for Protection Policies.

I understood the 'major problem' popup to be coming from EAM, no mention of a2-things.  

It's not really worth it to me to check, or learn to check, event logs for this.  Comodo CIS was a trouble-free installation and I've been using it for years.  Recently its CPU usage has been climbing so I wanted to try something else.

Link to comment
Share on other sites

> Am I supposed to be 'naked' while installing EAM?

I think it's normal to be unprotected while installing any main anti-virus/-malware product.  I think there's at least a possibility that having an existing product installed would get in the way of EAM installing itself.  Does Comodo CIS have a "real time" monitor part that may have prevented parts of the EAM install from running?  Would its logs tell you that?    It's also quite likely that if EAM did install ok, that Comodo might prevent it from running properly.  I would have expected the EAM installer to warn you that existing products should not be active at the same time, but maybe it doesn't do that.  It's ages since I last had to install from scratch.  @GT500will need to address that issue.  

When I install, I fetch full installers (ie not stubs that only work if one is online) and also (if needed) full uninstallers for any product that's already installed.  I then get rid of the old one and install the new one while the machine is not connected to the internet.  Once the new thing is installed and complaining that it's not uptodate, I let it connect.  But I am not typical...


> My EAM GUI looks like my screenshot

That isn't the EAM GUI (ie the thing that GT500's screenshot showed).  It's the browser-based console (which so far I've never used because I've never had a need to use one machine to manipulate another's machine's settings).  The GUI is opened by clicking the systray icon ... which looks like a small green shield (at least it's green when everything's ok), but if you now have no a2-.exe's running there won't be a systray icon.


> It's not really worth it to me to check, or learn to check, event logs for this

If you don't already know how, maybe not, but the event log records will say what .exe failed in what way, and that information is often helpful for any vendor looking into any problem with any crashing application.

Link to comment
Share on other sites

Comodo Internet Security may have interfered with the installation. If you have still have trouble installing Emsisoft Anti-Malware, then let's try getting a diagnostic log. The instructions and download are available at the following link:

Note: You will probably need to uninstall Emsisoft Anti-Malware and restart your computer twice before trying to reinstall. If you can't uninstall, then look for a file named EmsiClean in the Emsisoft Anti-Malware folder (usually C:\Program Files\Emsisoft Anti-Malware\) and copy it to your Desktop, then run it to remove Emsisoft Anti-Malware (you may need to run it more than once if it doesn't remove everything at first, restarting your computer after each time you run it).

Link to comment
Share on other sites

Even after getting Comodo out of the way I still get the Major problem.  So I gave up, tried Kaspersky, then ran into endless difficulty trying to remove McAfee Site Advisor.  Never could satisfy Kaspersky, so I've gone with Avira antivirus and Simplewall firewall.  Now neither of those tasks has high CPU usage, but System is running high at 35-40%.  So it goes.    Thanks for all the help. 


Link to comment
Share on other sites

13 hours ago, Young Geezer said:

Even after getting Comodo out of the way I still get the Major problem.

I think I know how to fix the issue. With Emsisoft Anti-Malware installed, try the following (assuming Windows 10):

  1. Hold down the Windows logo key on your keyboard (usually found between the Ctrl and Alt keys) and tap X to open the Power User Menu.
  2. Select Windows PowerShell (Admin) from the list.
  3. Once you can type in PowerShell, copy and paste the following command (right-click in PowerShell to paste) followed by pressing "Enter" on your keyboard to run it:
Set-Service -Name "EmsiCommService" -Status running -StartupType automatic; Set-Service -Name "a2AntiMalware" -Status running -StartupType automatic

After that, Emsisoft Anti-Malware should start working. If the error message is still open, then be sure to press OK to close it.

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...