tazman01

Cannot Connect to Internet with Firewall on

Recommended Posts

When the firewall part of OA paid 4.5.1.431 the internet will not connect. I tried to go into the firewall portion and reset the computer list and then trusted the network. This did not work. I can only connect when I uncheck and turn off the firewall. This started a couple of weeks ago but I am just getting around to looking at it. T

Share this post


Link to post
Share on other sites

Hi tazman01, welcome to the forum

1st, Please provide more detailed information about your System Environment as in Forum Posting Rules #2)

Does it apply to any connections /downloads/ updates of any Software?

or you mean the specific browser only, which is... ?

If that's just a browser then, have you tried the alternative one?

and please search whether there are some bocking rules in OA

Can you try pinging from command prompt when OA is active ?

e.g.:

> ping http://support.emsisoft.com

or your ISP?

Do you have any losses/ time-outs?

Since "..this started a couple of weeks ago", have you installed some new Software since?

Please check proxy on your LAN settings. I mean if that's changed and you were not using proxy - that will be something to think about

My regards

Share this post


Link to post
Share on other sites

I use firefox which is up to date, but also tired internet explorer with the same result.

I am using Winpatrol as well as Avast, XP Pro all updates are in place.

There have been no new installs a few weeks ago.

This is a second computer that family members use. I'm not sure if they did something to cause this but in the last few weeks I have not had the time to look at it so they've been using another computer in the house until I got a chance to look at it.

After re-booting the PC, I did some digging and turned off OA and the internet worked fine. I turned OA back on, turned off the firewall portion and the internet worked in both browsers. Once I turn the firewall back on the internet will not connect so there is a setting within OA's firewall that I cannot figure out only that when the firewall is on there I cannot connect to the internet.

The connection is a wireless connection but that is not the problem since I've narrowed it down to the firewall portion of OA, so there is a setting that is not right. This is why I went to the computer list in the firewall portion and clicked the reset list. OA then asked me if I wanted to trust the network, I answered yes. I thought this would clear up the connection, but it did not.

I've been using OA for 3 years and I'm not an expert with it but usually have no problems.

edit - pinging http://support.emsisoft.com in a command prompt works with both the firewall on or off in OA. But there is no connection in firefox (meaning I cannot reach any website if the firewall is on in OA.

Share this post


Link to post
Share on other sites

Thanks a lot for the reply, tazman01

1st, nobody knows everything & it's not easy to pin-point some issues remotely

I'm sure that after many years of using this or that FWall you will be able to fix it

If you tested what I asked for:

...pinging http://support.emsisoft.com in a command prompt works with both the firewall on or off

you are very close to solving the problem
... But there is no connection in firefox (meaning I cannot reach any website if the firewall is on in OA.

and you've tried IE

Then please, temporarily disconnect

...a second computer that family members use

As a matter of fact, is XP installed there as well?

"Trusting the network" (meaning local LAN) should work, but there can be some issues specifically related to "wireless", therefore disconnecting other nods as pointed should be a good test.

Cheers!

p.s. hmmm... :rolleyes: forgot. Since you confirmed that pinging is still working, can you please answer another Q as above can you update any Software / Security ? and alike (not related to browsing)

Share this post


Link to post
Share on other sites

After re-booting the PC, I did some digging and turned off OA and the internet worked fine. I turned OA back on, turned off the firewall portion and the internet worked in both browsers. Once I turn the firewall back on the internet will not connect so there is a setting within OA's firewall that I cannot figure out only that when the firewall is on there I cannot connect to the internet.

If you enable logging under Options -> Firewall and check the Firewall log (right click the OA icon and choose "Show Firewall log") when attempting to connect to the internet, it should show you if something is being blocked by OA. You might also check in Firewall-> Program Access and Firewall -> Rules to see if there are any red (block) entries present, in case someone accidently blocked a necessary entry there :)

Share this post


Link to post
Share on other sites

If you enable logging under Options -> Firewall and check the Firewall log (right click the OA icon and choose "Show Firewall log") when attempting to connect to the internet, it should show you if something is being blocked by OA. You might also check in Firewall-> Program Access and Firewall -> Rules to see if there are any red (block) entries present, in case someone accidently blocked a necessary entry there :)

Catprincess and others that were helping me. I apologize for the delay, but an 80 hour work week did not allow me time to work on the responses here until now.

I was able to update security programs - avast 5 and even check for updates on online armor, so the issue was just in internet access regardless of browser.

I checked the firewall log and narrowed it down to avastsvc.exe (my avast 5 antivirus). Weird though since I had already checked program access of avast and all components including avastsvc.exe and it was set to allow. Looking at the log it showed that (when trying to access the internet that avastsvc.exe was blocked TCP OUT port 80 and port 53. If I allow port 80 access the internet works fine with the firewall turned on. I did not allow port 53 and firefox works fine.

I do not know ports, but allowing port 80 now allows firefox to browse. Is this safe? Also, when I changed the rule I noticed the rule was created 5/4/2010 and the problem just started a few weeks ago - not sure why. edit - I just noticed that the date does not change after an edit so possibly my family member disabled this by mistake and that is what caused this problem in the first place.

Is it safe to allow port 80 and with this port 80 on do not allow, firefox cannot connect.

edit - this rule is for outbound port 80.

Share this post


Link to post
Share on other sites

Is it safe to allow port 80 and with this port 80 on do not allow, firefox cannot connect.

edit - this rule is for outbound port 80.

It's fine and indeed necessary to allow this for avastsvc.exe (there is no need to allow it for all programs) if you want to be able to use a browser as Avast uses a proxy to filter web traffic. However, it's generally a good idea to just exclude your AV under Options -> Exclusions as it can prevent conflicts with OA :)

Share this post


Link to post
Share on other sites

It's fine and indeed necessary to allow this for avastsvc.exe (there is no need to allow it for all programs) if you want to be able to use a browser as Avast uses a proxy to filter web traffic. However, it's generally a good idea to just exclude your AV under Options -> Exclusions as it can prevent conflicts with OA :)

I will do that. Thanks to all the help, it sounded like something simple, but I don't know my way around the program that well and I got thrown off when I originally saw the rule was set up 5/4/2010 so I brushed it off that it had to be something else (the date does not change after an edit of a rule. But my daughter must have accidentally denied the access when OA recently asked (probably after an avast update).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.