distar97

OA blocks radio sites, refuses to learn

Recommended Posts

I've had OA for a while. Generally I can add or have it learn sites and programs without

much difficulty.

I use fairly aggressive firewall settings with good results. But if Webshield is on, I cannot listen to radio sites.

They work if Webshield is off. I've tried getting it to "learn" but no luck nor manually adding sites.

As an example try www.wabcradio.com > click on "Listen Live" near the top > next page click on

"Click Here to Listen Live" down a bit down in the center (below ad copy). At this point a small window opens and a

"Loading" progress bar should appear for a few seconds. The control panel fills in and the audio auto starts...

or at least it should. I've noticed the progress bar flashes very quickly the the panel opens normally

but never fully loads.

What can I do to have OA not block radio sites like this. I've tried adding www.streamtheworld.com to the

trusted list but no luck. I cannot add the IP address I see when it works since it changes each time.

I'm sure I'm overlooking something with Webshield.

Thanks.

Share this post


Link to post
Share on other sites

OK, I got your example to work properly with Firefox after a bit of diagnosis. Are you using RunSafer on your browser? In my case the Adobe Flash Player was not installing properly, probably because it was downloaded from a Run Safer location or the way it installs is not permitted completely. I unsafered FF, redownloaded and reinstalled the Flash Player, and now all seems to work-at least I get the image of a radio and a bunch of talking from the site. No changes to Web Shield. I resafered FF and it kept working, so looks like an installation issue only. Something else to play with. :)

Share this post


Link to post
Share on other sites

Thanks SDED for the suggestion. Unfortunately it didn't work. But I'm not certain about the unsafer part.

Does this mean you went to configuration>programs and firefox.exe was set to run Safer and you changed it

to Allow (green) then reinstalled Flash?

In my case firefox.exe has always been green and set to allow. I reinstalled Flash with OA, AVG etc turned off. But no luck.

I'm puzzled as to why I can't teach OA to allow this Flash radio stream to load and run. As soon as I

deselect Webshield (by right clicking on the OA tray icon then deselecting Webshield)it works perfectly.

It's no burden for me to do this but I feel I should have better control over how OA operates.

Share this post


Link to post
Share on other sites

Sorry it didn't work for you. I actually changed FF to trusted and run normal, then redownloaded and reinstalled Flash-right click on download, run as admin. Sounds like different issues with the same symptoms.

Share this post


Link to post
Share on other sites

I'm puzzled as to why I can't teach OA to allow this Flash radio stream to load and run. As soon as I

deselect Webshield (by right clicking on the OA tray icon then deselecting Webshield)it works perfectly.

It's no burden for me to do this but I feel I should have better control over how OA operates.

Web Shield has been reported as causing issues with streaming radio in the past. If you use a program to steam radio, excluding the program folder is a workaround, however this isn't valid in your situation as it's streaming via a webpage instead. Unfortunately, you will likely need to temporarily disable Web Shield to use this site. I believe with the next release of OA though, you shouldn't have this problem with streaming radio :)

Share this post


Link to post
Share on other sites

What can I do to have OA not block radio sites like this. I've tried adding www.streamtheworld.com to the

trusted list but no luck. I cannot add the IP address I see when it works since it changes each time.

I'm sure I'm overlooking something with Webshield.

Thanks.

I'm not sure it will make a difference as I know some people have had issues with Web Shield and streaming radio, but this is worth a try. Try adding

player.streamtheworld.com to Websites as Trusted or even *.streamtheworld.com Then clear your temporary internet files and try the radio site again and see if you have any luck.

Share this post


Link to post
Share on other sites

Tried all the above suggestions..NG no luck. The only thing that works

is to unclick Webshield. Once the player is running I can go back and

enable Webshield, the player keeps working. So I'll just do this and see

if a new version of OA works better.

Thanks

Share this post


Link to post
Share on other sites

I withdrew my post above because I tried the referenced site with a number of different configurations and could not get a consistent result - sometimes I get the radio audio, sometimes audio from the advertisements. There appears to be an association with pop-ups and/or Silverlight, and the behaviour is different using IE or Firefox (with and without NoScript). However, I have not been able to determine a specific solution - apologies.

Share this post


Link to post
Share on other sites

Greetings Guys,

I have to add few remarks here, mainly in order to confirm that as pointed most likely you do have problems with OA (please see my configuration)

I tested the site on XP 32bit & win7 x64

Browsers:

- IE 8 - no problems whatsoever that poor bugger allows anything and I can listen & watch whatever I want that is streaming at the said site - no questions asked;

- The latest stable Chrome - as above

a side note : both IE & Chrome will fire up an additional window , but that's all. Perfect sound, perfect videos;

- Firefox. If I would run it in Safe Mode no questions , despite no pop-up window is needed;

- Firefox with NoScript & RequestPolicy Add-Ons indeed needs some adjustments.

The number of cross-sites is just unbearable/ enormous (!!!), but if you are patient enough and set that up - no issues again

Cheers!

Share this post


Link to post
Share on other sites
I have to add few remarks here, mainly in order to confirm that as pointed most likely you do have problems with OA (please see my configuration)

I tested the site on XP 32bit & win7 x64

I should have been as expansive as you. I tested the site with XP and W7 x64, IE8 and Fx - on XP, with and without the latest OA release - on W7 with the W7 fw. My results are similar but not the same as yours. I even got a request to allow a non-standard TCP port for IE on an XP+OA PC: IE protected mode did not like something about the player. You are correct about the need for patience. My conclusion was that browser settings are the determinant (I disable web shield on all of our PCs - it is, of course, also a determinant).

Share this post


Link to post
Share on other sites

Thank you for the reply, judson

Hmmm... I do understand that you are talking about "XP+OA", but anyway it would be interesting to see what kinda "request to allow a non-standard TCP port for IE" was that ???

Then, "IE protected mode did not like something about the player" That's not clear.

The player is just an "ordinary" (softly speaking) Flash player. I hope that the latest one is installed properly.

...and it makes no difference whether I would run "Protected Mode" or the latter is disabled

Out of curiosity I tested the site using newly installed Iron browser

wabcradio.png

Lighting fast. No issues with the said site. I really tortured it starting news/podcasts/videos simultaneously

No problems whatsoever; no delays; 4/5 contents at the same time a complete mixed mess & madness of voices & videos :blink:

& listen to the attached. Recording was reduced in quality though, in order to make the file smaller

Cheers!

Share this post


Link to post
Share on other sites
Thank you for the reply, judson

Hmmm... I do understand that you are talking about "XP+OA", but anyway it would be interesting to see what kinda "request to allow a non-standard TCP port for IE" was that ???

Then, "IE protected mode did not like something about the player" That's not clear.

XP+OA = PC with XP as its O/S plus OA 4.5.1.131 installed.

OA requested access to a TCP port number something like 3702 - I denied it - cannot remember which browser - I allow only ports 80, 443.

IE8 opened in protected mode and there was an icon in the status bar which, when right-clicked, indicated that some restricted cookies were blocked.

I'm working from memory: details may be imprecise.

PS: I wonder if the 'restricted' cookies were a consequence of SpywareBlaster - will check if I find the time. I have the most recent Flash installed - Fx and IE.

PPS: I have had Iron installed for some time - nice, fast. I also believe that IE8 is not all that bad.

Share this post


Link to post
Share on other sites

When I tried this site in IE8 I think it required connection to port 1852, a 'virtual time' port?

Site works okay for me in IE or Opera.

Lot of elements to load though.

Share this post


Link to post
Share on other sites
When I tried this site in IE8 I think it required connection to port 1852, a 'virtual time' port?

That may be the same port as here (I didn't record it, just remember that it had four digits); I don't allow 'non-standard' ports for browsers. I believe the site is (very) dependent on our respective configurations.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.