Luca Minichini

PROBLEMA: Problemi Aggiornamento OA con proxy

Recommended Posts

Buongiorno a tutti

Ho un problema nell'aggiornare OA quando mi trovo nella mia università.

Tutte le altre applicazioni (Firefox, Avira, ecc...) riescono a connettersi ad internet dopo aver inserito i dati del proxy, mentre OA è l'unico che mi da problemi...

Ecco il messaggio che trovo nella cronologia:

Aggiornamento Automatico fallito,09/03/2011 12.07.39,Nessuno,"OA: Errore Socket # 10054, Connessione resettata per peer."

Qualcuno sa come risolvere il problema???

Vi ringrazio

Luca

Share this post


Link to post
Share on other sites

Ciao Luca,

Non so se lo hai già fatto, dal tuo post non si evince chiaramente, ma se apri l'interfaccia di OA e vai in Opzioni/Generali troverai un tasto per settare la connessione ad Internet: Immagine

Da lì potrai impostare i dati del proxy.

Saluti,

N.

Share this post


Link to post
Share on other sites

Ciao Nick!

Si mi sono dimenticato di scrivere che ho impostato sia il proxy che la porta come ho fatto negli altri programmi che ho indicato sopra... L'unica differenza è che OA non funziona e gli altri si...

Share this post


Link to post
Share on other sites

Ho fatto una ricerca veloce sul vecchio forum e la maggior parte degli utenti che riscontravano problemi legati a "socket error" risolvevano riavviando il sistema. Non credo sia il tuo caso comunque.

Io controllerei che nessun componente di OA sia stato accidentalmente bloccato nella lista dei programmi. Verifica che siano tutti "trustati" e consentiti (colore verde). In particolare controlla: oawatch.exe, oacat.exe, oaui.exe, oasrv.exe, oarau.exe. Una lista indicativa degli altri la trovi qui: immagine - non considerare però il contesto dell'immagine, vale solo come utile elenco dei vari servizi.

Magari dai anche un'occhiata alle regole del firewall.

Altra cosa da fare è quella di impostare l'intervallo di update ad un'ora (Opzioni/Generali) e vedere se il problema viene risolto.

Bisogna però tenere presente che questi controlli avrebbero più senso se tu non riuscissi ad aggiornare in nessun caso. Ma tentar non nuoce - almeno così dicono... :D

Se non riesci a risolvere ti consiglio di esporre la cosa nella sezione in inglese del forum o se preferisci, dato che utilizzi una versione pay, potresti tranquillamente rivolgerti al supporto Emsisoft. Le coordinate sono qui: http://www.emsisoft.com/en/support/contact/ - tra le viarie opzioni troverai il Customer Center e la Live Chat.

N.

Share this post


Link to post
Share on other sites

Edit: se nella lista dei programmi e degli autorun non sono presenti tutti componenti di OA che ho citato precedentemente, non ti preoccupare: l'importante è che quelli presenti abbiano tutti i permessi.

Share this post


Link to post
Share on other sites
Guest CARON67

Ciao Luca Minichini

Cortesemente , in piu' , potresti postare anche un HJT Log , per avere un " quadro " piu' amplio , attinente la tua antecedente problematica , grazie

Cordiali saluti

Share this post


Link to post
Share on other sites

Ciao Luca Minichini

Cortesemente , in piu' , potresti postare anche un HJT Log , per avere un " quadro " piu' amplio , attinente la tua antecedente problematica , grazie

Cordiali saluti

Ciao CARON67,

ti allego il file che mi hai chiesto sperando possa esserti utile a risolvere la mia problematica.

Ti ringrazio

Ciao

Share this post


Link to post
Share on other sites

Edit: se nella lista dei programmi e degli autorun non sono presenti tutti componenti di OA che ho citato precedentemente, non ti preoccupare: l'importante è che quelli presenti abbiano tutti i permessi.

Ciao Nick,

ti ringrazio per le informazioni. Purtroppo non sono riuscito a risolvere ancora il problema.

Ancora grazie

Ciao

Share this post


Link to post
Share on other sites
Guest CARON67

Ciao Luca

Personalmente ti suggerisco di di-sistallare con Revo Unistaller FreeOnline Armor Firewall essendo che ha un Modulo H.I.P.S incompatibile con piu' Moduli dell' Avira ( ProActiv e AHeADTechnology ) in piu' creando delle instabilita' con il prodotto dell' Emsisoft , munendoti sempre di un Back-up antecedentemente funzionante ( esempio : Acronis , Norton Ghost , etc. )

Cordiali saluti

Share this post


Link to post
Share on other sites

Si raccomanda di non usare programmi di disinstallazione di terze parti con Online Armor.

Share this post


Link to post
Share on other sites

Ciao Luca Minichini

Cortesemente , in piu' , potresti postare anche un HJT Log , per avere un " quadro " piu' amplio , attinente la tua antecedente problematica , grazie

Cordiali saluti

Please do not request HJT logs. You are not approved to offer any support for malware removal, and this thread does not appear to be malware related.

Share this post


Link to post
Share on other sites
Guest CARON67
Please do not request HJT logs. You are not approved to offer any support for malware removal, and this thread does not appear to be malware related.
Okey JeanInMontana , many thanks but HJT Log ( in this case ) is only for one reading , is not concerning for to delete malware or more virus but only for to read incompatibility between program's and Operating System , at soon

Kind regards

Share this post


Link to post
Share on other sites

Okey JeanInMontana , many thanks but HJT Log ( in this case ) is only for one reading , is not concerning for to delete malware or more virus but only for to read incompatibility between program's and Operating System , at soon

Kind regards

There is already one person helping the user and HJT is a powerful tool if used in the wrong way can cause severe damage to the system.

Share this post


Link to post
Share on other sites

HJT Log ( in this case ) is only for one reading , is not concerning for to delete malware or more virus but only for to read incompatibility between program's and Operating System , at soon

Kind regards

Hi CARON67,

There's no incompatibility between OA (or any other OP's program) and Operating System.

The OP reported that OA is unable to update when using a Proxy - only when using a proxy.

Both Internet connection, OS and other programs are working as usual with or without the proxy.

When using a proxy at his University the OP receives a socket error (Socket Error # 10054) and OA is unable to automatically update. While at home without a proxy everything is working fine.

So all your replies and all your suggestions about third part software are not related to the topic of this thread.

Share this post


Link to post
Share on other sites
Guest CARON67
There's no incompatibility between OA (or any other OP's program) and Operating System.

The OP reported that OA is unable to update when using a Proxy - only when using a proxy.

Ciao Nick

Rispetto molto le tue opinioni ma personalmente ho testato Online Armor Firewall Free e Avira AntiVir Personal con a-squared free , invertendo tutti i programmi nella voce eccezioni ma ho riscontrato svariati blocchi , crash e instabilita' esattamente con Windows Vista e Windows Seven a 64 bit , disabilitando Windows Defender ed il Modulo U.A.C e in piu' non ho accennato antecedentemente e non ho inserito l' opzione del Proxy del Firewall ( OA ) , comunque e' un piacere condividere con te' le mie proprie umili esperienze informatiche

Cordiali saluti

Share this post


Link to post
Share on other sites

Last reply proves the user "CARON67" is a spammer. His last post (like the previous ones) makes no sense: just random quotes (mostly about third part software) and phrases.

@Luca Minichini: please ignore the replies posted by "CARON67".

Regards

N.

Share this post


Link to post
Share on other sites

Last reply proves the user "CARON67" is a spammer. His last post (like the previous ones) makes no sense: just random quotes (mostly about third part software) and phrases.

@Luca Minichini: please ignore the replies posted by "CARON67".

Regards

N.

Ciao Nick!

La risposta di CARON67 era indubbiamente inutile in quanto la combinazione OA + Avira è istallata su tutti i miei pc e non ho nessun problema.

Come mi hai consigliato tu ho scritto una mail al Customer Service e sono in attesa di una comunicazione. Quando risolverò il problema (spero presto) scriverò l'iter seguito per la correzione così se qualcuno ha/avrà il mio stesso inconveniente portà correggerlo.

Ciao

Share this post


Link to post
Share on other sites

Ciao Nick!

La risposta di CARON67 era indubbiamente inutile in quanto la combinazione OA + Avira è istallata su tutti i miei pc e non ho nessun problema.

Come mi hai consigliato tu ho scritto una mail al Customer Service e sono in attesa di una comunicazione. Quando risolverò il problema (spero presto) scriverò l'iter seguito per la correzione così se qualcuno ha/avrà il mio stesso inconveniente portà correggerlo.

Ciao

Ti ringrazio Luca. Purtroppo quell'utente era in realtà uno spammer che ha solo creato confusione in questo e in un altro thread del forum in italiano.

Già che ci sono volevo dirti che anche io nei giorni scorsi ho ricevuto un socket error relativo all'impossibilità di controllare gli aggiornamenti di programma (io non ho gli aggiornamenti delle definizioni dei virus in quanto utilizzo la versione free). La cosa è andata avanti per una mezza giornata, infatti il giorno dopo era tutto okay.

Probabilmente il problema nel mio caso aveva a che fare con i server Emsisoft momentaneamente non disponibili (può capitare a volte).

Anche se non lo hai specificato, suppongo che il tuo problema sia costante nel tempo: ogni qualvolta cioè utilizzi il server proxy della tua università.

Te lo faccio presente solo perché il fatto che la navigazione Internet funzioni normalmente significa che OA non ha problemi a gestire la configurazione con quel proxy ma solo a contattare i server per l'aggiornamento, il che è davvero strano...

Nella finestra di stato del Firewall hai notato qualcosa che non va? Voglio dire, quando navighi vedi in elenco le varie connessioni? Tutto è più o meno come appare negli esempi riportati in questa pagina o ci sono messaggi di errore? --> http://www.online-armor.com/webhelp3/FWStatus.html

Share this post


Link to post
Share on other sites

Ho notato che a differenza delle altre connessioni (Dropbox, Avwebgrt, ecc) nella casella di indirizzo remoto mi compare (utilizzando la funzione risolvi indirizzo) www.tallemu.com:http. Infatti se levo "risolvi indirizzo" compare un ip:80 ; gli altri programmi, invece, si connettono al proxy del Politecnico con un certo ip (che non ricordo) ma invece di :80 c'è :8080 . Ovviamente nelle impostazioni di OA (come per avira, ecc) ho impostato come proxy "proxy.polimi.it" e come porta 8080.

Ho come la sensazione che OA non digerisca il "secondo" 80 e lo "elimina" facendo incasinare il tutto.

Venerdì magari posto uno screen così è più chiara la cosa...

Ciao

Share this post


Link to post
Share on other sites

Infatti, il problema credo riguardi solo le connessioni ai server di aggiornamento. Utilizzi l'ultima versione di OA giusto? Lo chiedo perché non capisco da dove salti fuori quel tallemu.com dato che OA ormai da tempo è di proprietà delle Emsisoft. Quindi giusto nel caso, ti consiglio vivamente di aggiornare da casa il programma all'ultima release ufficiale.

Da quel che so la porta 8080 è un'alternativa alla porta classica HTTP ed è comunemente usata appunto per il Web proxy.

Avendo la versione free di OA non ho accesso alla finestra delle restrizioni, tu comunque dagli un'occhiata - non vorrei che in elenco fosse finita la porta 8080: http://www.online-armor.com/webhelp3/FWAdv.html#restricted

Spero comunque che l'assistenza ti risponda nei prossimi giorni - a volte passa un po' di tempo...

Ciao,

N.

Share this post


Link to post
Share on other sites

Mi risulta istallata la versione 4.5.1.431; è l'ultima???

Per quanto riguarda tallemu.com anche adesso vedo che ho diverse connessioni aperte verso quei server... Quindi quello non credo sia un problema.

Per quanto riguarda la porta 8080 ho controllato ed è tutto ok ed inoltre dovrebbe funzionare perchè Firefox ed Avira usano anche loro quella e non mi danno problemi...

Ti ringrazio per le dritte

Aspetterò la risposta dell'assistenza (sperando che il mio inglese sia comprensibile...)

Ciao

Share this post


Link to post
Share on other sites

Sì, quella è l'ultima versione.

Solo non capisco la ragione delle connessioni verso www.tallemu.com dato che quei server non dovrebbero più avere nulla a che fare con le attuali versioni di OA. Infatti quando controllo manualmente gli aggiornamenti del programma, le connessioni vengono stabilite verso www.online-armor.com

Provando col browser a raggiungere www.tallemu.com noterai che immediatamente si viene reindirizzati verso www.online-armor.com

Ora bisogna solo vedere a quali server si connette OA quando non usi il proxy: quando cioè la ricerca di aggiornamenti non restituisce errori.

Eventualmente, una volta ricevuta una risposta dall'assistenza, sarebbe opportuno accennare anche a questa faccenda dei server tallemu perché a quanto pare i problemi si limitano solo alle connessioni http coi server degli aggiornamenti.

Ciao e a presto,

N.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.