Jump to content

Emsisoft updates.


Cranfield
 Share

Recommended Posts

I  have mentioned in the past that Emsisoft updates (when I am using the PC) sometimes seem to slow my PC down to almost a halt.

Although the logs show the updates taking only a second or two, the after effect seems to last longer, today it was about 10 minutes, I even restarted to lose it.
Nothing else is running, apart from general browsing, when this happens.

My settings show, automatic updates turned on, intervals set at 1 hour and "don't run automatic updates in silent mode" box is ticked.

Is there anything I can do to prevent this happening ?

Please don't ask me to post logs, etc., thats above my pay grade. 
 

Link to comment
Share on other sites

The updates look to be having issues again. I have only had one single file update in the last 8 hours.

I've contacted Emsisoft through th GUI.

Let's see if anyone responds.

Cranfield have you tried unticking Memory Use Optimisation in the Advanced settings?

Link to comment
Share on other sites

@Cranfield- what specification is your PC?  How much RAM does it have?  Is it lightly loaded - I mean, not very busy usually, or are you often running it flat out (so the extra work when a set of updates has to replace, or be merged into, the existing signatures) would stress the machine? 

Saying nothing else is running except "general browsing" is a bit vague.  Some people have many tens of tabs (literally) open in a browser whereas others regard just a handful as normal.  Some websites use much more cpu & ram than others.  Browsers can use a great deal of RAM.

If you access Task Manager (right-click on the task bar and clicking Task Manager will start it) then click the Performance tab, then click on the "Memory" option, what sorts of figures do you see for "In Use", "Available" and "Committed"?  

For example, here, my machine has 8GB RAM in it.  Right now "In Use" and "Available" are 4.6 and 3.3 GB (which add up to about 8 GB).  But here, as well as real RAM, I have a large pagefile.sys defined, and the "Committed" figure indicates this, showing 5/16.2 GB.  The 16.2 GB figure here means that as well as the 8 GB of real RAM there's 8.2 GB of disk space being used as if it was RAM (stuff that programs need but not too urgently are written out the disk by the OS to free up real RAM), and of that 16.2 GB total, 5 GB is in use - mostly real RAM but not all of it.  Programs here could use almost 16.2 GB of memory without the machine grinding to a halt, even though it only contains 8 GB of real RAM.  When your machine goes very slow, it's likely to be running out of memory, or the cpu can't keep up with what you're wanting to do.

Link to comment
Share on other sites

@Cranfield... ok, but you need to look at the numbers every time the machine seems slow to you.  And please note the figures on the Performance tab as I said, which shows details about the sorts of memory in use.   Also when it's slow, go into the Details tab and sort (by clicking on) the Cpu column, so that the processes using the most cpu are at the top of the table.  There must be a reason for the poor performance you're seeing.

Link to comment
Share on other sites

If any of the Emsisoft processes are responsible for high CPU or RAM usage, right-click on the process that is consuming excessive CPU/RAM and select "Create dump file" send that dump file to [email protected], include a brief message of the issue.  If the dump is too large to send by email, you can use WeTransfer to send us files up to 2GB.

Link to comment
Share on other sites

Thanks for the comment SPD.

Looking through Emsisoft sections, I note in Settings that, "Don't run in silent mode" is ticked,  it then states that this "prevents interruptions  in resource intensive games or applications".
Despite this selection being made manually, in the logs it shows silent mode being enabled and disabled automatically.
Could this system override be contributing to the "interruptions" I get?
If not, how can a manual selection be overridden ?

Link to comment
Share on other sites

Do you see the arcade game character over the EAM taskbar icon?

Quote

Enter Silent mode – Silent mode ensures your full-screen sessions can proceed without interruptions by suspending updates and notifications, and silently and automatically answering alerts according to the recommended default actions. When Silent  mode is active a yellow arcade game character is displayed over the Emsisoft shield icon as a visual reminder.

 

Link to comment
Share on other sites

There's two settings that are silent-mode related:  the Updates one: "Don't run automatic updates in Silent Mode", and the Notifications one: "Don't show notifications in Silent Mode".  Neither are named "Don't run in Silent Mode" which would (perhaps) mean something completely different.

The fact that you see, in the log, EAM recording when it goes into and comes out of silent mode merely means that EAM is noticing that you're doing something (playing a game, or watching streamed video, or using a browser in full-screen rather than window mode) which might mean you don't want that full-screen use of the machine to be visually interrupted.

Just because EAM notices that, doesn't of itself mean that it will do anything differently.  Whether EAM /actually/ suppressess notifications (or prevents an update being attempted) depends on the two settings.  That is, if you're going in & out of fullscreen mode you'd hope always to see that EAM knows when that happens, in the log.

 

The arcade-game character is very small, and on my system at least where the task bar is a mustard yellow colour, the arrival of a tiny yellow smudge on the already small EAM icon is nearly impossible to see when one looks deliberately.  It'd certainly never attract one's attention.

 

You can also deliberately enter Silent Mode by clicking on the bell icon near the bottom left of the main GUI screen, or from the systray icon's menu -> Protection status -> Enter Silent Mode.  When EAM's in Silent Mode, the bell has a diagonal line drawn through it.  In that situation the arcade-game character is also visible, but in a normal full-screen use of the system you won't see the task bar icons at all, because the whole point of being in full-screen mode is that the whole screen is being used for the game, or video or whatever.

Link to comment
Share on other sites

Both Notifications and Updates are turned on and show as, "don't run updates" and "don't show notifications" respectively,  in Silent Mode.

I don't pretend to understand all the technical detail , but using basic commonsense, as I am the customer, shouldn't the Emsisoft system recognise that I am using "resource" and not overide the Silent Mode instructions to interfere with my use of those resources (which I need at the time).
Why doesn't it try again later, when my PC will be on, but idle.
That might be a very naive, simple question, but it is fair.

If it didn't priories its use of my resource, I wouldn't get the slow down and "not responding" messages, on anything I am trying to do.

Perhaps I should come off automatic updates and have a manual update at a quiet time of the day.
Is that an option ?

 

Link to comment
Share on other sites

It's not clear to me that Silent Mode is relevant to this issue.  I think what's actually significant is how busy your machine is, just before an update is attempted.

You've said before that, when the machine suddenly slows down, "Nothing else is running, apart from general browsing, when this happens".  If that's really true then you're NOT using so much resource that it'd be better to defer an update.   We really need to know whether the machine is running flat out doing that "general browsing".

My Windows 8.1, 8-year-old laptop, with the same amount of RAM as your machine (albeit also with lots of pagefile - and that's on an SSD) doesn't slow down significantly when updates arrive. 

 

 

Link to comment
Share on other sites

The slow down/seize up issue usually arrives at the first morning update, it is set for 1 hour intervals , soon after I start the laptop.
Its possible that other things are also updating at that time.
Most of my updates are set for automatic update, including Microsoft.

My point is that if Emsisoft senses that my resource is very busy, it should recognise the Silent Mode selection and update later, when resource is available.
The fact that it turns it on and off to suit itself seems odd.
Why have the option if its ignored.

Although, as I stated earlier, both Silent Modes have been selected, but there is still not any arcade icon on the Emsisoft shield on my taskbar.

Link to comment
Share on other sites

You only get the arcade icon when you take the tick out of the box for 'don't show notifications in silent mode''

The mode will not stop updates (that is not what it is for)

It will stop the update notification appearing on your screen when you are playing a game which is using all of the screen on your PC

People don't like their games etc being interrupted like this :)

Link to comment
Share on other sites

@Cranfield- "slowdown at first morning update" ... if that's so, do you mean as soon as you turn the machine on?  Or do you mean "at any time in the first hour after you start using it"?  If it's "as soon as", I'd find it hard to believe that in that instant you'd already started using the browser heavily.

But then again, do you ever properly shut down the machine?  Or do just (if it's a laptop) close the lid or briefly prod the on/off button so that it "sleeps"?  If the machine only ever suspends/hibernates (they're different) then it could be that the OS and browser etc would benefit from being stopped completely and restarted - which gives it a chance to build all its control tables afresh.  It's worth doing a full shutdown once every few days.  With my Win 8.1 system that means logging out of Windows then shift-clicking a shutdown option - an ordinary click on the option doesn't completely shut the machine down.

You shouldn't be getting updates every day; most MS updates come only once or twice a month.

When you say "The fact that it turns it on and off to suit itself seems odd."   If you mean Silent Mode ... EAM is merely telling you that it knows you're going in and out of full-screen mode (by running a game, or watching video in a full-screen or something).  It has to know whether you're in full-screen mode, so as to avoid interrupting your game, or video or whatever.  But it's responding to what YOU're doing - starting/pausing a game, starting/exiting from a video, or whatever - not changing its status "to suit itself".

The "arcade icon" is very very small.  It's just a yellow blob superimposed on the bottom third or so of the EAM systray green shield icon.

Link to comment
Share on other sites

I do not mean as soon as I turn the machine on, but usually within the first two hours, sometimes a bit later.
I only suggested this as other uses of my resource, as I have already said I do not have loads of tabs open, or download things constantly.

My conclusion is that its Emsisoft that is the problem, not my normal use of my laptop.
If it returns and causes problems I will go to manual updates and rely on the MS antimalware to pick up any slack.
I do appreciate your advice JN.

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...