ratman

High CPU usage by oasrv.exe

Recommended Posts

In the last few days I've noticed that often OA uses lots of cpu (50% and over)if I start Firefox when µTorrent is already running

Both apps stop responding so that I have to kill em or close OA.

In the latter case they're restored back to working condition.

Even restarting Online Armor keeps cpu usage to much lower level (1-15%).

Any idea

Share this post


Link to post
Share on other sites

Personally, I don't know what's going on with oasrv.exe ( Online Armor Service)when it spikes like that.

I also see the same thing at times(not often); mostly at bootup or when the OS is doing something different then normal.

I mean, for me it's not a worry(at this point).

I mean, security software always leaves a footprint to some degree, and at times does its thing, so occasionally, I see a spike in CPU and notice it's usually is oasrv.exe doing its thing. No worries. :)

Share this post


Link to post
Share on other sites

Personally, I don't know what's going on with oasrv.exe ( Online Armor Service)when it spikes like that.

I also see the same thing at times(not often); mostly at bootup or when the OS is doing something different then normal.

I mean, for me it's not a worry(at this point).

I mean, security software always leaves a footprint to some degree, and at times does its thing, so occasionally, I see a spike in CPU and notice it's usually is oasrv.exe doing its thing. No worries. :)

I'm not worried but it ain't pleasant to have apps freezing.

Share this post


Link to post
Share on other sites

Have you added all your security software with real-time guard to OA's exclusions list and vice versa?

Regards,

N.

Anything missing or wrong?

Share this post


Link to post
Share on other sites

From your screenshots: you have excluded oahlp.exe and oaui.exe. These are two GUI-related processes.

You'd need to exclude other OA executable files (or even better - exclude the whole "Online Armor" directory).

Best regards,

Andrey.

Share this post


Link to post
Share on other sites

From your screenshots: you have excluded oahlp.exe and oaui.exe. These are two GUI-related processes.

You'd need to exclude other OA executable files (or even better - exclude the whole "Online Armor" directory).

Best regards,

Andrey.

Thx

I've forgotten adding oasrv.exe to avira exclusions.

By the way I cannot add the whole folder to exclusion.

Added all OA executables to Avira exlusions....hope it works

Share this post


Link to post
Share on other sites

Added all OA executables to Avira exlusions....hope it works

It seems the best solution if you cannot add the whole folder.

You should also check that all entries both in Programs and Autoruns related to OA were set to Trusted (green).

Share this post


Link to post
Share on other sites

It seems the best solution if you cannot add the whole folder.

You should also check that all entries both in Programs and Autoruns related to OA were set to Trusted (green).

Have no OA related entries in autoruns

Share this post


Link to post
Share on other sites

Have no OA related entries in autoruns

I have entries related to some OA's drivers, however I'm using Windows XP Pro - not sure about Windows 7

Share this post


Link to post
Share on other sites

I have entries related to some OA's drivers, however I'm using Windows XP Pro - not sure about Windows 7

Can you list them

Share this post


Link to post
Share on other sites

Sorry for not replying you sooner .... been busy ;)

Think I'll do a fresh install of OA 5.

Is it possible to export my actual settings regarding programs,keyloggers,firewall etc..

Share this post


Link to post
Share on other sites

Hi ratman,

It's possible to export Firewall rules by right clicking anywhere in the Rules list and choosing "Export". Exporting Program settings is only possible via a full restore of settings. If you want to do this, go to Backup/Restore and make a backup of your settings prior to uninstalling. However, since you are opting for a fresh install, I'd probably recommended not restoring a full set of settings, at least at first. There is a better chance of determining whether the issue is settings related if you see or don't see the high CPU usage occurring with fresh settings.

Share this post


Link to post
Share on other sites

Hi

I've followed your advice not importing any firewall or program setting from my previous installation

Need some advices on using OA5

1)What's the recommended security group ?

2)I used to run web browsers,mail and p2p softwares like utorrent in protected mode(Safer Mode). Now I can only add them at a later time (the popup window the shows up every time a new program want to run has no option to run them in that mode)

3)Should I add also multiplayer games and spreadsheets to safer mode ?

4)Domains section is only needed if you want your home banking and favourite e-commerce websites to be checked for phishing (in that case you need to set them as protected) as for blocking malicious website it's easier to add them to blacklist (that is in the Firewall section)

5)In the "anti keylogger" section I only have a program (KillingFloor.exe)which has been allowed without my consent while back in the days I still used OA 4.5 I remenber I got a pop up and I was asked for letting it proceed

Mind that this program is not trusted but only allowed in the program section.

Is it normal or there's something wrong.

6)Is it still possible to set a program to only use a single cpu ?

7)What's the "Files and registry" section for ?

Hope you can help me

Thanks

Share this post


Link to post
Share on other sites

It seems that the high CPU usage is gone.

I had Utorrent (with six downloads running),JDownloader (with 5) and Firefox 4 (with 40 tabs open) working together just fine for more than an hour.

Low cpu usage from oasrv (2-3%)...apps very responsive

Share this post


Link to post
Share on other sites

1)What's the recommended security group ?

2)I used to run web browsers,mail and p2p softwares like utorrent in protected mode(Safer Mode). Now I can only add them at a later time (the popup window the shows up every time a new program want to run has no option to run them in that mode)

3)Should I add also multiplayer games and spreadsheets to safer mode ?

Yes it's a good idea to set browsers, mail clients and P2P software to RunSafer. Other programs that you can benefit from using RunSafer on include PDF readers, Office suites, internet facing games and media players. You can select the program's entry in the Program's list and click the RunSafer button to set this up.

4)Domains section is only needed if you want your home banking and favourite e-commerce websites to be checked for phishing (in that case you need to set them as protected) as for blocking malicious website it's easier to add them to blacklist (that is in the Firewall section)

I am not sure what question you are asking here?

5)In the "anti keylogger" section I only have a program (KillingFloor.exe)which has been allowed without my consent while back in the days I still used OA 4.5 I remenber I got a pop up and I was asked for letting it proceed

Mind that this program is not trusted but only allowed in the program section.

Is it normal or there's something wrong.

It should only be there if you have allowed it via a popup but without being in front of your computer it's hard to say what may have caused it to end up there. Perhaps it was running while Learning mode was active or something. If it's game you know and trust, you should just trust the program. If you don't know what it is, you can change it to blocked.

6)Is it still possible to set a program to only use a single cpu ?

The "Protection" and "Performance" sections (which is where this option is located) are only available on 32bit systems.

7)What's the "Files and registry" section for ?

It allows you to create rules to limit the access of certain application groups (ie, Trusted, Unknown, Untrusted) to specified files, folders or registry keys. You can read more about how to use it in the webhelp here http://www.emsisoft.com/en/info/oa/FilesReg.html

It seems that the high CPU usage is gone.

I had Utorrent (with six downloads running),JDownloader (with 5) and Firefox 4 (with 40 tabs open) working together just fine for more than an hour.

Low cpu usage from oasrv (2-3%)...apps very responsive

Glad to hear that :)

Share this post


Link to post
Share on other sites

4)Domains section is only needed if you want your home banking and favourite e-commerce websites to be checked for phishing (in that case you need to set them as protected) as for blocking malicious website it's easier to add them to blacklist (that is in the Firewall section)

I am not sure what question you are asking here?

Thanks for your time

Forgive for my bad english ....hope it's more comprehensible now

I was wondering what was the function of "Domains" section besides protecting home banking websites and so on

I've always added lists of malicious websites to the "Blacklists" section .... I think it's way easier than adding them one at time

It should only be there if you have allowed it via a popup but without being in front of your computer it's hard to say what may have caused it to end up there. Perhaps it was running while Learning mode was active or something. If it's game you know and trust, you should just trust the program. If you don't know what it is, you can change it to blocked.

I did not get any pop up and I'm sure learning mode had already ended by the time I tried that game

By the way that game is safe ....I've purchased it from Steam more than a year ago.I've allowed it run and go online but I've never set it to trusted

Share this post


Link to post
Share on other sites

I was wondering what was the function of "Domains" section besides protecting home banking websites and so on

If you Block or Allow a BITS job, the associated domain will also appear in the Domains list so you can manage the status of that domain should you change your mind about your original decision.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.