Jump to content

BUG in forum software (cont'd)


emwul64
 Share

Recommended Posts

There is an earlier thread titled 'BUG in forum software', but that one is closed.
There is no section to post non-Emsisoft software topics. Please allow me to post here.

It's about forum notifications.

(1) Clicking on the URL in the notification leads to me to a "Sorry - We could not find that topic"-error (2)
(3) Assuming that it is because I am not logged in, I log in, but I am not redirected to the specific post.
(4) Then I open the notifications panel of my profile and notice that the notification is not listed there.
(5) Whilst being logged in I click on the URL again, same error.

Am I the only one having this problem?

 

Emsisoft-Forum-notification-we could not find that topic-issue-28112021 053121.png

Link to comment
Share on other sites

I read emails in plain text, and have seen this problem for years.  It's because the emails that the forum software sends out contain malformed URLs, which literally contain

   ampersand  a m p semicolon

within them where there should just be an ampersand (as a separator between parameters that follow the site adress in the URL).  You can see that in the screenshot number 1 above.  That is they've generated the URL and its parameters in a form that (in HTML) you'd use to display an ampersand in some text rather than left it alone as one should do in an actual link, and when someone clicks on it the software running on Emsi's server can't make sense of the parameter string.

 

(I did try to c&p an example URL in, but the forum software is too clever and tries to convert what I pasted in to a link that one could click on, and in so doing removes from view the embedded problem - hence why I spelled it out, above.)

 

I read these emails with the Roundcube webmail program which allows one to switch between the plain text and rich text views of an email; I find that the links work ok in the rich text form.

 

> Please report an bugs/issues with the forum software to IPB.

IPB?  Is that the "invision Community" who are mentioned in small print at the foot of a forum page?  Surely Emsisoft have a commercial relationship with them?  Emsisoft are their customer, not us.  Why would it not be you who report such things?

Link to comment
Share on other sites

1 hour ago, JeremyNicoll said:

> Please report an bugs/issues with the forum software to IPB.

IPB?  Is that the "invision Community" who are mentioned in small print at the foot of a forum page?  Surely Emsisoft have a commercial relationship with them?  Emsisoft are their customer, not us.  Why would it not be you who report such things?

I do agree with this. I already spent time to elaborately report it, with screenshots and all. Most likely Emsisoft's words carry more weight, whereas my post will automatically end up in the Recycle bin.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...