Jump to content

EAM Home not opening


Recommended Posts

One of my EAM customers contacted me about an issue with the EAM Home not opening and apparently not running.  I remoted onto his machine and took a look.  Found that EAM was not in the system tray,

and would not open.  Removed EAM via Control panel and attempted a re-install but kept getting a message that it was already installed.  I then tried EMSICLEAN to remove fragments that may be causing the 

error.   Ran in Safe mode and in normal mode with restarts but not able to re-install EAM.    Trying to -re-install current  version of EAM and Windows is version 21H1 (build 19043.1415).  Customer not sure when

problem started but seems to think it happened after MS update.   Any assistance will be appreciated.

 

 

Link to comment
Share on other sites

Hello @Accumulator

We have issued an hotfix to address this issue.  One more step is needed to start the Emsisoft UI.

Open Notepad.
Copy & paste the below code to Notepad.

@ECHO OFF
CD C:\Program Files\Emsisoft Anti-Malware
a2cmd /u
a2start /warp
EXIT

Save as EAM 2022.1.1 Hotfix.cmd to the Desktop.
Close Notepad.
Right-click on EAM 2022.1.1 Hotfix.cmd and select "Run as administrator".

This will force an update of Emsisoft and then Start the Emsisoft UI using partial hardware acceleration.

Let me know if this did not work.

  • Like 1
Link to comment
Share on other sites

That hotfix worked for me!  The Emsisoft console has not been opening on my computer all week and that seemed to fix it.  We'll see if it is still ok tomorrow after a shutdown overnight.  Thanks!  I wouldn't have known about this if I had not come to search the forums.

Link to comment
Share on other sites

Running the script didn't seem to help at all.  However, I see that EAM is shown in programs and features, and that 2 processes are running.  Emsisoft protection platform, and Emsisoft protection service.  Does this mean that protection is enabled?  I am still unable to see the GUI, and have not seen any updates.  Being more of a hardware guy, I'm not 100% sure what is happening.  As always, any assistance is greatly appreciated.

Link to comment
Share on other sites

@Accumulatorthe script I provided should be run when Emisoft is installed.  If you are running it when Emsisoft is not installed then the line that issues the argument to start the UI using partial hardware acceleration does noting.

If the Emsisoft Protection Platform and Emsisoft Protection Service are running the system is being protected.

As far as updates over the weekend there weren't that many.  However, there was an issue with the BitDefender update feed that a server restart fixed.

Run the Hotfix script while Emsisoft is installed.  The GUI should start automatically if everything worked correctly.

Link to comment
Share on other sites

Add me to this list. Just noticed it this morning on my Windows 10 desktop. Emsisoft is no longer in my system tray & can't start it manually. Also right clicking on an .exe & choosing scan with Emisoft appears to be doing nothing. Unless it's scanning in the background & I can't see it. Will there be an update to fix this issue? I would prefer to wait till it's officially fixed since I can see Emsisoft is running in my task manager.   
Thanks.  

Link to comment
Share on other sites

I decided to run the hotfix this morning since since right clicking on exe files appears to be doing nothing visible to my eyes. And if it's scanning the exe but I can't see the result it's useless. Also noticed when I first logged onto my computer Emsisoft will show up briefly in my system tray for about 2 seconds before it completely vanishes. 

Is this related to this same issue? Do I need to start my own thread? Is there a fix in the work? 

Link to comment
Share on other sites

same issue here

 

I also had the Mesagebox  1:02: 

I tried to reinstall but still it doesnt opened it just didnt work..

1. I disabled all security in Windows Defender still no sign of life :(

2. did an compleate uninstall of Emisoft 

3. Restart of my PC

4. than I created the batch file :

On 1/7/2022 at 7:24 PM, ShadowPuterDude said:

Hello @Accumulator

We have issued an hotfix to address this issue.  One more step is needed to start the Emsisoft UI.

Open Notepad.
Copy & paste the below code to Notepad.

@ECHO OFF
CD C:\Program Files\Emsisoft Anti-Malware
a2cmd /u
a2start /warp
EXIT

Save as EAM 2022.1.1 Hotfix.cmd to the Desktop.
Close Notepad.
Right-click on EAM 2022.1.1 Hotfix.cmd and select "Run as administrator".

This will force an update of Emsisoft and then Start the Emsisoft UI using partial hardware acceleration.

Let me know if this did not work.

5. and run it as Administrator

 

some update routines happned 

I tried to enable Emsosoft File and Internet Protection it didnt work..

after using the registration key I was able to enable all protectio levels and the system tray icon reapeared 

Link to comment
Share on other sites

Hello,

Please try this:

Click your Windows Start Menu button and type "cmd" without quotation marks, then:

2. At the command prompt, click Run as administrator.

3. Enter this into the black window that appears and press Enter after each. Be sure to include the double quotes:

"C: \ Program Files \ Emsisoft Anti-Malware \ a2cmd" / u

"C: \ Program Files \ Emsisoft Anti-Malware \ a2start" / warp

 

Emsisoft Anti-Malware should open and it should be!

Claude

 

  • Like 1
Link to comment
Share on other sites

I have adjusted the batch script to account for non-English systems and checks the installation folder.

Open Notepad.
Copy & paste the below code to Notepad.

@ECHO OFF
IF EXIST "%PROGRAMFILES(X86)%/Emsisoft Anti-Malware/a2start.exe" (
	CD "%PROGRAMFILES(X86)%/Emsisoft Anti-Malware"
	) ELSE (
	CD "%PROGRAMFILES%/Emsisoft Anti-Malware" )
"a2cmd /u"
"a2start /warp"
EXIT

Save as EAM 2022.1.1 Hotfix.cmd to the Desktop.
Close Notepad.
Right-click on EAM 2022.1.1 Hotfix.cmd and select "Run as administrator".

This will force an update of Emsisoft and then Start the Emsisoft UI using partial hardware acceleration.

Let me know if this did not work.

Link to comment
Share on other sites

7 hours ago, Claude Bader said:

Hello,

Please try this:

Click your Windows Start Menu button and type "cmd" without quotation marks, then:

2. At the command prompt, click Run as administrator.

3. Enter this into the black window that appears and press Enter after each. Be sure to include the double quotes:

"C: \ Program Files \ Emsisoft Anti-Malware \ a2cmd" / u

"C: \ Program Files \ Emsisoft Anti-Malware \ a2start" / warp

 

Emsisoft Anti-Malware should open and it should be!

Claude

 

Just tried it. It didn't work.  

I ran the command prompt as an administrator & copy & pasted exactly as below
"C: \ Program Files \ Emsisoft Anti-Malware \ a2cmd" / u
hit enter got the system cannot find the path specified.
"C: \ Program Files \ Emsisoft Anti-Malware \ a2start" / warp
hit enter got the system cannot find the path specified.

I tried it with the quotes by the C & without. With the quotes by the C I get the system cannot find the path specified.
Without the quotes I hit enter & nothing happens. 

Link to comment
Share on other sites

Claude's advice has spaces in it that shouldn't be there, each side of the backslash characters.  So eg

"C: \ Program Files \ Emsisoft Anti-Malware \ a2cmd"    would need to be:   "C:\Program Files\Emsisoft Anti-Malware\a2cmd"

 

 

Link to comment
Share on other sites

1 hour ago, JeremyNicoll said:

Claude's advice has spaces in it that shouldn't be there, each side of the backslash characters.  So eg

"C: \ Program Files \ Emsisoft Anti-Malware \ a2cmd"    would need to be:   "C:\Program Files\Emsisoft Anti-Malware\a2cmd"

 

 

Thanks but even getting rid of the spaces it's not working. Am I missing something? 
This is what I just tried

"C:\ProgramFiles\EmsisoftAnti-Malware\a2cmd"/u
"C:\ProgramFiles\EmsisoftAnti-Malware\a2start"/warp

Also Just tried it like this
 
"C:\Program Files\Emsisoft Anti-Malware\a2cmd"/u
"C:\Program Files\Emsisoft Anti-Malware\a2start"/warp

Also with no luck.  
Thanks. 

 

Link to comment
Share on other sites

@gugarci

Try this updated batch script.

Open Notepad.
Copy & paste the below code to Notepad.

@ECHO OFF
SET EMSI_PATH=""
IF EXIST "%PROGRAMFILES(X86)%/Emsisoft Anti-Malware/a2start.exe" (%EMSI_PATH%="%PROGRAMFILES(X86)%/Emsisoft Anti-Malware")
IF EXIST "%PROGRAMFILES%/Emsisoft Anti-Malware/a2start.exe" (%EMSI_PATH%="%PROGRAMFILES%/Emsisoft Anti-Malware")
IF EXIST "%PROGRAMFILES(X86)%/Emsisoft Internet Security/a2start.exe" (%EMSI_PATH%="%PROGRAMFILES(X86)%/Emsisoft Internet Security")
IF EXIST "%PROGRAMFILES%/Emsisoft Internet Security/a2start.exe" (%EMSI_PATH%="%PROGRAMFILES%/Emsisoft Internet Security")
CD "%EMSI_PATH%"
a2cmd /u
a2start /warp
EXIT

Save as EAM_2022.1.1_Hotfix.cmd to the Desktop.
Close Notepad.
Right-click on EAM_2022.1.1_Hotfix.cmd and select "Run as administrator".

This will force an update of Emsisoft and then Start the Emsisoft UI using partial hardware acceleration.

Link to comment
Share on other sites

@geekgrrrl311@gugarci


I would like to get an Emsisoft Diagnostic Report.

Download and run the Emsisoft Diagnostic Tool from http://downloads.malwareteks.com/EmsiDiagTool.exe this is my personal server.  Currently hosting it from this location as I work on the updated version.

Attach the diagnostic report to your reply, it should be on the Desktop.

Link to comment
Share on other sites

@geekgrrrl311Emsisoft is definitely installed and and is version 2022.1.1.  We only need to force the interface to open using partial hardware acceleration.

I would like to remotely connect to your computer and try getting the Emsisoft interface to start.

We use TeamViewer QuickSupport for remote support sessions.

Please download TeamViewer QuickSupport from https://download.teamviewer.com/download/TeamViewerQS.exe

Run TeamViewer QuickSupport and Private Message me Your ID and Password that TeamViewer QuickSupport displays, do not post that information in this support topic.

Be sure to leave the TeamViewer program up on the screen and running. Closing it will terminate the session and we'll need to start over.

While I'm working, please don't use the keyboard or mouse, unless I bring the chat up and ask something. Otherwise, it moves them on my end too, and can lead to some pretty strange clicking!

Do not exit TeamViewer or turn off your computer until I give you an "All Clear".

Link to comment
Share on other sites

12 minutes ago, ShadowPuterDude said:

@geekgrrrl311@gugarci


I would like to get an Emsisoft Diagnostic Report.

Download and run the Emsisoft Diagnostic Tool from http://downloads.malwareteks.com/EmsiDiagTool.exe this is my personal server.  Currently hosting it from this location as I work on the updated version.

Attach the diagnostic report to your reply, it should be on the Desktop.

Sorry but when i click on your link I'm getting a message saying it can't be downloaded securely. 

Link to comment
Share on other sites

18 hours ago, Claude Bader said:

Привет,

Пожалуйста, попробуйте это:

Нажмите кнопку меню «Пуск» Windows и введите «cmd» без кавычек, затем:

2. В командной строке щелкните Запуск от имени администратора.

3. Введите это в появившееся черное окно и нажимайте Enter после каждого. Не забудьте включить двойные кавычки:

"C:\Program Files\Emsisoft Anti-Malware\a2cmd" /u

"C:\Program Files\Emsisoft Anti-Malware\a2start"/warp

 

Emsisoft Anti-Malware должен открыться, и так и должно быть!

Клод

 

Привет, Клод!

Спасибо большое! Попробовал как Вы сказали - Emsisoft Anti-Malware открылся, всё работает как раньше!..

Link to comment
Share on other sites

THANK YOU to all of you software experts that helpeed me resolve this.  My customer's (Emsisoft subscriber) EAM application seems to be working now after running the updated script.  If you are allowed, I would be interested in hearing what the issue was because it didn't affect all of my customers using EAM home, nor did it affect my Windows machine.

 

But, in the meantime, please know that I am grateful for your timely assistance.

 

Accumulator

Link to comment
Share on other sites

8 minutes ago, ShadowPuterDude said:

@gugarci Open an administrative command prompt.

Enter the following commands followed by pressing ENTER:

CD "%PROGRAMFILES(X86)%/Emsisoft Anti-Malware"
a2cmd /u
a2start /wrap
exit

Let me know the results.

Thanks for the reply. I'm at work I will try it around 5:00 eastern time.

Link to comment
Share on other sites

1 hour ago, ShadowPuterDude said:

@gugarci Open an administrative command prompt.

Enter the following commands followed by pressing ENTER:

CD "%PROGRAMFILES(X86)%\Emsisoft Anti-Malware"
a2cmd /u
a2start /wrap
exit

Let me know the results.

Thanks for the reply. I'm at work I will try it around 5:00 eastern time.

Link to comment
Share on other sites

18 hours ago, gugarci said:

Thanks but even getting rid of the spaces it's not working. Am I missing something? 
This is what I just tried

"C:\ProgramFiles\EmsisoftAnti-Malware\a2cmd"/u
"C:\ProgramFiles\EmsisoftAnti-Malware\a2start"/warp

Also Just tried it like this
 
"C:\Program Files\Emsisoft Anti-Malware\a2cmd"/u
"C:\Program Files\Emsisoft Anti-Malware\a2start"/warp

Also with no luck.  
Thanks. 

 

Hopefully one of ShadowPuterDude's revised scripts has fixed your problem, but to explain a bit about what you tried:

   "C:\Program Files\Emsisoft Anti-Malware\a2cmd"

was the example I gave, of a filename with spaces removed each side of backslash characters.  In your first pair of commands you tried, you also removed spaces from within the file path eg between "Program" and "Files".  That didn't work because the folder name includes those spaces.

In both your attempts you also removed the space between the full file name and the parameter to the command which is probably why they didn't work.  That is

  "C:\Program Files\Emsisoft Anti-Malware\a2cmd"/u         is no good, but

  "C:\Program Files\Emsisoft Anti-Malware\a2cmd" /u       should have worked.

That's because on Windows, commands tend to take the form: programname parameter1 parameter2 ...
and the system uses the space between the program name and the first parameter, and the spaces between parameters, to decide where each part of the command starts and stops.

Link to comment
Share on other sites

6 hours ago, ShadowPuterDude said:

@gugarci Open an administrative command prompt.

Enter the following commands followed by pressing ENTER:

CD "%PROGRAMFILES(X86)%/Emsisoft Anti-Malware"
a2cmd /u
a2start /wrap
exit

Let me know the results.

I'm not a techie & as a 6 year plus customer I'm getting frustrated since I was not planning to renew Emsisoft this year. 

Anyway just got home from work & It didn't work. 
I used an admin command prompt & I tried initially by entering one line at the time follow by enter & in the end nothing changed.
Although I saw it download something from the command prompt. Was I suppose to enter one line at the time follow by enter?  

Also copying & pasting the whole script into the command prompt followed by enter also did not work.

Link to comment
Share on other sites

@ShadowPuterDudeis there anything else I can do? I tried what you suggested last night & it didn't work. At this point EAM has not worked properly for almost a week. I've been using EAM for over 6 years & have never had any issues till now.   

Will uninstalling it & reinstalling it fix the issue. Although @Accumulatorwho started this thread had issues uninstalling & reinstalling EAM. Leaving for work soon.  

Link to comment
Share on other sites

Hello,

I have used this script with a 100% success for all customers.

Click your Windows Start Menu button and type "cmd" without quotation marks, then:

2. At the command prompt, click Run as administrator.

 

3. Enter or copy this into the black window that appears and press Enter after each line. Be sure to include the double quotes:

"C:\Program Files\Emsisoft Anti-Malware\a2cmd" /u

"C:\Program Files\Emsisoft Anti-Malware\a2start" /warp

 That is if Windows is in english.

 

Emsisoft Anti-Malware should open and it should be!

 

Claude

Link to comment
Share on other sites

20 minutes ago, Claude Bader said:

Hello,

I have used this script with a 100% success for all customers.

Click your Windows Start Menu button and type "cmd" without quotation marks, then:

2. At the command prompt, click Run as administrator.

 

3. Enter or copy this into the black window that appears and press Enter after each line. Be sure to include the double quotes:

"C:\Program Files\Emsisoft Anti-Malware\a2cmd" /u

"C:\Program Files\Emsisoft Anti-Malware\a2start" /warp

 That is if Windows is in english.

 

Emsisoft Anti-Malware should open and it should be!

 

Claude

I have not left for work yet. Leave in 15 minutes.
It didn't work please look at my attachment.  

Print Screen.jpg

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...