Sign in to follow this  
Nani

New Ports Open Up

Recommended Posts

Can someone explain to me why after successfully running a clean install of OA Premium and having no problems with OA except for the following:

When I open up Firefox (FF), which is my usual browser or even IE (to test it out), new ports open up according to OA despite running the Trust Everything during the Safety Wizard Checklist (SWC).

I have the same IP, and I am going to the same home page, so nothing is new. I don't understand why a new port would need to open up. I am currently deleting these new ports that are opening up and everything runs fine with the default ports that were created during the SWC. But it's a bit frustrating to keep track of these extra ports and having to delete them. Any suggestions? I had this same problem with the prior version as well, so I thought a clean install would help...guess not. :(

Share this post


Link to post
Share on other sites

FF uses TCP/IP for internal communication via localhost and opens ports as necessary for that. It is dynamic, based on current port usage. Is that what you are seeing? Ports also open up as local ports to provide the near end of inbound connections. And outbound connections. And there are lots of other internal connections going on. The SCW really is not involved. Dynamic ports are usually opened via a "1-up counter" so your computer will just keep opening new ports as necessary. Range for dynamic ports is 49152-65535 for Windows 7, but there also more specific ports used. You can see this happening on the Firewall Status Display, or in a bit more detail if you download currports from http://www.nirsoft.net/ . There is some discussion in the Help file at http://www.emsisoft.com/en/info/oa/Options.html#firewall of options for not adding them to rules for trusted programs, but you generally end up with popups instead if you uncheck the autoconfigure options.

Share this post


Link to post
Share on other sites

FF uses TCP/IP for internal communication via localhost and opens ports as necessary for that. It is dynamic, based on current port usage. Is that what you are seeing?

Yes, this is what I am seeing. I am using the Advanced settings of OA and seeing it under the Firewall ports log. As you stated, the number of ports is increasing sequentially. However, everything works fine when I delete the extra ports after surfing and clean my machine up. I just wanted to make sure everything was OK.

I did have everything set up as you pointed out in the link you provided for OA. Great tutorial for those that need it, BTW. ;) Thank you for your quick response.

Share this post


Link to post
Share on other sites

I don't understand why a new port would need to open up. I am currently deleting these new ports that are opening up and everything runs fine with the default ports that were created during the SWC. But it's a bit frustrating to keep track of these extra ports and having to delete them.

I'm not sure what you mean by new ports "opening up". Do you mean that, on the rules tab of the firewall, your browser is set to allow connections out to a few "default" ports (probably 80, 8080, 443 and possibly 53 and a couple of others), but that when you use it, new *rules* are created, allowing access through new ports?

If so, then you're quite right, a browser should work perfectly well for most people on only a few standard ports. In fact, other firewalls configure browsers (and some other software) with access only through the standard ports, and block all others. Otherwise, with OA automatically allowing all ports/protocols requested, it's almost like allowing the browser to bypass the firewall (albeit, with connections logged).

If, rather than keeping track and deleting the extra ports, you wanted to stop them from "opening up" in the first place, then you might like to create a rule blocking both protocols in both directions, on all ports. This should stop any new ports from "opening up" (because they're already blocked), while still allowing access through the default ports (which are already allowed). However, as sded said, lots of software talks to itself via the loopback interface, so you may find that blocking all ports causes your browser to malfunction, in which case, you should create a rule allowing UDP Out through All ports, but only to the specific endpoint of 127.0.0.1.

PS: Everything I said was referring to IE, as this machine doesn't have Firefox installed, so the loopback rule might be different (e.g. TCP In to 0.0.0.0)

Share this post


Link to post
Share on other sites

Thank you qwerty for your response. sded answered my question, and I should have put "resolved" next to my first post. But thank you for further clarifying.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.