Sign in to follow this  
qwerty

OA 4.5 fails to block ActiveX

Recommended Posts

When visiting this page, all of the ActiveX Controls are loaded.

The site isn't trusted, and I have tried setting it to "Not Trusted", clearing temp files and restarting the computer, but the ActiveX still loads.

This is strange, because other instances of ActiveX are blocked, including the Flash Player version page.

The Web Shield is enabled. OA v4.5.1.431, Windows XP SP3.

Share this post


Link to post
Share on other sites

If it's centrally trusted, probably. If I recall, there's a setting to "Ignore OA Websites list" on the Websites - > Options tab in 4.5 which makes OA ignore the centrally trusted list.

Share this post


Link to post
Share on other sites

If it's centrally trusted, probably. If I recall, there's a setting to "Ignore OA Websites list" on the Websites - > Options tab in 4.5 which makes OA ignore the centrally trusted list.

Right, now with "Ignore OA web sites list" selected (so every site should be treated as Unknown), ie.microsoft.com and microsoft.com set as "Not trusted", temp files deleted and machine restarted, the webpage still loads the same.

Share this post


Link to post
Share on other sites

Microsoft sites may possibly be hardcoded to be overridden to avoid users accidently blocking Windows updates. However, even if something isn't working as intended, since old versions don't receive bug fixes or updates and development of the version you are are using has ceased with the release of v5, there is really nothing that could be done about it unfortunately.

Share this post


Link to post
Share on other sites

Microsoft sites may possibly be hardcoded to be overridden to avoid users accidently blocking Windows updates. However, even if something isn't working as intended, since old versions don't receive bug fixes or updates and development of the version you are are using has ceased with the release of v5, there is really nothing that could be done about it unfortunately.

So, there is no support for any version prior to the absolute latest version?

If I buy a key, will it work with v4.5 or will I need to upgrade to v5?

Share this post


Link to post
Share on other sites

So, there is no support for any version prior to the absolute latest version?

Well, there are no updates (security or non security related) for versions prior to the latest release version. I guess you could say there is "limited support", in that basic questions about usage of the program can be answered.

If I buy a key, will it work with v4.5 or will I need to upgrade to v5?

Keys will work with any version.

Share this post


Link to post
Share on other sites

Well, there are no updates (security or non security related) for versions prior to the latest release version. I guess you could say there is "limited support", in that basic questions about usage of the program can be answered.

I understand that there will be no updates (v5 is the update), but is this a usage question, or do you think it's a bug?

Keys will work with any version.

Thank you.

Share this post


Link to post
Share on other sites

I understand that there will be no updates (v5 is the update), but is this a usage question, or do you think it's a bug?

My guess is that the option to ignore the centrally trusted list may not be working in the version you are using.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.