Sign in to follow this  
fabald

LocalHost

Recommended Posts

Hi,

I have Online-Armor premium 5.0.0.1100

Most of my applications ( Dropbox , Live Messanger , Firefox , IE9 , chrome ...etc ) are requesting a connection to localhost.

I did not install any proxy or VPN settings or applications , I did not change the Host file

How can i fix this issue ? I am blocking all requests to localhost , and why i have this issue ?

Thanks

Firefox1.png

IE9.png

Live%20Messenger.png

Share this post


Link to post
Share on other sites

localhost, 127.0.0.1, is your computer, and has nothing to do with the HOSTS file. It is the internal loopback network connection used by many processes to communicate with each other. See http://en.wikipedia.org/wiki/Localhost for more information. You should allow it, and have "intercept loopback interface" checked under options/firewall in OA.

Share this post


Link to post
Share on other sites

"intercept loopback interface" it is already checked even though i am still getting these messages , is that ok ?

And why are they all connect to dsn.skype.net server ?

Thank you very much

Loopback.png

Share this post


Link to post
Share on other sites

I don't use Skype, but the green messages generally say you should approve the connection and make a rule so the popup goes away. Since Skype incorporates VOIP, I suspect it uses a local proxy (localhost) to communicate with the rest of your system.

Share this post


Link to post
Share on other sites

OA intercepts DNS replies.

I guess if you'd run nslookup and resolve the mentioned skype-related addresses you'd see that they resolve to 127.0.0.1.

Best regards,

Andrey.

Share this post


Link to post
Share on other sites

OA intercepts DNS replies.

I guess if you'd run nslookup and resolve the mentioned skype-related addresses you'd see that they resolve to 127.0.0.1.

Best regards,

Andrey.

Could you tell me step by step how can i do that , because it is really annoying me

I appreciate your help

Thank you very much

Share this post


Link to post
Share on other sites

Could you tell me step by step how can i do that , because it is really annoying me

I appreciate your help

Thank you very much

1) Run cmd.exe

2) In cmd.exe type nslookup and hit enter

3) type the domain name from the popup and hit enter

4) See the result

Best regards,

Andrey.

Share this post


Link to post
Share on other sites

So what is next ?

If you have 'intercept loopback interface' enabled/checked (which is recommended), you should allow connections to localhost (which is your PC) for any trusted program - don't block, as you state at your post #1.

Many programs use localhost loopback. As long as the Program in these requests is one that you trust, you should allow them.

Share this post


Link to post
Share on other sites

I guess fabald is confused by the dsn4.d.skype.net and dsn0.d.skype.net etc. shown for a connection with the localhost (127.0.0.1).

And i agree, it's a bit confusing.

dsn4.d.skype.net dsn0.d.skype.net etc. resolve to 127.0.0.1 and OA remembers this. That information is shown again for a connection with the localhost (127.0.0.1).

If another program like firefox or iexplore wants to connect to the localhost (127.0.0.1), the stored infomation (dsn4.d.skype.net and dsn0.d.skype.net etc.) is shown again for the localhost, even if Skype isn't active.

On my machine i only noticed this after latest Skype update a few days ago.

Share this post


Link to post
Share on other sites
the stored infomation (dsn4.d.skype.net and dsn0.d.skype.net etc.) is shown again for the localhost, even if Skype isn't active.

On my machine i only noticed this after latest Skype update a few days ago.

So how can I remove or delete these stored information ?

Thank you

Share this post


Link to post
Share on other sites

fabald,

There is no need to delete that information, nslookup showed that the information is correct.

I suggest you enable these options:

I'm pretty sure those options were enabled by default to avoid popups for trusted programs.

See also: Online Armor - Best Practices

Share this post


Link to post
Share on other sites

Just curious:

The Online Help indicates, "This option allows you to change whether Online Armor will pop-up when the loopback interface is used and is enabled by default."

When one un-checks "Intercept loopback interface," it is assumed, then, that ALL popups for 127.0.0.1 are suppressed and ALL those connections are allowed by default from thereon. Correct?

Thank you!

Share this post


Link to post
Share on other sites

When one un-checks "Intercept loopback interface," it is assumed, then, that ALL popups for 127.0.0.1 are suppressed and ALL those connections are allowed by default from thereon. Correct?

Yes, that's right. With this option unticked, loopback connections are just allowed silently (you will not see any firewall rules created for them either).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.