Fabian Wosar

Emsisoft Anti-Malware 6.0 public beta started!

62 posts in this topic

Hi everyone,

We want to invite you to join the public beta test of Emsisoft Anti-Malware 6.0.

What is new?

Scanner:

  • Redesigned the dual scan engine framework for optimization of multi core systems.
  • 450% speed improvement on average - with the same things being scanned.
  • Advanced caching for self optimizing scans - it gets faster with every scan.
  • New direct disk access scan mode to improve rootkit detection.
  • Changed the scan setting defaults: Rootkit scan (new) active, Cookie scan inactive..
  • Improved handling of potential false positives.
  • Desired scan actions can now be set before the scan.
  • Detection names engine postfixes changed to !E1 and !E2.
  • Changed the animation seen during active scans.
  • Simplified the user interface.
  • Added a load scan engine animation to security setup wizard.
  • Added an option to run missed scheduled scans on next program startup.

Realtime protection:

  • Optimized program loading to greatly reduce boot time.
  • Added advanced caching to significantly improve the performance of File Guard.
  • Added an internal rating system to reduce false positives in 'real world' use.
  • Added an option to reset the File Guard file extensions list to its original values.
  • Simplified the method for viewing internal and custom host blocker rules.
  • Re-organized the guard tray icon menu to provide quick access to common features.

Licensing:

  • Changed licensing to a key-based system which replaces user accounts.
  • Changed licensing to provide a unique licence key for each computer.
  • Simplified the online licensing and relicensing dialogs.
  • Improved the notification that a license is about to expire.
  • Added a renewal rewards program - 5% cumulative reduction each renewal.
  • Added a referral rewards program to earn full version credits by referring new users.
  • Earn a 1 month credit for referring each new 1 month trial user. (no purchase).
  • Earn a 6 month credit for referring each new customer (for first purchase only, any plan).

General:

  • Simplified the setup process significantly.
  • Changed storage of settings to use 'ini' files rather than the Registry.
  • Added the ability to export and import settings by category.
  • Added security prompts when permanently deleting files, rules or logs.
  • Added improvements for more stability of online updates.
  • Added improvements to avoid potential crashes and hangs.
  • Added newsletter subscription link in news area.
  • Removed the trojan horse illustration.

Known issues:

  • The direct disk access scan feature is not available for striped RAIDs due to non-standard, 'vendor specific' systems.

Installation:

Emsisoft Anti-Malware 6.0 now asks for a license key instead of a user account. You can find this license key in the Emsisoft Customer Center (choose "Manage Licenses" on the left).

Last but not least: All trial licenses have been reset and we will most likely reset them again during and after the beta test to make sure you can participate in the public test without a paid license.

Screenshots:

A new custom scan dialog with the new Rootkit scan as well as some additional new scan options:

20110816_205629.png

Some people may notice the lack of horses in the GUI. Well, we removed them:

20110816_210457.png

The rootkit scan is able to detect MBR and file based malware. In this example ZeroAccess but TDL is covered as well:

20110816_210428.png

Two examples for the dozens of usability improvements we implemented. In general whenever you delete something you now get a confirmation dialog:

20110816_205714.png

Whenever there are settings you can edit like extension lists you can reset them to their defaults:

20110816_205809.png

When will the final version be out?

This greatly depends on the feedback and number of bug reports we receive. Our goal is to deliver a stable product and not to meet a deadline. If no more major issues are found during the public test phase you can expect a release within the next 1 or 2 months though.

We want your feedback!

Have you started or found a thread about EAM 6.0 in a different forum? Do you like or dislike a specific change? Do you have questions about one of the new features of EAM 6.0? Are you a Youtube or any other kind of reviewer and made a review? Don't keep them to yourself. Share them with us! Either by simply replying here or via mail.

1

Share this post


Link to post
Share on other sites

Great news!

Two questions:

- Is it recommend to always use the new direct disk access scan mode if you want to do a full scan of your system?

- Does the direct disk access scan mode increase the scan duration?

0

Share this post


Link to post
Share on other sites

Hello.

I see now there is !E2 after the name of the virus. There was not such before. Which engine does it mean?

0

Share this post


Link to post
Share on other sites

- Is it recommend to always use the new direct disk access scan mode if you want to do a full scan of your system?

- Does the direct disk access scan mode increase the scan duration?

Direct disk access mode is slower than regular scanning. It's not recommended to use it all the time therefore. Just ensure to check the rootkit scan option in custom scans (all other scan types include it anyway). The rootkit scan performs a DDA mode scan on the windows drivers folder to detect hidden rootkits.

0

Share this post


Link to post
Share on other sites

Installer issue: I have just installed this program to be faced by second all time personal "HATE'S" Why can I not change the install location? I have to uninstall this now before I go any further as it's gone to my C: drive. The big fat 1TB mechanical drive I have was completely ignored and Yep that tiny little SSD I have Windows installed to was used. Great. Do I bother updating it and running it the once or is your program going to write more data where I don't want it to??? Am I going to find a nice new folder in user space full of Emsisoft stuff??

PS Personal HATE # 1/ is software developers that call install programs "setup.exe" FFS how many "setup.exe's" dose one guy need :)

Thank you Emsisoft for not calling the setup program "setup.exe" but big fat minus points for not giving your users/customers the option of changing the install location.

0

Share this post


Link to post
Share on other sites

Hello!

Installed beta version of the program on a laptop running Windows 7 x64 antivirus Panda GP 2012, Emsisoft Anti-Malware is working fine, conflicts were detected.

P.S. Since Panda GP 2012 uses a built-in firewall, the settings must neobhdimo set "Allow incoming and outgoing connections" for Emsisoft Anti-Malware.

Sorry for the English, translated from Russian by Ace Translator 9.

0

Share this post


Link to post
Share on other sites

I see now there is !E2 after the name of the virus. There was not such before. Which engine does it mean?

We've changed the engine postfixes from !A2 to !E1 and from !IK to !E2.

0

Share this post


Link to post
Share on other sites

Why can I not change the install location?

You can! Our setup file supports the /DIR="x:\whatever\Emsisoft Anti-Malware" parameter for advanced users like you.

The installer dialogs have been reduced to a minimum for better user experience and simplification (like most other programs today do). The vast majority of users don't want to know where exactly a software is installed, the setup just should be quick and simple - similar to the apps concept on mobile systems.

0

Share this post


Link to post
Share on other sites

No key listed in my Emsisoft Customer Center "Manage Licenses" section.

Thanks.

0

Share this post


Link to post
Share on other sites

The problem with EAM Beta 6: after leaving the computer with sleep / hibernation, turned off active real-time protection - protection from malware - data guard. You can not start it by clicking on the Activate protection - does not respond. It helps to restart the computer and restart the application.

If you minimize to tray-to pitch tasks (Windows 7) there is no program icon.

0

Share this post


Link to post
Share on other sites

No key listed in my Emsisoft Customer Center "Manage Licenses" section.

Thanks.

Please send me a PM with your old key you used in version 5.1.

Sorry, but I can't PM you want I don't have.

0

Share this post


Link to post
Share on other sites

Hi,

Installed the beta could not have been easier. Run the scan it identidied 'pricegong' that has been previously missed by othe anti-malware programs. Had to always manually delete.

Working fine so far.

Shapur

0

Share this post


Link to post
Share on other sites

Sorry, but I can't PM you want I don't have.

Then please send me your old license code by email to info at emsisoft dot com

I'll have a look.

0

Share this post


Link to post
Share on other sites

Only license key in my account is for 2008; nothing for this version.

FuzzyRev

0

Share this post


Link to post
Share on other sites

Cannot download beta file ... download just sits there and does nothing.

0

Share this post


Link to post
Share on other sites

I having been testing 6.0.0.30 (now .31) the last few days. Install went okay, although first time I was presented with a screen asking if I wanted to delete version 5.1. I answered no and the installation hung. Retried and answered yest to removing 5.1 and installation of version 6 then worked, I assumed it would delete 5.1 automatically. I thought I had lost my 5.1 settings, but upon reboot they were still there. Full scan is much faster than 5.1. In the past I would avoid full scans as they took too long. I will now do a full scan at least monthly (scheduled scan). Version 6 seems to be getting along with my other security MBAM, DefenseWall and LooknStop Firewall. DefenseWall did flag four .ini files in EAM 6 as untrusted. I allowed them and changed their status in DW to trusted. I reported this to Ilya (DW's developer) so he can fix. So far I have no issues to report with EAM 6. Running on Windows 7 Home Premium x86.

I do have a license issue. I have around 42 days left on my 5.1 license, but version 6 does not recognize the license so I am running the 30-day trail.

0

Share this post


Link to post
Share on other sites

hey, i am having a problem with the scheduled scan, even if i select slient scan when the scan runs i still get displayed with a progress screen

0

Share this post


Link to post
Share on other sites

kenpachizero, do you use any special scan settings file? I can't reproduce the problem. The scan is executed as minimized window, showing the progress only in taskbar (win7). However, when the scan has finished, the window is brought to the top to show the results. That's expected behavior.

0

Share this post


Link to post
Share on other sites

Hey, every 3 hours i get it to scan traces/memory/cookies and the window is displayed every time it runs

0

Share this post


Link to post
Share on other sites

Hi

Everything seems fine here, although deep scans are not much quicker. But I am running an old XP/AMD Sempron Mobile 2800+ (1.6GHz) laptop.

I've auto-updated to OA Premium 5.1.0.1315 and EAM 6.0.0.31.

The auto update preserved all settings, no problems.

A couple of queries though:

EAM 6 occasionally stops the PC shutdown the same as EAM 5 did (various forum threads relate). Is this an XP fault as has been suggested?

EAM 6 seems to scan significantly fewer objects than EAM 5 (Scan Logs below).

++++++++++++++++++++++++++++++++++++++++++++++++

Emsisoft Anti-Malware - Version 5.1

Last update: 27/08/2011 06:57:13

Scan settings:

Scan type: Deep Scan

Objects: Memory, Traces, C:\

Scan archives: On

Heuristics: Off

ADS Scan: On

Scan start: 27/08/2011 06:59:09

Scanned

Files: 98130

Traces: 747937

Cookies: 0

Processes: 38

Found

Files: 0

Traces: 0

Cookies: 0

Processes: 0

Registry keys: 0

Scan end: 27/08/2011 08:44:27

Scan time: 1:45:18

+++++++++++++++++++++++++++++++++

Emsisoft Anti-Malware - Version 6.0

Last update: 04/09/2011 16:15:59

Scan settings:

Scan type: Deep Scan

Objects: Memory, Traces, C:\

Scan archives: On

ADS Scan: On

Scan start: 04/09/2011 16:18:20

Scanned 482447

Found 0

Scan end: 04/09/2011 18:03:14

Scan time: 1:44:54

++++++++++++++++++++++++++++++++++

Regards

tim-b

0

Share this post


Link to post
Share on other sites

Latest update EAM 6 crash windows explorer in windows 7 home premium - after downloaded update and restart computer.

Windows tries to run the explorer.exe process and restart the system still - loop.

You can not stop it, or run system restore.

Only helped me start in safe mode and the execution of this level to an earlier System Restore point (not the last good configuration - this solution does not work).

The last published update from 20:00 to Emsisoft Anti-Malware 6.0 Beta.

0

Share this post


Link to post
Share on other sites

The problem has been located and fixed by now. An update is currently being replicated on our update servers and should be available for everyone within the next minutes. Sorry for the inconvenience.

0

Share this post


Link to post
Share on other sites

I would say they did an excellent job on the scan engine as it's speed has increased four fold.

It used to be 3 hours to scan and now it only takes 45 minutes on a first scan. Very impressive.

Here's a test I have done:

1

Share this post


Link to post
Share on other sites

Hi Kelvinw4,

Thanks for taking the time to register and your kind words. They are appreciated :).

1

Share this post


Link to post
Share on other sites

I know this is off topic, but I find that using Online Armor Free and Emsisoft Antimalware will deliver 340/340 on the comodo leak test

:thumbs:

0

Share this post


Link to post
Share on other sites

Hello,

the detections of a2service.exe by Avast are false alerts. Please contact the Avast support so they can fix this false detections.

If you have any more questions or problems, just let us know.

0

Share this post


Link to post
Share on other sites

Thank you vodkin, that will prevent "false positives" when other people try this product out.

0

Share this post


Link to post
Share on other sites

Can I already EAM6 beta update for the computer without any problems caused by Emsisoft update released for this program?

What was the cause of this error?

Was it updated signature database, scan engine, the next beta version or update may be the development of the program was not just something completely different, having no connection with the operation of the basic anti-malware, anti virus system - such rumors circulating on the Internet.

0

Share this post


Link to post
Share on other sites

Continue to run version 6 beta with no problems. I purchased new 1-year Emsisoft AM license through SurfRight (HItman Pro). That went smooth and version 6 accepted my new license with no problems. The only suggestion I have so far is in the logs for quarantine is to add when something is removed from quarantine whether it is "restored" or "deleted".

0

Share this post


Link to post
Share on other sites

The following two issues were migrated from v5 into current beta v6

1) User can just “remove all” from the initial Custom Scan list without further adding any drives/folders & then hit Next – EAM will perform simple Quick Scan

Similar if the scanset was saved and/or used as Scheduled Scan

Produced report will identify that Custom Scan was performed. Yes it was, but ...

That is at least a bit confusing

Probably either the list should not be allowed to be empty or user should be notified about Quick Scan as a result;

2) A bit offTopic here, but anyway... another minor bug reported earlier concerning Custom Scheduled Scan.

Similarly, the Quick Scan will be performed if “Scan Settings File” does not exist (moved / line was incorrectly edited/ etc.)

My regards

0

Share this post


Link to post
Share on other sites

hey, i have the screen shot of my settings and attached(default.txt) is the a2s file i use

We can now confirm the problem. It will be fixed with one of the next beta updates. Thanks for reporting!

0

Share this post


Link to post
Share on other sites

I turned EAM6 minimized to the tray in August, when I clicked on the icon of the program in general is not responsible

it can not be run, or from the exploatora or cmd line.

Helped end the processes in Task Manager and restart the program.

Protection does not turn on file-I need to run manually in the options program.

0

Share this post


Link to post
Share on other sites

I find that when you minimize or Alt - Tab in some games such as Maplestory, the Gui seems to become like a dark square on the system tray.

0

Share this post


Link to post
Share on other sites

hi, i just got the 6.0.0.32 beta and put it on my new notebook, no hiccups so far, even with hibernation and restart.

always curious about how and where a2 is going, kind of like that name. ;-)

will keep you updated.

0

Share this post


Link to post
Share on other sites

Hi,

to english language file, line: labOrderAntiMalware=

statisfied ---> satisfied

0

Share this post


Link to post
Share on other sites

HI, another problem i have noticed is that when EAM quarantines a file and i choose to restore that file EAM then quarantines it immediately again, is there a way for me to restore the file from quarantine and add a allow rule?

0

Share this post


Link to post
Share on other sites

No, you have to create the whitelist entry for the file or folder path before restoring. Usually people don't intend to keep malware on their system.

0

Share this post


Link to post
Share on other sites

Hello,

then please disable the File Guard temporary. Restore the file and create a whitelist entry for the file. Enable the File Guard. This should work.

0

Share this post


Link to post
Share on other sites

I don't know if it only happens since this latest update (6.0.0.35) but when I click on "Update now" on the frontpage of Anti-Malware, move my mouse cursor to the "Menu" on the top left and click on "Security Status" nothing happens. I need to click on "Back to the Security Status" on the bottom left to return.

And another issue I just found: Same procedure as above - clicking on "Update now" on the frontpage of Anti-Malware and moving my mouse cursor to the "Menu" on the top left. I make sure that the cursor is somewhere in yellow marked area

.

and [ALT]+[TAB] to another window. Surprisingly the floating menu stays:

I think the reason for that behaviour is because this menu is some sort of window itself.

0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.