Sign in to follow this  
galande

Can't update signatures and rules--bad gateway?

Recommended Posts

I am running version 5.0.0.1100, and I update my firewall manually. When I try to update the sigs and rules of OA, I get a message http:/1.1 502 Bad Gateway. I also get a "bad gateway" message when I try to get to online-armor.com. I am not having any internet connectivity issues, and I am able to update Windows and my antivirus. The firewall seems to be operating normally, apart from not letting me update. Why am I getting this message? Is there a problem with the update server? Is it because I haven't downloaded the latest version of the firewall yet? Please help.

Share this post


Link to post
Share on other sites

galande,

Please try again. I just checked on 2 machines. Performed 11 manual updates and 2 updates failed with the "HTTP:/1.1 502 Bad Gateway" error.

So, the server isn't down. Guess the server is under a heavy load at the moment.

Share this post


Link to post
Share on other sites

I am seeing the same and getting a pop-up 'a2wl.dat is corrupted' - manual updating - over several days - Win XP, OA Premium.

As a 'test', I switched to automatic updates and did not have the same problem - OA/signatures updated. The issue may be with manual updates. I am using OA 5.1: manual upgrade from v5.0.

Share this post


Link to post
Share on other sites

I am seeing the same and getting a pop-up 'a2wl.dat is corrupted' - manual updating - over several days - Win XP, OA Premium.

As a 'test', I switched to automatic updates and did not have the same problem - OA/signatures updated. The issue may be with manual updates. I am using OA 5.1: manual upgrade from v5.0.

Cannot edit the above - just clarifying my post. I upgraded to OA 5.1 - manually rather than automatically - several days ago. Since then, each time that I have attempted an update (of signatures?), I have received the above errors/messages. When I enabled automatic updates, OA updated (signatures?) without any errors/messages.

Share this post


Link to post
Share on other sites

hi) I have the same thing yesterday ... when you install Online Armor program in Quick Setup mode failsclick "update" ... when trying to update manually to give an error "I get a message http:/1.1 502 Bad Gateway" at later refreshed automatically, but slowly, and in addition it is impossible to get to the sitehttps://www.online-armor.com/ and log into your account ...

Share this post


Link to post
Share on other sites

I'm also getting the a2wl.dat is corrupted message in the History every time mine updates via the auto-update function, so it looks like it's not related to manual updates ?

I'm also running 5.1.0.1331 after doing a manual upgrade from whatever the previous was (?) so maybe it's the corrupt file is related to this ?

Share this post


Link to post
Share on other sites

I'm having the same issue.

Yesterday I received both the "Bad Gateway" and the "a2wl.dat is corrupted" error messages for several times.

I use the daily auto-update function, however, this morning same result also with manual updates. The only exception is this new error message:

Created: 25/09/2011 11.19.20*

Summary: Automatic Update failed

Description: OA: Wrong response format

Event type: Auto update(11)

Event action: None(1)

*Italian time

------

Win XP Pro SP3

Online Armor Free 5.1.0.1331

Avast! Free AV 6.0.1289

Share this post


Link to post
Share on other sites

Well, I am relieved to see that I am not the only one with update problems. I find that I can now get to online-armor.com, but that doesn't really help me very much in terms of getting updates...

I tried updating signatures and rules manually just now (Sunday AM), and the update failed again, but this time I am getting a different message: "OA: Access violation at address 5B1AF53B in module OAui.exe. Read of address 00000000". I have no idea what that even means, unless my firewall is misinterpreting the updates as a threat and blocking them.

I don't really want to turn on automatic updates to get sigs and rules, because I might also get automatically updated to the new version of the OA firewall, which I'm not ready to do yet, and from the posts above, it doesn't appear that having the new version makes the manual updating problem any better.

Also, I'm not sure this is related, but today my History shows some sort of "kernel event" which says: OADriver: PostMessage, Msg: 49475/c143 3784 -> 3044, Deny (protected)

Yesterday, there was also a different "kernel event": OADriver: PostMessage, Msg: 49450/c12a 1700 -> 804, Deny (protected)

I have not seen the one about the corrupted file that others reported, though.

Share this post


Link to post
Share on other sites

Tried to update again--this time OA says it is up to date, and there were no error messages and no update failure message in the history. It didn't seem to DO very much in the way of downloading and installing, but since it says it is up to date, I'll take that as a positive sign! Maybe there weren't many changes in the sigs and defs. Has everyone else gotten updated?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.