Sign in to follow this  
Jose_Lisbon

Emsisoft Anti-Malware not recognized by the Windows Action Center

Recommended Posts

After uninstalling Avast with its unistalling tool in safe mode I produced to install EAM 6.

It didn't turn on File Guard, it wouldn't do it.

I rebooted twice, to no avail.

I uninstalled and reinstalled EAM (with the usual reboots); all was on but... Windows didn't (doesn't) recognise the program.

It's been three hours now, and I'm yet to understand what is wrong (it's not my machine, please don't ask).

I don't mind wasting time but... I mind wasting time like this.

P.S. after another reboot Windows says there's no AV or AS on the horizon... nice

P.P.S. EAM's two processes (is it two?) are consuming less than 3 MB ram, and no CPU at all.

I'm leaving...

Share this post


Link to post
Share on other sites

I have had this problem from time to time with Windows 7 action center.

You will find that EAM is actually running it's just not communicating with Action Center.

You can verify this by opening EAM and turning off all scanners (file guard, behavior blocker, and surf protection) at which point Action Center will complain that EAM is not on (even though it just complained it wasn't on when it was).

To fix it leave all 3 unchecked and close the EAM interface, then click the warning in Action Center... this will allow action center to turn on file guard, behavior blocker and surf protections, and sync the "state" properly.

If you get a popup about trusting EAM I usually check the box to always remember, and press YES which seems to fix it for some time.

I do see it come back now and again... but EAM is never really off... Action Center just thinks it is.

(PS: I don't understand the logic of leaving because the processes are now smaller and using less resources than ever ;) )

Good Luck.

Share this post


Link to post
Share on other sites

There is a chance that your WMI repositories were damaged. You can try to reset your database using the following steps:

  1. Go to your "Control Panel" and open "System and Security"/"Administrative Tools".
  2. Open "Services".
  3. There please stop the following services by right clicking their entries and selecting "Stop":
    Emsisoft Anti-Malware 6.0	
    Windows Managament Instrumentation	
    


  4. Make sure that the "Startup Type" for both services is set to "Automatic".
  5. Then go to the "C:\Windows\System32\wbem" folder and delete the "Repository" sub-folder there.
  6. Reboot.

Windows will now rebuild your WMI repository during the reboot which should allow Emsisoft Anti-Malware to register correctly.

Share this post


Link to post
Share on other sites

Hi.

I uninstalled EAM right after my first post and reinstalled Avast.

This afternoon, after reading your answers (thanks for that), I installed EAM again, this time just disabled Avast. Everything is fine.

I'm yet to decide if I'll buy a licence. Not that the quality of the product is in question. It is, arguably, the best AV solution out there.

I'm just not sure, considering I browse 99.9% ot the time inside Sandboxie, if I need to pay for a security app.

Anyway... right now it's running at bellow 5MB (is that normal...?) with no impact on browsing.

Languy99 tested it

with excelent results (the quiz at the end of the video is of highly questionable pertinence and leaves a sour taste in the mouth, but that's only a personal opinion).

Overall, congratulations for a top notch program.

Jose.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.