Jump to content

Visual Studio IDE unable to connect to helplibagent.exe

Recommended Posts

Hi there,

when I press F1 in Visual studio to get context sensitive help, it tries to start a process called HelpLibAgent.exe to handle the help request. From what I can gather, it passes these help requests via http on to the help agent which then displays the relevant help topic.

The problem is that Online Armor is blocking this communication attempt. I have added the HelpLibAgent.exe into the firewall rules, even allowing in and out traffic on all ports. I have tried to allow all traffic on 47873 to any program to be passed through. Nothing has helped. There are no blocking messages in the History.

If I shut down Online Armor, there is no problem with pressing F1 and getting help, and once the Help Library Agent is up and running, I can restart Online Armor and provided I do not shut down the agent, help works as expected and the communication on continues. If I close down the agent, I am back where I started.

Is there anybody out there who uses Visual Studio with local help and Online Armor and can get the help to work?

Link to post
Share on other sites

Hello Jorg,

as far as i know this is not a known problem of Online Armor.

Please, can you provide a little bit more information about which product edition (exact product version number) and operating system you are using.


Does "tries to start a process called HelpLibAgent.exe" means, that the process is not starting at all ?

No error message, no pop-up and not window (e.g. from Internet Explorer) is opening ?

You are using Visual Studio 2010 right ? Which Browser are you using for viewing the help ?

Do you have already checked if it maybe is a known issue of the Help System from Visual Studio ?

You can find the "Help System Readme" from Visual Studio 2010 in the .

(e.g. there is an issue when "port 47873 is used by another process")

I also found a F.A.Q. on the internet which could help for some problems like,

"Agent keeps crashing" or you are "unable to access localhost".

Link to post
Share on other sites

Hi Thomas,

I am running Online Armor Premium on a Win 7 64-bit system with all the current updates applied to it. I also run Anti-Malware I believe both are the current products.

I am using Visual C++ 2010 which has the option of viewing help files online or local help files. If I set the option for online, there is no problem. It fires up Chrome and displays the help online. I prefer the local help though, so I set the help system for local help files. Thus when I activate the help by pressing F1, VC++ tries to launch a program called HelpLibAgent.exe which is part of the Microsoft supplied Help Viewer V1.0. This local help does not use a browser, it is a custom written Microsoft program to navigate through locally installed help files from Microsoft.

When HelpLibAgent.exe starts, it throws a popup error window stating :

The Help Agent is not be able to attach and use the requested port due to incorrect security settings. To correct the http.sys ACL settings it is necessary to run the following http.sys configurtion command from an admin elevated command line. netsh http add urlacl url=http"//"[port]/help/ sddl=D:(A;;GX;;;WD)

Then when I click on OK (the only option I have), the popup disappears and the program exits. If I try to run the program manually, ie. go to its directory and fire it up without using Visual C++, exactly the same thing happens. Thus this has nothing to do with Visual Studio. The HelpLibAgent program refuses to start, irrespective of how it is invoked. Firing up the HlpViewer.exe program has the same result. It tries to start HelpLibAgent and produces the error.

I tried using several other ports as suggested in the Help System Readme.zip file you included in your response (just in case 47873 was used, but there was no change to the problem. The same error message each time. As part of the error testing I even temporarily allowed all ports to be allowed to access all programs for input and output on both TCP and UDP in the OA Firewall settings. Again no difference.

The only way I can get the HelpLibAgent to start is by shutting down OA. Then it fires up without any problem at all, if OA is not running. Once it is running, I can start OA again, and as long as the HelpLibAgent runs in the background, I can invoke local help from VC++ by pressing F1. If I shut down the HelpLibAgent, I am back in the same boat as before.

This makes me believe that there is no conflict with port 47873, unless just per chance, OA uses that port for internal purposes and thus has it locked and no other program can use it.

I hope this helps. I guess I can could send you the HelpLibAgent to see if you have the same problem if you can't advise me on what could be the problem.

Link to post
Share on other sites

Just to confirm it is not just port 47873, I changed the port to 47888 via the registry key setting as described in the readme file, the same error occurred and once I shut down OA, it instantly worked and is using 47888, so unless OA uses both 47873 and 47888 internally, there is no conflict.

Link to post
Share on other sites

Ok, thank you for testing.

Strange, I use Windows 7 Ultimate 32bit with the same EAM and OA versions you are using,

have installed Visual Studio 2010 and decided to use the local help when I installed it.

When I press F1 while in the source code, my standard browser (Chrome) opens a page,

starting with the address

I am offline so I use the local help. When I kill the process "HelpLibAgent.exe" and try to use local help again,

it takes a longer time because the process needs to be started again, but it works fine.

Online Armor was running the whole time when I was testing.

Maybe we are able to track down the problem when we take a look at your firewall log.

Would you be so kind to gather that information and attach it here in the forum ?

(You can use the Button "More Reply Options" at the right bottom of the screen)

To enable the firewall logging please follow these steps:

1. Open Online Armor.

2. Choose "Options" from the left hand menu

3. Select the "Firewall" tab.

4. You can enable and disable logs by enabling or disabling the "Enable logging" check box.

5. Finally as default logging level please choose "All activity"

Try to use the local help from Visual C++ as you would do normally.

When you have reproduced the situation you can show the log by clicking the right mouse button on the Online Armor symbol and choose "Show Firewall Log..."

Now please just copy and paste the log entries, put them into a text file and post it here, if this is ok for you.

Link to post
Share on other sites

Hi Thomas,

sorry for the slight delay in getting back to you. I did 2 logging sessions, first without "Additional debug info" and then with it. I am no log expert, but I could not see anything in there showing me that the helper agent is trying access a port and is then rejected. I believe that because I get the error irrespective of whether I use VC++ or not in order to start the helper, it is solely a helper problem.

I also use Chrome as my default browser, but the Helper agent does not look to me as though it uses Chrome to display the help that it interfaces too, but is uses HlpViewer.exe, at least that is the program I see in task manager when I see the help. So on my system when I press F1 in VC++ to activate the context sensitive help, HelpLibAgent is started if it is not already running and then HlpViewer displays the help information.

And while OA is running, I can't convince HelpLibAgent to run as it displays an error box and then shuts down after I acknowledge it.

Anyway, here is the log file. I hope it helps, but I can't see anything in there. The .73 ip address is the machine with OA and VC++, the other local ip addresses are valid machine ip's on my local network. I checked them out.


P.S. I just pressed Attach This File twice, but there is still a message that says 0bytes of your 250MB used. Not sure if it only counts in MB and the file is tiny, so either you end up with none, because it did not work, or I ended up passing 2 to you.

Link to post
Share on other sites

Hello Jorg,

thanks for the log file.

I had a look at it but can't find an evidence that online armor is blocking something.

I will try to find out more about what could be the problem.

If you are sure that your system is not infected, may you want to give it a try and start the HelpLibAgent.exe one time,

when Online Armor is in Learning Mode. In Learning Mode, Online Armor monitors all programs to see how they behave and automatically creates rules to allow these behaviors. (Don't forget to immediately turn Learning Mode off when you have finished the test!)

Link to post
Share on other sites

Hello Jorg,

when I asked you for help by providing the log file I forgot to tell you

that the checkbox "Intercept loopback interface" shouldn't be checked when logging. (Options -> Firewall)

May you want to give it a second try and send me the files per PM ?

Please check if there maybe is a program/firewall rule created which prevents the helper from starting.

The next step could be to create Online Armor debug logs.

You can also send the result per PM to me.

(Here you can find out how to enable/disable debug logs)

Link to post
Share on other sites

Hi Thomas,

sadly the learning mode did not do anything different, and I have included the log file with loop back turned off. Once again, I can't see anything useful in there.

I have also run a debug log session, but I can't understand the debug file at all, it does not seem to be an ascii file. I am going to PM it to you after I send this message.

Link to post
Share on other sites

I was also facing the same issue. I also thought that issue was Firewall or Antivirus restriction. But after investigtaion I found that... Mine issue was system running using IPV6 in place of IPV4 and system was recognizing [::1] in place of, so made an entry in system (using Admin priviledge)

netsh http add urlacl url=http://[::1]:47873/help/ sddl=D:(A;;GX;;;WD)

Check the forum http://social.technet.microsoft.com/wiki/contents/articles/3711.aspx for the reference.

Hope it might be of some help.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...