Cubittus

Update to 5.5 fails due to corrupt file (and also licence missing)

8 posts in this topic

I've just started getting errors pop up in OA when it tries to update itself. I'm currently on version 5.1.1.1395, on WinXP SP3. My AV is Eset NOD32 4.2.71.2, and both are working together just fine (appropriate exclusions are in place so they don't conflict).

This is the event log entry for the update failure:

Created: 2012-02-09 01:22:08

Summary: Automatic Update failed

Description: OA: File help_ena.chm is corrupted

Event type: Auto update(11)

Event action: None(1)

Also, within OA my licence is showing up fine. I just renewed a couple of weeks ago.

However the licence is now no longer appearing in the Customer Center web page.

I read another post about this and tried to register my key (I still have the email from the renewal) but it says this:

ERROR: The license key you entered does not exist or is already registered with another user account.

Please note, that the key printed on your purchase documents might be different to the one that the software displays. Please enter the key that is displayed in the licenses dialog of the software only.

Online armor 5.1 just tells me how long my licence has left, it doesn't show the key.

What's going on?

0

Share this post


Link to post
Share on other sites
:) Go to the service centre-license-manager-Can't see your license key? Please register your license key here-select OА from the drop-down menu,insert the key- registration.After this your new register and will be visible in the service center.....and http://support.emsis...dpost__p__43820
0

Share this post


Link to post
Share on other sites

What's going on?

The most likely cause is a problem with the Windows Crypto API on your system. We fixed that issue in the new Online Armor 5.5 version. I would suggest you download a new Online Armor setup and perform an upgrade installation instead. This will upgrade Online Armor to version 5.5 while preserving all your settings and rules.

0

Share this post


Link to post
Share on other sites

I downloaded the installer and ran the upgrade install. All seems to be working just fine now. The built-in updater also runs correctly.

Also, the Customer Center page now accepts my licence key - the exact same key it wouldn't accept yesterday!? Is this because I had to actually run OA 5.5 before the key could be registered?

Also, you mention a problem with Windows Crypto API on my system. I've not experienced any other problems that may be related to this service. Could you provide more details on how I can fix this or determine if there is an actual problem in my system? (Or might you actually mean that it was a OA bug related to the Crypto service?)

Thanks

0

Share this post


Link to post
Share on other sites

Also, the Customer Center page now accepts my licence key - the exact same key it wouldn't accept yesterday!? Is this because I had to actually run OA 5.5 before the key could be registered?

Correct. The Emsisoft customer center only recognizes keys that have been converted from the old licensing system to the new one. Conversion is performed when you install or update to version 5.5. So essentially you must have put in your key at least once in Online Armor 5.5 so that the customer center is able to see it.

Could you provide more details on how I can fix this or determine if there is an actual problem in my system?

Microsoft doesn't expect the crypto chain to break so there is no official way to repair it. If you are not experiencing any other problems with your installed applications I would simply ignore it. Online Armor used to use some rarely used functions inside the Windows Crypto API that is causing trouble if the Windows Crypto API isn't working 100% correctly. I doubt there will be much more applications that use it the same way. So more than likely you won't have any trouble in the future if you don't have them now.

0

Share this post


Link to post
Share on other sites

Microsoft doesn't expect the crypto chain to break so there is no official way to repair it. If you are not experiencing any other problems with your installed applications I would simply ignore it. Online Armor used to use some rarely used functions inside the Windows Crypto API that is causing trouble if the Windows Crypto API isn't working 100% correctly. I doubt there will be much more applications that use it the same way. So more than likely you won't have any trouble in the future if you don't have them now.

OK thanks. I'll keep my fingers crossed.

Another quick question related to licences. Later this year I expect to build a new PC and migrate to Windows 7. I'll want to migrate my software onto the new PC and will be decomissioning the old one.

I seem to remember that the old OA licence page had an option to free up a licence from one PC in order to install it on another. I can't see this option on the new Customer Center pages.

How would I go about doing this?

Thanks again.

0

Share this post


Link to post
Share on other sites
Another quick question related to licences. Later this year I expect to build a new PC and migrate to Windows 7. I'll want to migrate my software onto the new PC and will be decomissioning the old one.

I seem to remember that the old OA licence page had an option to free up a licence from one PC in order to install it on another. I can't see this option on the new Customer Center pages.

How would I go about doing this?

That function is obsolete with the transition from the old Online Armor licensing system to the Emsisoft licensing system. Essentially when you type in your key on your new machine and you don't have any licenses left on that key it will ask you whether or not you want to reassign the license from your old machine to the new one. This can be done up to 3 times in any 24 hour time frame.

0

Share this post


Link to post
Share on other sites

That function is obsolete with the transition from the old Online Armor licensing system to the Emsisoft licensing system. Essentially when you type in your key on your new machine and you don't have any licenses left on that key it will ask you whether or not you want to reassign the license from your old machine to the new one. This can be done up to 3 times in any 24 hour time frame.

That's perfect! Thanks!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.