Sign in to follow this  
Pedro59

Online Armor blocking all programs at startup

Recommended Posts

Can someone possibly help with this problem.

I turned the computer on and checked for and installed the latest Windows Defender Definitions. KB915597 and possibly allowed a flashplayer installer

When tried to open any program I get the message:

‘Windows cannot access the specified device, path or file. You may not have the appropriate permissions to access them.

I could select ‘Run as Administrator’ the program opened and ran OK.

The programs which would normally be shown at the bottom RH of the task bar i.e. Anti-Virus, Firewall etc. did not appear to be running.

I did a system restore to before the Windows Defender update which gave no improvement.

After an expensive check by a technician the problem corrected by uninstalling Online Armor.

Should I take the chance of reinstalling Online Armor?

Toshiba Sattellite A300 Windows 7 Home premium

Share this post


Link to post
Share on other sites

Should I take the chance of reinstalling Online Armor?

There have been a couple of reports of similar problems after Windows Updates on Win 7. Please try enabling Learning mode before installing Windows Updates, then reboot and switch Learning mode off again after your desktop has loaded and this should avoid a recurrence of the issue.

Share this post


Link to post
Share on other sites

I have reinstalled OA and installed 6 Windows updates after putting OA into learning mode.

I did not have a repeat of the program blocking.

My technician has had a similar problem with a customers PC.

Is there an easier fix if a problem occurs such as starting OA as admisitrator and enabling learning mode rather than uninstalling and reinstalling OA?

Share this post


Link to post
Share on other sites

Is there an easier fix if a problem occurs such as starting OA as admisitrator and enabling learning mode rather than uninstalling and reinstalling OA?

You could try this. If you able to open OA's GUI you could also just check History to see what has been blocked and then Allow it manually.

Share this post


Link to post
Share on other sites

Cat Princess

I ran into this problem again. My fault, I was doing a windows update after an operating system reload and forgot to enable learning mode.

As per your previous advice i checked the GUI history tab and found a large number of files blocked. I was unable to allow them but recovered by clearing history.

When I tried to open several programs I was asked to allow a file C:\windows\system32\audiodg.exe.

I have been asked to allow C:\windows\system32\sppsvc.exe which will allow slui.exe (Process ID = 1612) I have allowed this file.

All seems to be OK now but I will provide further detail in a few days.

Regards

Pedro59

Share this post


Link to post
Share on other sites

Hi Pedro,

Since it sounds like you can access OA's GUI okay, if you have further issues with these files being blocked you might try enabling Learning mode and then rebooting. This should allow OA to sort things out at the next reboot and you can then take it out of Learning mode.

Share this post


Link to post
Share on other sites

Cat Princess

Is this still a problem with Windows updates and OA on Windows7? I have been switching to learning mode before installing Windows updates and have not had a problem but would prefer not to do so.

Has any change been made to OA to overcome this?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.