madith

putative incompatibility with Database .NET

Recommended Posts

Hi,

i've been trying to run Database .NET in its previous versions 6.4.4511, can be downloaded here: http://fishcodelib.com/Database.htm, on a T520 Lenovo notebook with Win 7 Pro x64, running Online Armor v5.5.0.1557 and ESET NOD v5.0.95.0.

It would show the splash screen of the program, but then terminate with an error message.

Please see my email communication with the developer below, who suggested asking the support here for a suggestion. (at the time of that email

Let it be said, that in the meantime I was able to run Database .NET with the same version of Online Armor and ESET NOD on a Win 7 Pro x32 without problems, still no luck with x64 though.

Hi!

I have reproduce the issue on Win7 x64 with Armor

It is a bug of the Armor firewall.

I think the issue ONLY appear on Win "X64" with Armor.(same as the Avast 5.x)

You can select "Close and Shutdown Online Armor" and Run Database4.exe again.

You also can report the issue to the Armor support: http://support.emsisoft.com/

fish

-----Original Message-----

From: <snip> [mailto: <snip>]

Sent: Wednesday, May 09, 2012 4:53 PM

To: fish

Subject: Re: RE: fish's dotNET:Feedback

Hi,

considering your advice I have tried the following:

1) Temporarily disable protection features of my antivirus software (ESET NOD32 v5.x - current version)

2) Disable my firewall (Online Armor v5.5 - current version)

3) both 1) and 2)

In the case of 2) and 3) I can now see the Database. NET splash screen, but it then stops working and launches the windows error reporting system.

i see the following two errors logged in the system events:

Faulting application name: Database4.exe, version: 6.4.4511.20089, time stamp: 0x00000030 Faulting module name: KERNELBASE.dll, version: 6.1.7601.17651, time stamp: 0x4e211319 Exception code: 0xe0434352 Fault offset: 0x0000b9bc Faulting process id: 0x1dec Faulting application start time: 0x01cd2dc0710df22c Faulting application path: C:\DatabaseNet4\Database4.exe Faulting module path: C:\Windows\syswow64\KERNELBASE.dll

Report Id: af71c702-99b3-11e1-858a-005056c00008

Application: Database4.exe

Framework Version: v4.0.30319

Description: The process was terminated due to an unhandled exception.

Exception Info: System.InvalidOperationException

Stack:

at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.DoApplicationModel()

at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.Run(System.String[])

at My.ӷ.Ӹ(System.String[])

i have tried using the program on a friend's computer and it works fine there. it uses avir antivir personal (most current version) and online armor (same version as mine), though it is a win7 pro 32bit version.

any other hint ?

thank you for your time, i really appreciate it.

Best,

Madith

-------- Original-Nachricht --------

> Datum: Wed, 9 May 2012 07:50:09 +0800

> Von: <snip>

> An: <snip>

> Betreff: RE: fish\'s dotNET:Feedback

> Hi!

>

> Database .NET supports Windows x64 and x86 (Known issue) Database .NET

> does not work on Windows x64 with "Avast 5.1"(It is a bug of

> Avast)

> you can upgrade to 6.x to resolve the issue

>

> If this is not the problem please let me know...

>

> fish

>

> -----Original Message-----

> From: <snip> [mailto: <snip>]

> Sent: Tuesday, May 08, 2012 11:51 PM

> To: <snip>

> Subject: fish's dotNET:Feedback

>

> Hi,

>

> it seems, that I am not able to start Database .NET and I wonder, if

> you might be able to lend me a hand in figuring out why that is ?

> I am running Windows 7 Pro 64 bit on a Lenovo T520 notebook. .NET

> framework v4.0 is installed (64 bit) and all current updates are

> installed. When start the program, it appears in the process list, and

> then quits and I find the following application error in the System Event Viewer.

>

> Faulting application name: Database4.exe, version: 6.4.4511.20089,

> time

> stamp: 0x00000031 Faulting module name: unknown, version: 0.0.0.0,

> time

> stamp: 0x00000000 Exception code: 0xc0000005 Fault offset: 0x00000000

> Faulting process id: 0x1f14 Faulting application start time:

> 0x01cd2d2155bdd77d Faulting application path: C:\DatabaseNet4\Database4.exe Faulting module path:

> unknown Report Id: 9386f2e0-9914-11e1-840f-005056c00008

>

> Do you have any idea, what might be the problem there?

>

> Best Regards,

> Madith Hamran

Share this post


Link to post
Share on other sites

Here are some instructions on adding this program's folder to the Exclusions list in Online Armor:

  1. Click on the 'Start' button, go to "All Programs", go to "Online Armor", and click on the Online Armor icon to open it.
  2. Click on 'Options' in the menu on the left.
  3. Go to the 'Exclusions' tab.
  4. Click on the 'Add' button.
  5. Use the little [+] and [-] icons to the left of folder names to open and close them, find the folder that you wish to add to the exclusions list, click on it to highlight it, and then click 'OK' at the bottom. The folder you are looking for is most likely C:\DatabaseNet4
  6. Close the Online Armor window.

Share this post


Link to post
Share on other sites

Hi again,

sorry for the long delay of this answer.

@GT500:

Thank you for your advice. I followed your instructions, but I still could not get the software to run.

I did some testings on my own afterwards and I experienced the following:

1. Database .NET does run on a clean install of Win x64.

2. It cannot be run at all with Online Armor v5.0 or higher installed - don't know about earlier versions though. The program appears in the task list for a while and then terminates with Windows error reporting tool popping up.

3. Adding the containing folder of Database .NET and its working path (incl. subfolders) to the exceptions list in Online Armor let's the application show the splash screen and then terminate as under 2.

4. Uninstalling Online Armor is not resolving the issue, as I would have expected.

5. This behaviour is only experienced on Win x64, on the x32 system it runs fine even alongside Online Armor.

6. For fun I tried the same steps on a virtual machine on another computer - same results.

Do you have any further suggestions ?

Share this post


Link to post
Share on other sites

Could you please try excluding the foloder of the program in OA, rebooting and running the program again?

I already did that. Sorry for not including it in the descriptions above. I tried to run the software in 3. and 4. as listed above before and after reboot, yet no difference observed.

Share this post


Link to post
Share on other sites

OK, we'll probably need some logs to see what the problem is. Open Online Armor, go to Options in the menu on the left, click the little check box to enable debug mode (just above the Run Safety Check Wizard, restart your computer, and then try running your Database .NET program. After the program terminates, please ZIP your entire logs folder (normally C:\Program Files\Online Armor\Logs), upload it to RapidShare, and then copy and paste the link to download the file into a reply (or you can send it to me in a Private Message if you don't want the link posted publicly on the forums). Note that, if you don't have a utility such as 7-Zip, WinZip, or WinRar that you can ZIP files and folders by right-clicking on them, going to Send To, and clicking on Compressed (zipped) Folder.

Share this post


Link to post
Share on other sites

The logs aren't showing that you restarted your computer after adding the exclusions. Could you go ahead and turn off debug mode, restart your computer, delete the logs folder, and then turn on debug mode again, restart again, add exclusions again, and then restart again and send us the logs after that?

Share this post


Link to post
Share on other sites

Hello madith,

Could you please make sure that Database4.exe file is marked as "Trusted" (green) at OA Configuration->Programs page?

If the executable is marked "Trusted" the issue is not reproducible.

Share this post


Link to post
Share on other sites

Hi,

the Program Guard and HIPS features were disabled, when I tried to run this - just wanted to be sure there. So adding it to the list shouldn't make a difference there, should it ? - I tried it anyways now, but still no success.

Is there any hint in the logs, that there is some unusual behaviour from Online Armor in this ? - I mean, I'm still not entirely sure, that the firewall is the actual culprit here, but it's my best guess, since two separate physical machines and a virtual machine in one of these won't run Database .NET on a x64 Win7, when Online Armor is installed. And one of the PCs and the VM run it just fine, when there's no Online Armor on.

Share this post


Link to post
Share on other sites

I was able to reproduce the issue and, as soon as I'll find the source of the problem - I'll get it fixed.

However, the problem should not occur if the oawatch.dll wouldn't be loaded into the Database4.exe process.

(This can be achieved by excluding the folder the database4.exe located at and rebooting.)

Could you please try reproducing the issue having HIPS features of OA enabled and the folder the database4.exe located at excluded in OA ?

Thank you in advance,

Share this post


Link to post
Share on other sites

Hi,

sorry for the long silence, it seems the issue is solved now.

I could not verify, if this is due to an update in Online Armor or due to an update in the Database .NET application. However, as of version OA 5.5.0.1616 and Database .NET v7.0 there are no glitches in starting and operating this piece of software anymore.

Thank you for your time in trying to help me out.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.