Jump to content

Online Armor prevents Skype to access the internet


Recommended Posts

Hi All,

Online Armor is starting to mess with my nerves once again (twice again, actually).

Since the latest update of Skype (it updated itself), Online Armor prevents it from signing in.

What has happened is that Skype updated itself, and then Online Armor just continuously (read it showed a new dialog immediately after pressing Allow) asked me whether I want to allow Skype to connect to the internet because it did not recognize it, After a seemingly endless series of this dialog (I have pressed Allow for at least 30 times) I pressed Block to end this farce. Since then Skype is not able to sign in.

I tried to take back the setting Online Armor recorded for it, but I can't find it. The application is marked as Allowed and Trusted (I even untrusted and trusted it again), but still Skype is not able to sign in anymore.

It is 100% that it is Onine Armor preventing it, because when I shutdown OA and started Skype again, it was able to sign in immediately. Then after restarting OA and then Skype, Skype was again unable to sign in thereafter.

Please install Skype versions properly in the applications database and bring out a fix which solves this issue.

Also, when I installed Office 2010 it just hit me with a few hundred of do I want to allow this and that autostart to run with garbage like program names, and such program names and paths now pollute my Programs and Autoruns list.

I don't think Office 2010 and Skype would be so niche programs that Online Armor should not be able to support them properly, for God's sake. Make a proper application recognition routine for Autoruns installed by Microsoft Office components and clean up that crap which most likely resides in every Office users Programs/Autoruns list.

I use Online Armor paying version 5.5.0.1616, latest updates (I explicitly updated during trying to fix the Skype issue) and Windows 7 SP1 Professional 64 bit.

The Office problem I have seen with several versions of Office (it happened also with Office 2003 on Windows XP).

Best regards,

Robert

Link to post
Share on other sites

Hi Robert,

Do you see any blocked (red) entries in Firewall > Programs or Firewall -> Ports for Skype?

Thanks, so that is where the culprit was... Ports had some deny settings... programs had it on Allowed and Trusted. After changing the Port entries to Allow, Skype works fine now. Don't understand why that loop with the dialog happened, though.

Any idea about my other question: what to do with all the rubbish looking entries in Autorun/Programs which were added when I installed Office 2010?

Thanks and best regards,

Robert

Link to post
Share on other sites

All those "Allow or block ?"-questions when installing fx. Office 2010 is an "old" problem...

But there is an easy fix for that, turn off OA´s Program shield before you run the installer, then turn Program shield on again when the installation has finished.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...