Jump to content

Online Armor 6.0.0.1736 OASrv.exe 25% CPU usage (=freeze)


Hanziness
 Share

Recommended Posts

Hi! I've never had such problems with Online Armor since today. When I started GameMaker 8.1, it didn't start and when I checked Task Manager, OASrv.exe was using 25% of my CPU (I have a Core i5 processor - 4 cores). Sometimes it asks for any unknown programs but sometimes not and it keeps hanging. What should I do? I have already reinstalled it and the problem is still present.

I just tried to start GameMaker's uninstaller and the OASrv.exe CPU usage went to 25% again and it won't reduce, I have to restart the system to solve it (temporary!)

NOTE: I can browse the internet etc. but if I try to start an unknown program (like a game that hasn't got a rule yet) OA won't ask me what to do and I can't do anything with it.

NOTE #2: When I start updating OA from the UI, it freezes

NOTE #3: OA can still ask me about some programs but it keeps using 25% of my CPU.

Thank you very much in advance.

Hanziness

Link to comment
Share on other sites

Hello! Of course, here you are:

I'm using Online Armor Free 6.0.0.1736 on a 32-bit Windows 7 Professional without service packs [hu]. I am using OA along with avast! Internet Security (OA is excluded from avast!'s File Shield and avast! is excluded from OA's protection)

The case when this happens: on some program starts. Mostly OA asks me what to do with certain programs, but for example, when I started Game Maker or The Elder Scrolls V: Skyrim (TESV.exe), OA's CPU usage jumped to 25% (one full core on my CPU) and didn't give me any warnings. I tried to shut it down trough OA's interface but OAsrv.exe didn't close and when I started oaui.exe again, it just stayed there with a "Synchronizing" message. Each time this happens I have to restart the entire system because a "log off-log on" won't work. This hasn't happened when I was using OA version 5.x. Currently I have 4 exclusions (avast!, Intel drivers, Skyrim and Game Maker). I've got NVIDIA Graphic Drivers installed but I haven't experienced problems with drivers.

I'm going to submit a bug report of course...

Link to comment
Share on other sites

Hello! Of course, here you are:

I'm using Online Armor Free 6.0.0.1736 on a 32-bit Windows 7 Professional without service packs [hu]. I am using OA along with avast! Internet Security (OA is excluded from avast!'s File Shield and avast! is excluded from OA's protection)

.

Doesn't Avast Internet Security come with its own firewall? I can see from your post that you're using OA Free, I'd tend to believe that you have currently two different firewalls installed on your system...

Link to comment
Share on other sites

Well, the funny thing is that it's not the FIREWALLS that conflict! There's nothing network-related in Skyrim's executable, I think. It's the program guard, and I'm pretty sure that avast!'s firewall won't stop OA from checking/opening TESV.exe. I have also unchecked going online to check whether a file is safe in OA's settings. And of course avast!'s firewall won't block OA from accessing the internet because it's set to allow every connection on every port from OA's components.

Note: I haven't had such problems with OA and avast! IS since OA's latest update.

Currently I'm downloading Windows 7 SP1. I don't know why it is necessary as I haven't had such problems with OA before, anyway it's worth a try.

EDIT: In the first post I said OA freezes when I try to update it: it only freezes when OAsrv.exe has a 25% CPU usage - it's set to auto update and it's working.

Link to comment
Share on other sites

  • 1 month later...

Avast! Firewall disabled (unfortunately I can't uninstall it) and Win7 Service Pack 1 with all updates installed --> problem is still appearing. I just tried opening a file with QuickTime Player and OASrv.exe "froze" - again -, clicking on the notification icon won't do anything..

Link to comment
Share on other sites

Avast! Firewall disabled (unfortunately I can't uninstall it) and Win7 Service Pack 1 with all updates installed --> problem is still appearing. I just tried opening a file with QuickTime Player and OASrv.exe "froze" - again -, clicking on the notification icon won't do anything..

 

What I often did was a customized installation of avast Internet Security and with that disabling the Firewall component (just to be sure it would work without conflicts). If I am right you can still do this by going into "Programs and Features" and then click on the avast program and press uninstall. This should give you a pop-up menu of the program where you can change/repair/uninstall Avast. Deselecting the Firewall module under change would then uninstall the firewall. I do not know however if this would reset the other avast settings.

Link to comment
Share on other sites

Didn't help, OA keeps doing the same thing when specific programs start :(

 

EDIT: This time it "froze" when I started uninstalling the Autodesk 3DS Max 2013 FBX plug-in. The UAC dialogue popped up and I clicked 'Yes', and then OASrv.exe CPU usage jumped to 25% and it doesn't want to do anything until I restart the computer...

Link to comment
Share on other sites

Didn't help, OA keeps doing the same thing when specific programs start :(

 

EDIT: This time it "froze" when I started uninstalling the Autodesk 3DS Max 2013 FBX plug-in. The UAC dialogue popped up and I clicked 'Yes', and then OASrv.exe CPU usage jumped to 25% and it doesn't want to do anything until I restart the computer...

Could you please try the beta version available at http://changeblog.emsisoft.com/2012/12/03/beta-updates-2012-12-03/ ?

(Clean install please)

 

Can't say for sure without logs, but it seems that the problem you encounter is like the one I've fixed in regards to hanging uninstallers.

 

Thank you in advance,

 
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...